Kernel panic after installing wifi drivers for ax1650 on latest 4.19.84-1 kernel

Hi,
Running on an XPS 7590 here.
I had Manjaro running well for the past few months, I just had to compile and install drivers manually for the killer ax1650 card, as mentioned on https://wiki.archlinux.org/index.php/Dell_XPS_15_7590 and some tweaks as well.
After the last update ( [Stable Update] 2019-11-14), I restarted, everything look OK except WiFi is not working, I recompiled and installed the drivers like I did the last few updates.
After the restart and logging in (when KDE tried to reconnect to the saved WiFi), system freezes completely and caps lock blinking, tried reinstalling, but it's the same.
System info below:

$  inxi -Fxxxz
System:    Host: diaa-XPS Kernel: 4.14.154-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 Desktop: KDE Plasma 5.17.3 
           tk: Qt 5.13.2 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: Dell product: XPS 15 7590 v: N/A serial: <filter> Chassis: type: 10 serial: <filter> 
           Mobo: Dell model: 0VYV0G v: A00 serial: <filter> UEFI: Dell v: 1.2.3 date: 07/23/2019 
Battery:   ID-1: BAT0 charge: 54.3 Wh condition: 93.3/97.0 Wh (96%) volts: 11.6/11.4 model: SMP DELL GPM0365 type: Li-ion 
           serial: <filter> status: Unknown 
CPU:       Topology: 6-Core model: Intel Core i7-9750H bits: 64 type: MT MCP arch: Kaby Lake rev: A L2 cache: 12.0 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 62232 
           Speed: 800 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 800 2: 801 3: 801 4: 800 5: 800 6: 801 7: 800 8: 800 
           9: 802 10: 800 11: 800 12: 800 
Graphics:  Device-1: Intel UHD Graphics 630 vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:3e9b 
           Device-2: NVIDIA vendor: Dell driver: nvidia v: 430.64 bus ID: 01:00.0 chip ID: 10de:1f91 
           Display: x11 server: X.Org 1.20.5 driver: intel,modesetting compositor: kwin_x11 resolution: 3840x2160~60Hz 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 630 (Coffeelake 3x8 GT2) v: 4.5 Mesa 19.2.4 compat-v: 3.0 
           direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           chip ID: 8086:a348 
           Sound Server: ALSA v: k4.14.154-1-MANJARO 
Network:   Device-1: Intel Wi-Fi 6 AX200 vendor: Bigfoot Networks driver: N/A port: 3000 bus ID: 3b:00.0 chip ID: 8086:2723 
           Device-2: Samsung GT-I9070 (network tethering USB debugging enabled) type: USB driver: rndis_host bus ID: 1-5:18 
           chip ID: 04e8:6864 serial: <filter> 
           IF: enp0s20f0u5 state: unknown speed: N/A duplex: N/A mac: <filter> 
           Device-3: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152 bus ID: 2-2.3:6 chip ID: 0bda:8153 
           serial: <filter> 
           IF: enp0s20f0u2u3 state: down mac: <filter> 
Drives:    Local Storage: total: 476.94 GiB used: 169.07 GiB (35.4%) 
           ID-1: /dev/nvme0n1 vendor: SK Hynix model: PC601 NVMe 512GB size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 
           serial: <filter> rev: 80002111 scheme: GPT 
Partition: ID-1: / size: 19.56 GiB used: 14.58 GiB (74.5%) fs: ext4 dev: /dev/nvme0n1p8 
           ID-2: /home size: 62.50 GiB used: 14.09 GiB (22.5%) fs: ext4 dev: /dev/nvme0n1p9 
           ID-3: swap-1 size: 2.00 GiB used: 92 KiB (0.0%) fs: swap dev: /dev/nvme0n1p10 
Sensors:   System Temperatures: cpu: 57.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 270 Uptime: 12h 06m Memory: 15.31 GiB used: 1.61 GiB (10.5%) Init: systemd v: 242 Compilers: gcc: 9.2.0 
           Shell: bash v: 5.0.11 running in: yakuake inxi: 3.0.36

Anyone is facing the same problem or knows what might be the reason?

thanks for helping :slight_smile:

In the mentioned reference it is written:
With kernel version 5.2.2 and linux-firmware 20190717.bf13a71-1, WIFI would be working out of the box.

Linux 5.2 is EOL, but have you tried Linux 5.3 kernel just without any extra driver?

I haven't, I am worried it might break nvidia drivers or the current working setup I have for steam.

You have posted no system info.

inxi -Fxxxz

Please, no pics of outputs. Use Android USB phone tethering if you have no connection.

Do you dual boot with Windows?

The "tweaks" you speak of, give full details.

1 Like

Hi tbg,
I added system info in the original post.
and the tweaks are mainly the following kernel parameters:

pcie_port_pm=off rcutree.rcu_idle_gp_delay=1 mem_sleep_default=deep

^^^ please answer the question, this information may be the most important aspect of your issue. Windows has been causing issues for Intel adapters recently.

1 Like

Do you dual boot with Windows?

Sorry forgot to answer that, yes I do.

Then there's a high probability that Windows is at fault.

I would try the following procedures.

Windows can interfere with some Intel adapters being able to connect properly on dual boots systems. Window's has apparently been interfering with some Intel adapter's country codes being set properly recently.

If Windows is interfering with being able to set your regulatory domain (country code) correctly you will need to change your driver options in both Windows and Linux.

In your advanced wifi driver configuration settings in Windows disable "LAR" in your adapter's parameters. Save the driver settings changes and reboot into Manjaro.

To change your driver parameters in Linux you must create an iwlwifi driver configuration file. The required driver config file can be easily created with the following command:

echo "options iwlwifi lar_disable=1" | sudo tee -a /etc/modprobe.d/iwlwifi.conf

Reboot after making those driver configuration changes.

If the options file does not improve things you can delete the config file or simply comment out the entry with a # (pound sign) in front of the options entry.

1 Like

Forum kindly sponsored by