Kernel panic after freeze during update and no pacman in liveOS

Hello i`m new to the forum, and i hope someone can help me.
Yesterday i did a pacman -Syu but everything froze… i tried to redo the update via chroot but i get this output:

pacman: error while loading shared libraries: /usr/lib/ file too short

thanks in advance

1 Like

check this [Solved] Pacman no longer works at all!! / Pacman & Package Upgrade Issues / Arch Linux Forums

alternatively you can try pacman static and use it to reinstall curl


thank u i will try this

got pacman to run again but now im getting this error for all packages u have any idea

pacman: /usr/share/zsh/site-functions/_updpkgsums exists in filesystem
Errors occurred, no packages were upgraded.

I have the big hammer

--overwrite '*'

use at your own risk, some think this can lead to problems in some situations

1 Like

Ok thank u

Please tell if it managed to fix things for you.

Unfortunately not :confused: i tried to reinstall the kernel but now i get this errors when trying to rebuild the image…

did you try

sudo pacman -Syyu --overwrite '*'

before it?

If you did then you could try reinstalling all packages

sudo pacman -Syu $(pacman -Qnq)

I did not should i try it now?

Those are only warnings regarding missing firmware for hardware RAID controllers — which you probably don’t have — so you can ignore them.

Try booting up from the installed system and see whether it works.

It does not work it freezes during boot

Your filesystem may be damaged. Boot up from the live USB, but do not chroot or mount your root filesystem. Open up a terminal window and run an fsck on the root filesystem instead.

Only when the root filesystem checks out clean can you try chrooting and updating your system that way.

fsck returns

fsck from util-linux 2.39.2
e2fsck 1.47.0 (5-Feb-2023)
/dev/nvme0n1p6: clean, 909254/11526144 files, 19549458/46080000 blocks

Okay, so now update your system via the chroot. :arrow_down:

[manjaro-gnome /]# pacman-mirrors -f && pacman -Syyu
/usr/bin/pacman-mirrors: line 20: from: command not found
/usr/bin/pacman-mirrors: line 21: from: command not found
/usr/bin/pacman-mirrors: line 23: _: command not found
/usr/bin/pacman-mirrors: line 26: try:: command not found
/usr/bin/pacman-mirrors: line 27: syntax error near unexpected token `('
/usr/bin/pacman-mirrors: line 27: `    pm = pacman_mirrors.PacmanMirrors()'

the second cmd does not go though :confused:
any suggestions?

At this point, I would recommend that you back up your important data (if you have not done so already) and reinstall. :man_shrugging:

ok thank u all for ur time!!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.