Kernel not updating

new kernal install will not run. im on kernal 5.9.16-1 i can not update it to anything newer if i restart my computer it automatically boots into my current one rather then the newer one i installed how can i make it boot into the newer version.

Press shift while booting (may vary on desktops) to enter grub menu and you can select which kernel to boot with there

What kernel?

What’s the output of:

mhwd-kernel -li

from top to bottem it says linux511 linux59 i have tried installing other kernals how ever regardless of version it boots into linux59

When booting, press the Esc key, or press and hold the Shift key to enter the grub menu. Once there, navigate with the đŸ — arrow button, to the Advanced... option.

Select it by pressing Enter. You should now have a list of kernels to boot into. Navigate to the one you wish to use, and boot into it by pressing Enter when hovering over it.

check if you have the package linux-latest installed…that tip worked fine for me in a similar issue…