[Kernel] Modprobe FATAL on mtdram module, not found in /lib/module

I’m trying to flash using RPI4 and headless manjaro installation for arm64.
When I’m trying to do modprobe mtdblock, it works w/o issue, but it fails on next step, where I need to call modprobe mtdram total_size=6336, it returns modprobe: FATAL: Module mtdram not found in directory /lib/modules/6.0.2-1-MANJARO-ARM-RPI
I was able to found related issue on older kernel version, but I don’t understand if that issue was resolved or not and if it’s enabled for RPI

I’ve tried on 5.15.74 version, which was installed after latest update with the same result, then I’ve tried to jump on 6.0.2 hoping there won’t be that issue, but still no luck.

MTD is for SPI flash devices I believe. As far as I know, the Raspberry Pi does not have such a device.

I have it connected via usb, I’m not trying to flash with RPI directly, but to use with usb connected SPI flasher

Seems like a very specific usecase though. :wink:

But yeah, it’s likely that the module needed is not available in the rpi kernel.

Ok, what’s the next steps or possible solution?