Kernel Errors After Forced Power Off

So I made the rookie mistake of powering off my machine when it was updating under the assumption it was hung up. I went to reboot and it had issues with both my active kernel 5.10 and the fallback.

I created a live iso and booted into that. Here’s what I’ve done:

mhwd-kernel -r linux510

Removed no problem after removing the db.lck file.

mhwd-kernel -i linux510

I get the error “no targets specified”. After browsing the forums, I’ve tried the following without success:

pacman -Syu

Updated no problem, it even stated that the kernel had been updated.

mhwd-kernel -li

Lists no kernels installed.

mkinitcpio -P

Gives two error messages saying “specified kernel image does not exist” for 5.10 and 5.10 fallback.

grub-install --recheck --no-rs-codes

Error message saying install device isn’t specified.

No idea where to go from here. Is this salvageable?

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information.

[HowTo] Provide System Information

  1. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
sudo inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.

(Wisdom lies in reading :wink: )

You can also use maxi -eg

to collect information about the boot process. This works,

  • when you are in your running system (with CTRL+ALT+F2).
  • And also in a live environment

manjaro-chroot -a
rerun update:
pacman-mirrors -f 5 && pacman -Syyu
if there were no errors and you are up to date, reinstall the kernel:
pacman -S linux510
if you have nvidia, reinstall the kernel module too:
pacman -S linux510-nvidia
if there were no errors, exit chroot and reboot

pacman -S linux510

This solved it, thank you! Why does pacman work and not mwhd-kernel in this instance?

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.