Kernel ACPI BIOS Error

Hallo zusammen,

ich habe folgendes Problem:
Jedes mal wenn ich in den Bereitschaftsmodus gehe, verbraucht der Akku 8% pro Stunde.

Folgende Ausgangssituation:

System:
Host: Kernel: 4.19.45-1-MANJARO x86_64 bits: 64
Desktop: Cinnamon 4.0.10 Distro: Manjaro Linux
Machine:
Type: Laptop System: ASUSTeK product: ZenBook UX433FN_UX433FN v: 1.0
serial:
Mobo: ASUSTeK model: UX433FN v: 1.0 serial:
UEFI: American Megatrends v: UX433FN.204 date: 09/19/2018
Battery:
ID-1: BAT0 charge: 41.1 Wh condition: 48.5/50.1 Wh (97%)
CPU:
Topology: Quad Core model: Intel Core i7-8565U bits: 64 type: MT MCP
L2 cache: 8192 KiB
Speed: 800 MHz min/max: 400/4600 MHz Core speeds (MHz): 1: 800 2: 800
3: 800 4: 800 5: 801 6: 800 7: 800 8: 800
Graphics:
Device-1: Intel UHD Graphics 620 driver: i915 v: kernel
Device-2: NVIDIA GP108M [GeForce MX150] driver: N/A
Display: x11 server: X.Org 1.20.4 driver: intel tty: N/A
OpenGL: renderer: Mesa DRI Intel HD Graphics (Whiskey Lake 3x8 GT2)
v: 4.5 Mesa 19.0.4
Audio:
Device-1: Intel Cannon Point-LP High Definition Audio
driver: snd_hda_intel
Sound Server: ALSA v: k4.19.45-1-MANJARO
Network:
Device-1: Intel Cannon Point-LP CNVi [Wireless-AC] driver: iwlwifi
IF: wlo1 state: up mac: 00:bb:60:08:a8:d1
Drives:
Local Storage: total: 238.47 GiB used: 8.45 GiB (3.5%)
ID-1: /dev/nvme0n1 vendor: Western Digital
model: PC SN520 SDAPNUW-256G-1002 size: 238.47 GiB
Partition:
ID-1: / size: 233.43 GiB used: 8.45 GiB (3.6%) fs: ext4
dev: /dev/nvme0n1p2
Sensors:
System Temperatures: cpu: 37.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 281 Uptime: 26m Memory: 15.48 GiB used: 1.15 GiB (7.4%)
Shell: bash inxi: 3.0.34

Bei dem Befehl "sudo journalctl -p 3 -xb" erscheinen folgende Fehlermeldungen:

kernel: ACPI BIOS Error (bug): Failure creating [_SB.>
kernel: ACPI Error: AE_ALREADY_EXISTS, During name loo>
kernel: ACPI Error: Skip parsing opcode Method (201808>
kernel: ACPI BIOS Error (bug): Failure creating [_SB.>
kernel: ACPI Error: AE_ALREADY_EXISTS, During name loo>
kernel: ACPI Error: Skip parsing opcode Method (201808>
kernel: ACPI BIOS Error (bug): Could not resolve [_SB>
kernel: ACPI Error: Method parse/execution failed \CND>
kernel: ACPI Error: Method parse/execution failed , A>
kernel: ACPI Error: Invalid zero thread count in metho>
kernel: ACPI Error: Invalid OwnerId: 0x00 (20180810/ut>
kernel: ACPI Error: AE_NOT_FOUND, (SSDT:xh_whld4) whil>
kernel: ACPI Error: 1 table load failures, 9 successfu>
kernel: iTCO_wdt iTCO_wdt: can't request region for re>

Kann mir hier jemand weiterhelfen?

Danke

lg

Vielleicht hier mal
/etc/fstab
posten.

fstab:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=3E25-13AB                            /boot/efi      vfat    defaults,noatime 0 2
UUID=a7391828-220e-4c82-a99c-1b9ed2c4c714 /              ext4    defaults,noatime 0 1

Um Suspend to disc zu verwenden, wird eine Swap Partition benötigt.

ACPI Errors können eigentlich immer ignoriert werden. Du kannst sie nicht verschwinden lassen ohne die nicht vollständig unterstützte Hardware auszuschalten. Das geht in vielen Fällen nicht oder führ einfach zu nichts. Man kann versuchen einen neuern Kernel zu installieren um zu schauen ob ein paar ACPI Errors verschwinden.

ACPI Kernel Argumente benötigt man eigentlich nur wenn irgendwas nicht funktioniert. Die sind aber nicht gedacht um ACPI Errors zu entfernen. Sondern um Hardware die nicht verwendet werden kann in einen Zustand zu bringen um von Linux angesprochen zu werden.

Finde ich nicht zu schlecht. Die Frage ist was im Bereitschaftsmodus noch alles an bleibt und wie Stromsparend die einzeln Komponenten sind. Oft bleibt zum Beispiel das Wifi noch an und schickt munter Pakete durch die Luft. Manchmal kann man solche Sachen im UEFI ausschalten.

Ich dachte es geht hier um Standby und nicht um den Ruhezustand.

Weiterer Punkt:
die Nvme SSD ist falsch partitioniert.

Ich würde einen aktuelleren Kernel verwenden.

Wird denn der S3 Modus unterstützt?
Poste mal den output von:

journalctl -b | grep -i acpi | grep -i support

Die Ausgabe sollte so etwas enthalten: kernel: ACPI: (supports S0 S3 S4 S5)

Und auch was er sagt wenn er aufwacht:

journalctl -b| grep -i waking

Die Ausgabe sollte so etwas enthalten: kernel: ACPI: Waking up from system sleep state S3

journalctl -b | grep -i acpi | grep -i Support:

Mai 28 13:32:50 kernel: ACPI: (supports S0 S3 S4 S5)
Mai 28 13:32:50 kernel: acpi PNP0A08:00: _OSC: OS supports [ExtendedConfig ASPM ClockPM Segments MSI]

bei "journalctl -b | grep -i waking" bekomme ich gar keine Ausgabe

Du musst den laptop mindestens einmal schlafen gelegt haben. Logischer Weise :wink:

Versuch mal ohne "-b"

journalctl | grep -i waking

Das ist super schlecht. Das ist ja quasi der volle Stromverbrauch und nach 12 Stunden ist der Akku leer. Mein laptop hat im standby unter 1 %, hält also mehrere Tage in dem Zustand aus.

Ich vermute eher der laptop legt sich überhaupt nicht schlafen, sondern schaltet nur den Monitor aus. Das würde auch erklären warum @kollegah89 keine Aufwachmeldungen wie "ACPI: Waking up from system sleep state S3" im log hat.

Ich habe jetzt den Laptop mit der Option Swap Partition mit Ruhezustand neu installiert.
Wenn ich jetzt in den Bereitschaftsmodus gehe, brauch ich immer noch ca 8% Akku pro Stunde.
Wenn ich aber die Option Hybrid-Bereitschaft aktiviere, brauch ich ca 1 % pro Stunde.

ich habe dann folgende Meldung ("journalctl -b| grep -i waking"):

kernel: ACPI: Waking up from system sleep state S4
kernel: ACPI: Waking up from system sleep state S3
kernel: ACPI: Waking up from system sleep state S3
kernel: ACPI: Waking up from system sleep state S3

Wenn ich aber denn Laptop über Nacht im Hybrid-Bereitschaftsmodus lasse, brauche ich zwar kaum Akku, aber leider wachte der Laptop heute nicht mehr auf und ich musste den Laptop abwürgen...

Das ist in der Tat super schlecht.
Im Standby-Modus ("suspend to RAM") sollte eigentlich fast alles bis auf den Arbeitsspeicher schlafen gelegt werden, so dass der Stromverbrauch nur minimal sein sollte.
Vielleicht eine fehlerhafte ACPI Implementierung des S3 Zustandes?
In dem Falle dürfte nur ein BIOS Update weiterhelfen - laut Asus Homepage ist das aktuellste BIOS vom April 2019 mit der Versionsnummer 302. Dazu gibt es auch ein Firmware Update (März 2019).

Das sieht erstmal alles richtig aus. Im log steht beim booten das S3 unterstützt wird und er sagt beim aufwachen auch das er sich im S3 Zustand befunden hat. Sehr merkwürdig.

Aber wie habe ich denn das hier zu verstehen:

Wenn ich aber denn Laptop über Nacht im Hybrid-Bereitschaftsmodus lasse, brauche ich zwar kaum Akku, aber leider wachte der Laptop heute nicht mehr auf und ich musste den Laptop abwürgen...

Hybrid-Bereitschaftsmodus macht ja einen suspend (Bereitschaft, S3) und ein hibernate (Ruhezustand, S4) gleichzeitig. Wobei der Rechner im suspend bleibt bis die Batterie nach einiger Zeit leer ist. Dann schaltet er sich einfach ab und ist dann im hibernate. In welchem Zustand war denn dein laptop bei diesem Versuch? War er noch im suspend oder schon im hibernate?

ok ich habe jetzt ein BIOS update auf 302 gemacht, ich werde das bis morgen beobachten.
ich hoffe das der Laptop ohne Probleme aus dem Bereitschaftsmodus erwacht.