Kernel 5.19.0 problems with display and system hangup

I was asked to open a thread here, but i think the problem is not directly related to the graphics card/display.
After updating kernel to 5.19.0-2 screen goes black after a while and image flickers very sporadically in the background.
Mouse cursor stays visible and can be moved. Programs are running in the background but slowly.
Even with CTRL-ALT-F2 still black screen and after login and shutdown (still cant see what i type coz of the black screen), the system hangs (keyboard leds unresponsive) and a hard shutdown is needed.
There are no issues switching back to 5.18.x or LTS.
With 5.19.0_rt10-1 realtime kernel the system does not “crash”…
No blackscreen, no nothing… except a super-small hickup in audio/video once in a minute or 2, but the system is mostly usable.

System info (with the WORKING 5.18.16-1 kernel)

System:
  Kernel: 5.18.16-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.18-x86_64
    root=UUID=133640ff-250a-4d2c-a8a2-ddd4a7c162e2 rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: KDE Plasma v: 5.24.6 tk: Qt v: 5.15.5 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: ASUSTeK model: CROSSHAIR VI HERO v: Rev 1.xx
    serial: <superuser required> UEFI-[Legacy]: American Megatrends v: 8002
    date: 03/09/2021
Battery:
  Message: No system battery data found. Is one present?
Memory:
  RAM: total: 31.28 GiB used: 4.54 GiB (14.5%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges
    required.
CPU:
  Info: model: AMD Ryzen 7 3800X bits: 64 type: MT MCP arch: Zen 2 gen: 3
    built: 2020-22 process: TSMC n7 (7nm) family: 0x17 (23) model-id: 0x71 (113)
    stepping: 0 microcode: 0x8701021
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 32 MiB desc: 2x16 MiB
  Speed (MHz): avg: 2402 high: 3333 min/max: 2200/4559 boost: disabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 2314 2: 2339
    3: 2477 4: 2180 5: 2376 6: 2112 7: 2224 8: 2075 9: 2139 10: 2555 11: 2438
    12: 2197 13: 3333 14: 2082 15: 2330 16: 3268 bogomips: 124851
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
    bmi2 bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy
    constant_tsc cpb cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total
    cqm_occup_llc cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid
    f16c flushbyasid fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb ibs
    irperf lahf_lm lbrv lm mba mca mce misalignsse mmx mmxext monitor movbe
    msr mtrr mwaitx nonstop_tsc nopl npt nrip_save nx osvw overflow_recov pae
    pat pausefilter pclmulqdq pdpe1gb perfctr_core perfctr_llc perfctr_nb
    pfthreshold pge pni popcnt pse pse36 rapl rdpid rdpru rdrand rdseed rdt_a
    rdtscp rep_good sep sev sev_es sha_ni skinit smap smca smep ssbd sse sse2
    sse4_1 sse4_2 sse4a ssse3 stibp succor svm svm_lock syscall tce topoext
    tsc tsc_scale umip v_spec_ctrl v_vmsave_vmload vgif vmcb_clean vme vmmcall
    wbnoinvd wdt xgetbv1 xsave xsavec xsaveerptr xsaveopt xsaves
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT enabled with STIBP
    protection
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
    always-on, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT]
    driver: amdgpu v: kernel arch: RDNA-1 code: Navi process: TSMC n7 (7nm)
    built: 2019-20 pcie: gen: 4 speed: 16 GT/s lanes: 16 ports:
    active: DP-1,DP-2 empty: DP-3,HDMI-A-1 bus-ID: 0d:00.0 chip-ID: 1002:731f
    class-ID: 0300
  Device-2: Logitech HD Pro Webcam C920 type: USB
    driver: snd-usb-audio,uvcvideo bus-ID: 5-2:2 chip-ID: 046d:082d
    class-ID: 0102 serial: <filter>
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
    compositor: kwin_x11 driver: X: loaded: amdgpu gpu: amdgpu display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 5120x1440 s-dpi: 96 s-size: 1354x381mm (53.31x15.00")
    s-diag: 1407mm (55.38")
  Monitor-1: DP-1 mapped: DisplayPort-0 pos: primary,left model: LG
    (GoldStar) ULTRAGEAR serial: <filter> built: 2020 res: 2560x1440 hz: 144
    dpi: 109 gamma: 1.2 size: 597x336mm (23.5x13.23") diag: 685mm (27")
    ratio: 16:9 modes: max: 2560x1440 min: 640x480
  Monitor-2: DP-2 mapped: DisplayPort-1 pos: right model: Acer XG270HU
    serial: <filter> built: 2016 res: 2560x1440 dpi: 109 gamma: 1.2
    size: 598x336mm (23.54x13.23") diag: 686mm (27") ratio: 16:9 modes:
    max: 2560x1440 min: 720x400
  OpenGL: renderer: AMD Radeon RX 5700 XT (navi10 LLVM 14.0.6 DRM 3.46
    5.18.16-1-MANJARO) v: 4.6 Mesa 22.1.4 direct render: Yes
Audio:
  Device-1: AMD Navi 10 HDMI Audio driver: snd_hda_intel v: kernel pcie:
    bus-ID: 1-12:9 gen: 4 chip-ID: 262a:9113 class-ID: 0102 speed: 16 GT/s
    lanes: 16 bus-ID: 0d:00.1 chip-ID: 1002:ab38 class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 0f:00.4 chip-ID: 1022:1487 class-ID: 0403
  Device-3: SAVITECH SA9123 USB Audio type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Device-4: C-Media USB PnP Audio Device type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-3:2 chip-ID: 0d8c:0134
    class-ID: 0300
  Device-5: Logitech HD Pro Webcam C920 type: USB
    driver: snd-usb-audio,uvcvideo bus-ID: 5-2:2 chip-ID: 046d:082d
    class-ID: 0102 serial: <filter>
  Sound Server-1: ALSA v: k5.18.16-1-MANJARO running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: PulseAudio v: 16.1 running: no
  Sound Server-4: PipeWire v: 0.3.56 running: yes
Network:
  Device-1: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel
    pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 05:00.0
    chip-ID: 8086:1539 class-ID: 0200
  IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  IF-ID-1: br10 state: down mac: <filter>
  IP v4: <filter> scope: global broadcast: <filter>
  WAN IP: <filter>
Bluetooth:
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
    bus-ID: 1-4:3 chip-ID: 0bda:8771 class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
Logical:
  Message: No logical block device data found.
RAID:
  Message: No RAID data found.
Drives:
  Local Storage: total: 7.5 TiB used: 82.36 GiB (1.1%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 970 EVO 500GB
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: 2B2QEXE7 temp: 34.9 C scheme: MBR
  ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WD20EZRX-00DC0B0 size: 1.82 TiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s type: N/A serial: <filter> rev: 0A80
    scheme: MBR
  ID-3: /dev/sdb maj-min: 8:16 vendor: Western Digital
    model: WD1002FAEX-00Y9A0 size: 931.51 GiB block-size: physical: 512 B
    logical: 512 B speed: 6.0 Gb/s type: N/A serial: <filter> rev: 1D05
    scheme: MBR
  ID-4: /dev/sdc maj-min: 8:32 vendor: Samsung model: SSD 850 EVO 500GB
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 2B6Q scheme: MBR
  ID-5: /dev/sdd maj-min: 8:48 vendor: Samsung model: SSD 840 EVO 250GB
    size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: DB6Q scheme: MBR
  ID-6: /dev/sde maj-min: 8:64 vendor: Toshiba model: HDWE140 size: 3.64 TiB
    block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD
    rpm: 7200 serial: <filter> rev: FP1R scheme: GPT
  Message: No optical or floppy data found.
Partition:
  ID-1: / raw-size: 232.88 GiB size: 228.17 GiB (97.98%) used: 82.36 GiB
    (36.1%) fs: ext4 dev: /dev/sdd1 maj-min: 8:49 label: N/A
    uuid: 133640ff-250a-4d2c-a8a2-ddd4a7c162e2
Swap:
  Alert: No swap data was found.
Unmounted:
  ID-1: /dev/nvme0n1p1 maj-min: 259:1 size: 50 MiB fs: ntfs label: Riservato
    per il sistema uuid: C85A3C5D5A3C4B08
  ID-2: /dev/nvme0n1p2 maj-min: 259:2 size: 465.2 GiB fs: ntfs label: N/A
    uuid: 9CAA3CEEAA3CC714
  ID-3: /dev/nvme0n1p3 maj-min: 259:3 size: 517 MiB fs: ntfs label: N/A
    uuid: EA6E95D86E959DBF
  ID-4: /dev/sda1 maj-min: 8:1 size: 1.82 TiB fs: ntfs label: Storage 2TB
    uuid: 06CA11F6CA11E2AB
  ID-5: /dev/sdb1 maj-min: 8:17 size: 931.51 GiB fs: ntfs label: Storage 1TB
    uuid: 01D35E7DCBA0EAC0
  ID-6: /dev/sdc1 maj-min: 8:33 size: 465.76 GiB fs: ntfs label: SSD 500GB
    uuid: 01D47E887B29B550
  ID-7: /dev/sde1 maj-min: 8:65 size: 3.64 TiB fs: ntfs label: Storage 4TB
    uuid: 01D57C6C57C5A320
USB:
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 14 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-3:2 info: C-Media USB PnP Audio Device type: Audio,HID
    driver: hid-generic,snd-usb-audio,usbhid interfaces: 3 rev: 1.1
    speed: 12 Mb/s power: 100mA chip-ID: 0d8c:0134 class-ID: 0300
  Device-2: 1-4:3 info: Realtek Bluetooth Radio type: Bluetooth
    driver: btusb interfaces: 2 rev: 1.1 speed: 12 Mb/s power: 500mA
    chip-ID: 0bda:8771 class-ID: e001 serial: <filter>
  Device-3: 1-6:4 info: Logitech G815 Mechanical Keyboard type: Keyboard,HID
    driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s
    power: 500mA chip-ID: 046d:c33f class-ID: 0300 serial: <filter>
  Hub-2: 1-8:5 info: Texas Instruments TUSB8041 4-Port Hub ports: 4 rev: 2.1
    speed: 480 Mb/s chip-ID: 0451:8142 class-ID: 0900
  Device-1: 1-8.4:7 info: LG USA Monitor Controls type: HID
    driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 12 Mb/s
    chip-ID: 043e:9a39 class-ID: 0300 serial: <filter>
  Hub-3: 1-9:6 info: Genesys Logic Hub ports: 4 rev: 2.0 speed: 480 Mb/s
    power: 100mA chip-ID: 05e3:0608 class-ID: 0900
  Hub-4: 1-10:8 info: Genesys Logic Hub ports: 4 rev: 2.0 speed: 480 Mb/s
    power: 100mA chip-ID: 05e3:0608 class-ID: 0900
  Device-1: 1-10.2:10 info: Corsair H115i Platinum type: Keyboard
    driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 12 Mb/s
    power: 100mA chip-ID: 1b1c:0c17 class-ID: 0300
  Device-2: 1-10.4:12 info: Corsair type: HID driver: corsair-psu,usbhid
    interfaces: 1 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 1b1c:1c06
    class-ID: 0300
  Device-3: 1-12:9 info: SAVITECH SA9123 USB Audio type: HID,Audio
    driver: hid-generic,snd-usb-audio,usbhid interfaces: 3 rev: 1.1
    speed: 12 Mb/s power: 100mA chip-ID: 262a:9113 class-ID: 0102
  Device-4: 1-13:11 info: Logitech G502 Proteus Spectrum Optical Mouse
    type: Mouse,HID driver: hid-generic,usbhid interfaces: 2 rev: 2.0
    speed: 12 Mb/s power: 300mA chip-ID: 046d:c332 class-ID: 0300
    serial: <filter>
  Hub-5: 2-0:1 info: Super-speed hub ports: 8 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-6: 2-8:2 info: Texas Instruments TUSB8041 4-Port Hub ports: 4 rev: 3.0
    speed: 5 Gb/s chip-ID: 0451:8140 class-ID: 0900
  Hub-7: 3-0:1 info: Hi-speed hub with single TT ports: 2 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-8: 4-0:1 info: Super-speed hub ports: 2 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-9: 5-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 5-2:2 info: Logitech HD Pro Webcam C920 type: Video,Audio
    driver: snd-usb-audio,uvcvideo interfaces: 4 rev: 2.0 speed: 480 Mb/s
    power: 500mA chip-ID: 046d:082d class-ID: 0102 serial: <filter>
  Device-2: 5-4:3 info: ThrustMaster GPX Controller type: <vendor specific>
    driver: xpad interfaces: 4 rev: 2.0 speed: 12 Mb/s power: 500mA
    chip-ID: 24c6:5b02 class-ID: ff00 serial: <filter>
  Hub-10: 6-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
Sensors:
  System Temperatures: cpu: 47.0 C mobo: 31.0 C gpu: amdgpu temp: 41.0 C
    mem: 60.0 C
  Fan Speeds (RPM): cpu: 4272 case-1: 0 case-2: 0 case-3: 0 gpu: amdgpu
    fan: 709
  Power: 12v: 12.03 5v: N/A 3.3v: N/A vbat: 3.05 gpu: amdgpu watts: 33.00
Info:
  Processes: 366 Uptime: 9m wakeups: 0 Init: systemd v: 251 default: graphical
  tool: systemctl Compilers: gcc: 12.1.1 clang: 14.0.6 Packages: 1989
  pacman: 1965 lib: 508 flatpak: 17 snap: 7 Shell: Zsh v: 5.9
  running-in: konsole inxi: 3.3.20

Problems solved with Kernel 5.19.1-2

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.