Kernel 5.15.13_rt26-1 not booting on my laptop for audio pro usage

Hi all.
Since i’m configuring my machine for professional audio usage with great real-time performance i just discovered Manajaro which is recently often suggested as a good platform for pro audio work.
I’ve correctly installed the latest Manjaro XFCE on my dual boot machine (the other OS is Windows 11) and everything works fine since i installed Manjaro with “proprietary drivers” option because of my Nvidia GPU. The kernel is version 5.15.16-1. To gain minumum latency with audio work i then installed via “Manjaro Settings Manager/Kernel” the Linux 5.15.13_rt26-1 real time kernel.
It correctly appears as an option in the advanced tag at boot time but if i try to boot the kernel the laptop does not boot and stays forever on this message : “/dev/sda4: clean, 744133/12804096 files, 6738619/51200000 blocks”. If i try to start with the original 5.15.16-1 kernel everything works fine and Manjaro does boot correctly. Any hint? thanks and all the best

Sounds like a video driver issue. Boot to Linux 5.15 kernel, check if driver is properly installed for the RT kernel from terminal.

mhwd -li
pacman -Qs linux515

Give the output of commands, for each commands put them between three bacticks when pasting it here, example:

terminal output here

there is others versions of rt

sudo mhwd-kernel -l
[sudo] Mot de passe de scoin : 
available kernels:
   * linux510
   * linux515
   * linux516
   * linux517
   * linux54
   * linux510-rt
   * linux515-rt
   * linux516-rt

choose another one

It is 5.15.13.

Not 5.13

Hi guys. Thanks for the first hints.
@omano at

mhwd -li

i get…

> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
    video-nvidia-390xx            2021.12.18               false            PCI

Warning: No installed USB configs!


pacman -Qs linux515

i get

local/linux515 5.15.16-1
    The Linux515 kernel and modules
local/linux515-nvidia-390xx 390.147-7 (linux515-extramodules)
    NVIDIA drivers for linux.
local/linux515-rt 5.15.13_rt26-1
    The Linux515-rt kernel and modules

So yeah it is not installed for your RT kernel, so let get back to video drivers, list the available video drivers, also list the system information

mhwd -l
inxi -Fazy

thanks @omano …this is what i get

0000:01:00.0 (0300:10de:0dfa) Display controller nVidia Corporation:
                 NAME               VERSION          FREEDRIVER           TYPE
   video-nvidia-390xx            2021.12.18               false            PCI
          video-linux            2018.05.04                true            PCI
    video-modesetting            2020.01.13                true            PCI
           video-vesa            2017.03.12                true            PCI


  Kernel: 5.15.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=02c17bfc-43c4-4f37-99e7-183e0e2be641 rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1
    vt: 7 dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Hewlett-Packard product: HP EliteBook 8560w v: A0001D02
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Hewlett-Packard model: 1631 v: KBC Version 01.3F
    serial: <superuser required> BIOS: Hewlett-Packard v: 68SVD Ver. F.63
    date: 10/27/2016
  ID-1: BAT0 charge: 55.4 Wh (100.0%) condition: 55.4/55.4 Wh (100.0%)
    volts: 16.6 min: 14.4 model: Hewlett-Packard Primary type: Li-ion
    serial: <filter> status: Full
  Info: model: Intel Core i7-2670QM bits: 64 type: MT MCP arch: Sandy Bridge
    family: 6 model-id: 0x2A (42) stepping: 7 microcode: 0x2F
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 6 MiB desc: 1x6 MiB
  Speed (MHz): avg: 1014 high: 1485 min/max: 800/3100 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 798 2: 1058 3: 838
    4: 1485 5: 798 6: 1276 7: 816 8: 1046 bogomips: 35129
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
  Type: itlb_multihit status: KVM: VMX unsupported
  Type: l1tf mitigation: PTE Inversion
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
    IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GF108GLM [Quadro 1000M] vendor: Hewlett-Packard
    driver: nvidia v: 390.147 alternate: nouveau,nvidia_drm bus-ID: 01:00.0
    chip-ID: 10de:0dfa class-ID: 0300
  Device-2: Chicony Integrated HP HD Webcam type: USB driver: uvcvideo
    bus-ID: 2-1.4:3 chip-ID: 04f2:b230 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org compositor: xfwm4 v: 4.16.1 driver:
    loaded: nvidia display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x286mm (20.0x11.3")
    s-diag: 583mm (23")
  Monitor-1: LVDS-0 res: 1920x1080 hz: 60 dpi: 142
    size: 344x193mm (13.5x7.6") diag: 394mm (15.5")
  Message: Unable to show advanced data. Required tool glxinfo missing.
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio
    vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
    chip-ID: 8086:1c20 class-ID: 0403
  Device-2: NVIDIA GF108 High Definition Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:0bea
    class-ID: 0403
  Sound Server-1: ALSA v: k5.15.16-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.43 running: yes
  Device-1: Intel 82579LM Gigabit Network vendor: Hewlett-Packard
    driver: e1000e v: kernel port: 5020 bus-ID: 00:19.0 chip-ID: 8086:1502
    class-ID: 0200
  IF: enp0s25 state: down mac: <filter>
  Device-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi
    v: kernel bus-ID: 25:00.0 chip-ID: 8086:0085 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  Local Storage: total: 465.76 GiB used: 29.7 GiB (6.4%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 840 EVO 500GB
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: BB6Q scheme: MBR
  ID-1: / raw-size: 195.31 GiB size: 191.19 GiB (97.89%)
    used: 29.7 GiB (15.5%) fs: ext4 dev: /dev/sda4 maj-min: 8:4
  Alert: No swap data was found.
  System Temperatures: cpu: 38.0 C mobo: 37.0 C gpu: nvidia temp: 32 C
  Fan Speeds (RPM): N/A
  Processes: 269 Uptime: 3m wakeups: 2 Memory: 19.49 GiB used: 1.77 GiB (9.1%)
  Init: systemd v: 250 tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.0
  Packages: 1143 pacman: 1136 lib: 318 flatpak: 0 snap: 7 Shell: Bash
  v: 5.1.16 running-in: xfce4-terminal inxi: 3.3.12

OK you only have the 390 Nvidia driver available to you, so try to reinstall it.

sudo mhwd -a pci nonfree 0300

It should install the Nvidia video driver automatically, if for some reason it doesn’t install the missing module for the RT kernel, you could try to force the reinstall, but let start with that command, and give the output here before rebooting (you could reboot, but for the sake of keeping track of what happened with the command, just put it here).

To force the re-installation of video driver 390 here is the command:

sudo mhwd -f -i pci video-nvidia-390xx

You were not alone having problem booting kernel v5.15rt
Boot to black screen after recent update

Updates for stable branch today include kernel v5.16.2_rt19-1
I have been using this kernel on testing branch and it is working well here

I suggest you install this kernel – sudo mhwd-kernel -i linux516-rt

remove the old kernel – sudo mhwd-kernel -r linux515-rt

then turn it up and party on!

:pencil2: EDIT: to correct commands

I’m not sure suggesting to install a non LTS RT kernel, that will probably be dropped from repositories in a couple months, is the proper solution, especially when we still don’t know if he has an issue installing the LTS 5.15 RT kernel, and when he’s trying to make a setup for “professional audio usage” which would probably need to be something stable, and not having to keep track of new RT short lived kernel when they are dropped/added.

Having the 5.15 RT kernel properly setup is the way to go for a long term setup.

Seems like for now actually your best bet is to use the linux 5.16 RT kernel as suggested by nikgnomic above, I tried for the sake of it and there is actually multiple issues with the linux 5.15 RT kernel currently, so remove it for now.

See this here Linux Kernel 5.15.18-2-rt28-MANJARO Broke NVIDIA Drivers - #7 by omano

I pushed the missing Nvidia driver updates

thanks everybody
@nikgnomic if i do

sudo mhwd -i linux516-rt

i get

Error: invalid use of option: -i/--install

Usage: mhwd [OPTIONS] <config(s)>

  --pci					list only pci devices and driver configs
  --usb					list only usb devices and driver configs
  -h/--help				show help
  -v/--version				show version of mhwd
  -f/--force				force reinstallation
  -d/--detail				show detailed info for -l/-li/-lh
  -l/--list				list available configs for devices
  -la/--listall				list all driver configs
  -li/--listinstalled			list installed driver configs
  -lh/--listhardware			list hardware information
  -i/--install <usb/pci> <config(s)>	install driver config(s)
  -ic/--installcustom <usb/pci> <path>	install custom config(s)
  -r/--remove <usb/pci> <config(s)>	remove driver config(s)
  -a/--auto <usb/pci> <free/nonfree> <classid>	auto install configs for classid
  --pmcachedir <path>			set package manager cache path
  --pmconfig <path>			set package manager config
  --pmroot <path>			set package manager root

Apologies - the correct command for installing kernel should be

sudo mhwd-kernel -i linux516-rt

thanks. this is what i get.

Error: Please make sure if the given kernel(s) exist(s).
available kernels:
   * linux414
   * linux419
   * linux44
   * linux49
   * linux510
   * linux514
   * linux515
   * linux516
   * linux54
   * linux510-rt
   * linux515-rt

That kernel exists. Refresh your database and try again:

sudo pacman-mirrors -f 5 && sudo pacman -Syyu && sudo mhwd-kernel -i linux516-rt

thanks a lot everybody guys. Now i have 5.16.2_rt19-1 up and running.
Next step is to see if i can disable/uninstall pulseaudio and use pipewire and jack only without blowing the whole Manjaro XFCE…

As said this kernel is short lived, it will automatically be dropped from Manjaro soon. Only LTS kernels are kept for multiple years, so now make sure you follow the announcement in the forum to check when this kernel will be dropped.

As Philm said, he fixed kernel 5.15 RT so I would advice to install it instead as this one will probably live for years in Manjaro. As you wish but you’ve been warned.

@oberon has released updated nvidia drivers for kernel v5.15rt to unstable branch

Manjaro - Branch Compare - linux515-rt-nvidia-

So I would expect that when you get update for linux515-rt-nvidia-390xx to v390.147-3
Kernel v5.15rt should be able to boot without problems

If Manjaro team fasttrack this update to stable and testing repositories we might have this kernel working again within a few hours

Ho it wasn’t pushed already? my bad :wink: