Kernel 5.13 and USB

I recently updated to kernel 5.13 and usb docks stopped working. There seems to be an issue with USB 3, 3.1 on kerne 5.13 [1]. The internal USB ports are all still working, just everything connected to the docking station or the usb hub of a monitor did not work. Downgrading to 5.12 fixes the issue.

The machine is a Lenovo L14 (AMD)

[1] - [SOLVED] USB keyboard and mouse not detected at boot with kernel 5.13.4, 5.12.11 is OK

Kernel 5.12 is EOL so please read this:

Especially the Linux has multiple kernels section and then install both 5.4 and 5.10 and see which one does work.

Alternatively, if you have a compelling reason to be on 5.13, please read the section What’s this Upstream/Downstream business? and file a bug upstream…



My Laptop is an L14 (AMD) and has some issues with the LTS kernel, so I have been on the newest version for a while now. I have no issues staying on 5.12 until the problem gets fixed in 5.13 or 5.14 but I am aware of 5.12 not receiving any more updates. Not sure if there is a better solution.

5.10 gets the same security updates and bug fixes as 5.13, but just does not have the new features. Have you tried it recently???


The Slackware discussion linked from OP was marked as solved based on this comment

07-29-2021 05:35 PM
The update to 5.13.6 has fixed the problem for me

The Arch bug report for this issue was also resolved on same date

FS#71570 : [linux] USB hubs aren't detected after upgrade to 5.13.4
Comment by Alexey (axp) - Thursday, 29 July 2021, 17:22 GMT
Seems that revert that fixes the issue has been merged into 5.13.6:

Comment by Alexey (axp) - Thursday, 29 July 2021, 23:18 GMT
Yes, I can confirm: issue is solved in 5.13.6

Manjaro is currently using kernel v5.13.12, or v5.13.13 on unstable branch

1 Like

Just had the same issue with 5.12 again. I can make it work if I connect the USB hubs during boot… Very strange.

I also suspect that this has something to do with a firmware update that I did at the same time as changing the kernel.

I have turned off autosuspend for usb devices in powertop and now it seems to work, also with kernel 5.13…

I think I have the culprit: My USB headset had a bent pin, first time I see a broken USB plug. If the headset was connected while turning on the computer everything was fine. If it was connected directly to the dock and the dock got disconnected things break. Now I connect it through the Monitor and things seem to be fine.

Another update: I have stopped using the Dock, now I am using a USB-C monitor and its internal USB hub.

The problem still occurs and I think it is the USB disconnect issue that many AMD processors have [1]. I happens, when I stress the GPU and Thunderbird is enough to do that. I can reliably reproduce the disconnect of the USB-C monitor running the Unigine Superposition Benchmark [2]. The monitor turns black, its USB Hub disconnects and it takes 10-20s for everything to go back to normal.

I have the latest BIOS/Firmware version installed and it didn’t help.
The problem also only occurs if I set the CPU governor to performance, on powersafe (i.e. 1.4GHz) everything works just fine. Also elevating the laptop for better airflow seems to help somewhat.

[1] AMD Offers Tips to Mitigate USB Disconnect Problems on B550, X570 Motherboards | PCMag

EDIT: Since a week or two there is a very audible coil whine…