Kernel 5.11 crashes, produces black screen

I need help, please! It’s a SERIOUS PROBLEM: Kernel 5.11 crashes in my computer, it produces a black screen when it boots. For kernel 5.10 I use amdgpu.dc=0 to solve this problem, but this does NOT solve the problem for kernel 5.11. I add below the details of my computer:
Computer: HP Laptop 15-db0xxx
CPU: Dual Core AMD A6-9225 RADEON R4 5 COMPUTE CORES 2C+3G (-MCP-) @ 2x 2.6GHz
GPU/graphics card: AMD Stoney [Radeon R2/R3/R4/R5 Graphics]
Graphics driver: amdgpu

Please share the Desktop Environment and Login manager used?

AMDgpu have this issue but you can press Ctrl + Alt + F2 and there you should be able to see something in command line, try to login there and start the de manually from there.

Try and let me know.

The desktop environment is KDE Plasma and the login manager is sddm (the usual login manager for KDE Plasma). I’ve tried your suggestion (ctrl+alt+F2, and also ctrl+fn+alt+F2, fn+alt+F2, and alt+F2) with and without amdgpu.dc=0 and the result is the same: black screen. And then I have to power off and power on the computer with the power button.

Ok then it is not the issue which I was thinking off :frowning:

You need to look for some more details, did you make any changes ?

I’m sorry, could you explain what changes are you talking about, please? I don’t understand what you want to mean.

What is the reason you use Kernel 5.11 (experimental) instead of 5.10 (stable)?

Check if using the video= kernel parameter works. For my RX 5700 XT, I use:

video=DP-0:2560x1440@60 video=DP-1:2560x1440@144 video=DP-2:2560x1440@60

I’ve tried this for my computer:
video=DP-0:1366x768@60 video=DP-1:1366x768@60 video=DP-2:1366x768@60
The result is the same: Black screen. I’ve also restored the default BIOS configuration and the result is again the same: Black screen. Perhaps is not a problem of graphics, I don’t know. I’m worried because if the problem continues with new kernels, I will not be able to install from new isos (if I need to do it), and because although the life of kernel 5.10 can be long, it’s not infinite, so when the life of kernel 5.10 finishes, I would have to buy a new computer.

datiswous, kernel 5.11 is stable now.

Sorry, Kernel page was showing outdated info.

UPDATE: I’ve published this kernel bug in the bugzilla of the Linux kernel as bug 212133 and there is an active thread there trying to solve and repair this kernel bug.

SOLVED: In the thread of the bug 212133 in the bugzilla of the Linux kernel, this kernel bug has been solved and is being corrected. While kernels are being corrected, another solution that has been found there is that you add the kernel parameter iommu=soft in the kernel boot line.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.