Kernel 5.10 and optimus-manager (Nvidia) problem

Hello all.

Yesterday I had this problem that I could not for the life of mine get optimus-manager working on kernel 5.10, while it worked fine on kernel 5.9. I checked the installations of optimus-manager as thoroughly as I could, but no errors were found. I was on testing branch then.

So I reinstalled Manjaro KDE this morning, following these steps

  1. First boot after reinstall on kernel 5.9xx, I installed optimus-manager, configured sddm.conf, enabled optimus with systemctl enable optimus-manager.service put in my password and rebooted, I was able to switch between intel and Nvidia.
  2. I changed from stable branch to testing, downloaded every update and rebooted, still on kernel 5.9xx. Switched to Nvidia using optimus-manager, which was no problem
  3. Installed kernel 5.10xx and rebooted, checked if I was running kernel 5.10 (which I am/was depending on when you read this), tried to change to Nvidia using optimus-manager, and got this error
inxi -Fazy
  Kernel: 5.10.2-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=010ae137-0d3b-4682-b22a-64ee4f8e451e rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: KDE Plasma 5.20.4 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Laptop System: HP product: HP Pavilion Gaming Laptop 15-cx0xxx 
  v: Type1ProductConfigId serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: HP model: 8478 v: 70.57 serial: <filter> UEFI: Insyde v: F.22 
  date: 04/21/2020 
  ID-1: BAT1 charge: 26.7 Wh condition: 26.7/52.8 Wh (51%) volts: 12.9/11.6 
  model: Hewlett-Packard PABAS0241231 type: Li-ion serial: <filter> 
  status: Full 
  Info: Quad Core model: Intel Core i5-8300H bits: 64 type: MT MCP 
  arch: Kaby Lake note: check family: 6 model-id: 9E (158) stepping: A (10) 
  microcode: DE L2 cache: 8 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 36812 
  Speed: 800 MHz min/max: 800/4000 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 
  4: 801 5: 800 6: 800 7: 800 8: 800 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel UHD Graphics 630 vendor: Hewlett-Packard driver: i915 
  v: kernel bus ID: 00:02.0 chip ID: 8086:3e9b 
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: Hewlett-Packard 
  driver: N/A alternate: nouveau bus ID: 01:00.0 chip ID: 10de:1c8d 
  Device-3: Cheng Uei Precision Industry (Foxlink) HP Wide Vision HD 
  Integrated Webcam 
  type: USB driver: uvcvideo bus ID: 1-5:5 chip ID: 05c8:03bc 
  Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: modesetting 
  display ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x193mm (13.5x7.6") 
  diag: 394mm (15.5") 
  OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.3.1 
  direct render: Yes 
  Device-1: Intel Cannon Lake PCH cAVS vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci 
  bus ID: 00:1f.3 chip ID: 8086:a348 
  Sound Server: ALSA v: k5.10.2-2-MANJARO 
  Device-1: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter 
  vendor: Hewlett-Packard driver: rtw_8822be v: N/A modules: rtw88_8822be 
  port: 4000 bus ID: 02:00.0 chip ID: 10ec:b822 
  IF: wlo1 state: up mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Hewlett-Packard driver: r8169 v: kernel port: 3000 bus ID: 05:00.0 
  chip ID: 10ec:8168 
  IF: eno1 state: down mac: <filter> 
  Local Storage: total: 1.6 TiB used: 521.33 GiB (31.9%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: MZVLW256HEHP-000H1 
  size: 238.47 GiB block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
  lanes: 4 serial: <filter> rev: CXB73H1Q temp: 40.9 C 
  ID-2: /dev/sda maj-min: 8:0 type: USB vendor: Western Digital 
  model: WD My Passport 0740 size: 465.73 GiB block size: physical: 512 B 
  logical: 512 B serial: <filter> rev: 1007 
  ID-3: /dev/sdb maj-min: 8:16 type: USB vendor: Toshiba 
  model: External USB 3.0 size: 931.51 GiB block size: physical: 512 B 
  logical: 512 B serial: <filter> rev: 5438 
  ID-1: / raw size: 238.17 GiB size: 233.43 GiB (98.01%) 
  used: 11.65 GiB (5.0%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2 
  ID-2: /boot/efi raw size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 312 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 
  Alert: No Swap data was found. 
  System Temperatures: cpu: 56.0 C mobo: 29.8 C 
  Fan Speeds (RPM): N/A 
  Processes: 251 Uptime: 16m wakeups: 1 Memory: 15.53 GiB 
  used: 1.9 GiB (12.2%) Init: systemd v: 247 Compilers: gcc: 10.2.0 Packages: 
  pacman: 1324 lib: 405 flatpak: 0 Shell: Zsh v: 5.8 default: Bash v: 5.1.0 
  running in: konsole inxi: 3.2.01 

optimus-manager log

[7] INFO: # Xorg pre-start hook
[7] INFO: Previous state was: {'type': 'pending_pre_xorg_start', 'requested_mode': 'nvidia', 'current_mode': 'intel'}
[7] INFO: Requested mode is: nvidia
[7] INFO: Checking for GDM display servers
[87] INFO: Available modules: ['nouveau']
[87] INFO: Unloading modules ['nouveau'] (if loaded)
[114] INFO: Loading module nvidia
[114] ERROR: Xorg pre-start setup error
Traceback (most recent call last):
  File "/usr/lib/python3.9/site-packages/optimus_manager/hooks/", line 45, in main
    setup_kernel_state(config, prev_state, requested_mode)
  File "/usr/lib/python3.9/site-packages/optimus_manager/", line 21, in setup_kernel_state
  File "/usr/lib/python3.9/site-packages/optimus_manager/", line 56, in _nvidia_up
    _load_nvidia_modules(config, available_modules)
  File "/usr/lib/python3.9/site-packages/optimus_manager/", line 109, in _load_nvidia_modules
    _load_module(available_modules, "nvidia", options="NVreg_UsePageAttributeTable=%d" % pat_value)
  File "/usr/lib/python3.9/site-packages/optimus_manager/", line 175, in _load_module
    raise KernelSetupError(
optimus_manager.kernel.KernelSetupError: module nvidia is not available for current kernel. Is the corresponding package installed ?
[115] INFO: Removing /etc/X11/xorg.conf.d/10-optimus-manager.conf (if present)
[115] INFO: Writing state {'type': 'pre_xorg_start_failed', 'switch_id': '20201223T093224', 'requested_mode': 'nvidia'}

I should note that I found mention of similar problem in unstable notification, where rebuilding kernel 5.10 seemed to be the answer.

sudo mhwd -a pci nonfree 0300


nvidia-utils and nvidia-455xx-utils are in conflict

So far I have tried:

Uninstall nvidia-utils and nvidia-455xx-utils using sudo pacman -R nvidia-utils nvidia-455xx-utils which only throws an error regarding conflicts with other programs (kernel 5.9, and more)

Uninstalled optimus-manager and optimus-manager-qt, then reconfigure existing kernel with sudo mkinitcpio -p linux510 rebooted. Then I installed optimus-manager and optimus-manager-qt again. Tried switching, didn’t work. Tried reconfiguring kernel again, rebooted and tried switching again. No luck.

Using kernel 5.9.16 (which is almost EOL), switching works fine, no problems and Nvidia is active.

Im definitely a noob with kernels but have you tried downloading both repos and seeing if there’s any patches missing in 5.10?

Installing optimus-manager-git from AUR got the thing working, finally.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.