Kept using a gamepad, OS warns of suspension due to inactivity

I connected a PS4 wireless controller via Bluetooth. I did not install any other special driver or anything for the controller. I used Retroarch to play some games, and the problem is that even though I had been pressing the buttons on the game controller, after a while, the screen got dimmer and a popup was saying that the system would soon get suspended due to inactivity.

How to fix this? Basically, it seems that the OS is not considering the inputs from the game controller as using the system, unlike keyboard or mouse.

Hi @kingofmanjar0,

I don’t use Gnome, but I immediate though it’s something like this. According to this page:

The solution is to disable automatic suspend:

  1. Open GNOME Control Center, go to Power tab (or simply gnome-control-center power)
  2. In Suspend & Power Button set Automatic suspend, to Off when Plugged In.

Hope this helps!


Also on that page:


Setting->Power : Suspend: “off”

Or open a terminal, and execute the command:

gsettings set org.gnome.settings-daemon.plugins.power sleep-inactive-ac-type 'nothing'

I don’t use GNOME, either, but is that a message from GNOME itself, or from RetroArch?

Did you enable this option under RetroArch:
Settings → Video → Supend Screensaver → On

1 Like

That option was on by default. And in my experience, it does not prevent the automatic suspension due to inactivity. I was using 5 minutes for battery mode. You can test it more easily by setting the time to 1 minute. In the Settings → Power → Power Saving Options → Automatic Suspend, the shortest amount is 15 minutes but you can set shorter amount like 1 minute by executing

gsettings set org.gnome.settings-daemon.plugins.power sleep-inactive-battery-timeout 60

(60 means 60 seconds = 1 minute).

Try setting the timeout to 1 minute and use only the wireless gamepad for 1 minute (no keyboard/mouse). Does your computer not go into sleep mode?

This is probably a GNOME or GNOME + RetroArch issue.

Under KDE, even if I don’t press any buttons on my gamepad, the system will not suspend nor lock, as long as RetroArch is open.

If I close RetroArch and wait, then the system will suspend based on the configuration under the power options. (I tested this with a 1-minute setting.)