Kein Weg führt an grub rescue bei der Installation vorbei.

grub
#1

Hallo,
ich möchte auf meinem Thinkpad mit zwei SSDs, auf der 1. ist schon Win10, Manjaro Cinnamon installieren.
Allerdings lande ich beim booten über USB immer in grub rescue.
Folgendes habe ich schon probiert:

  • boot repair disk
  • grub über Ubuntu zu updaten, root partition mounten
  • alle möglichen Befehle um den grub Ordner festzulegen (set root=(hd1)...), Efi Verzeichnis kann nicht gefunden werden
  • Boot mit Win10 live Stick -> Computerreparatur -> cmd -> Bootrec /fixmbr, Win Starthilfe
  • Installation von Manjaro Cinnamon, Architect, XFCE
    Leider hat bisher nichts geholfen.
    Mit mx und Arch funktioniert die Installation einwandfrei.
    Danke schonmal im Voraus.
    comqoy
#2

Hast du die SHA256 Checksumme des *.isos geprüft? Wie hast du den USB-Stick erstellt? Wenn ich mich richtig erinnere benötigen so gut wie alle isos noch bei Rufus den dd-Modus (das wird aber zur Zeit angegangen: Make Manjaro installer images work with Rufus), bzw. müssen mit balena Etcher / dd erstellt werden. Dazu gibt es auch einige Forum-Threads z.B. Create Bootable USB
Wenn ich dich richtig verstanden habe kannst du auf dem Stick nicht booten und landest in Grub-Rescue?
Ansonsten wären ein paar Informationen über deine Hardware vielleicht nicht schlecht d.h. am Besten inxi -Fxxxz und als Text reinstellen, markieren und den </> Button verwenden (dann wird das als Code formatiert)

#3

Ja genau ich lande immer im Grub Rescue allerdings nur bei Manjaro .isos
Erstellt hab ich die Sticks mit Rufus und Unetbootin (habe das mehrfach probiert). Ich werde mal schnell ein anderes Programm ausprobieren.


Betriebssystemname:                            Microsoft Windows 10 Pro
Betriebssystemversion:                         10.0.17134 Nicht zutreffend Build 17134
Betriebssystemhersteller:                      Microsoft Corporation
Betriebssystemkonfiguration:                   Eigenständige Arbeitsstation
Betriebssystem-Buildtyp:                       Multiprocessor Free
Registrierter Benutzer:                        
Registrierte Organisation:                     Nicht zutreffend
Produkt-ID:                                    
Ursprüngliches Installationsdatum:             13.02.2019, 14:59:18
Systemstartzeit:                               04.05.2019, 21:08:03
Systemhersteller:                              LENOVO
Systemmodell:                                  20KTA001GE
Systemtyp:                                     x64-based PC
Prozessor(en):                                 1 Prozessor(en) installiert.
                                               [01]: Intel64 Family 6 Model 142 Stepping 10 GenuineIntel ~1801 MHz
BIOS-Version:                                  LENOVO R0PET42W (1.19 ), 14.06.2018
Windows-Verzeichnis:                           C:\windows
System-Verzeichnis:                            C:\windows\system32
Startgerät:                                    \Device\HarddiskVolume3
Systemgebietsschema:                           de;Deutsch (Deutschland)
Eingabegebietsschema:                          de;Deutsch (Deutschland)
Zeitzone:                                      (UTC+01:00) Brüssel, Kopenhagen, Madrid, Paris
Gesamter physischer Speicher:                  8.089 MB
Verfügbarer physischer Speicher:               3.880 MB
Virtueller Arbeitsspeicher: Maximale Größe:    9.369 MB
Virtueller Arbeitsspeicher: Verfügbar:         4.048 MB
Virtueller Arbeitsspeicher: Zurzeit verwendet: 5.321 MB
Auslagerungsdateipfad(e):                      C:\pagefile.sys
Domäne:                                        
Anmeldeserver:                                 \\DESKTOP-HS2N90M

Netzwerkkarte(n):                              3 Netzwerkadapter installiert.
                                               [01]: Realtek 8822BE Wireless LAN 802.11ac PCI-E NIC
                                                     Verbindungsname: WLAN
                                                     Status:          Medien getrennt
                                               [02]: Realtek PCIe GbE Family Controller
                                                     Verbindungsname: Ethernet
                                                     DHCP aktiviert:  Ja
                                                     DHCP-Server:   
                                                     IP-Adresse(n)
                                                     
                                               [03]: TAP-Windows Adapter V9
                                                     Verbindungsname: Ethernet 2
                                                     Status:          Medien getrennt
Anforderungen für Hyper-V:                     Erweiterungen für den VM-Überwachungsmodus: Ja
                                               Virtualisierung in Firmware aktiviert: Nein
                                               Adressübersetzung der zweiten Ebene: Ja
                                               Datenausführungsverhinderung verfügbar: Ja

Da ich nur in Windows unterwegs hab ich mal die systeminfo rein.

#4

Unetbootin funktioniert mit Manjaro meines Wissens nicht, bei Rufus muss der dd-Modus verwendet werden.

1 Like
#6

Ich hab es grade mit dem Linux Live USB Creator ausprobiert und damit geht es leider auch nicht.

#7

Versuchs mal mit etcher:


Damit hatten die meisten bisher keine Probleme

2 Likes
#8

Du solltest auch mal die sha1sum der iso kontrollieren.

Wenn Du nur Windows hast geht es zum Beispiel mit
"CompareChecksum ".
http://checksumcompare.sanktuaire.com/home

Der Wert deiner iso sollte so sein.
SHA1: 96dd0f5b4d5ec9eba65ae9bc86c843b85915f02b

1 Like
#9

Vielleicht funktioniert es, wenn du den Boot-Modus "Security" oder "Sicherheit" im BIOS deaktivierst oder auf "Standard-Boot" stellst. Falls du solche Optionen hast. Manchmal muss man auch erst das Boot-Image dem BIOS "bekannt" machen. Vielleicht hast du auch so eine Option. Grub Rescue wird eigentlich immer dann geladen, wenn das System vom UEFI gesperrt wurde oder das System schrott ist oder die Startpartition nicht vorhanden ist. Und keine Ahnung wann noch. :sweat_smile:

1 Like
#10

Hallo comqoy,

da dies selten kommentarlos geschieht, wären eventuelle vorherige Meldungen auch interessant, etwa so was:

error: no such device: < a uuid >
error: unknown filesystem
Entering rescue mode...
grub rescue>

oder was immer Grub da meckert.

viele Grüße gosia

1 Like
#11

Ich habe es jetzt mit BalenaEtcher mit verschiedenen .isos (cinnamon, kfce, architect) ausprobiert und da erkannte mein Laptop anfangs gar keinen Stick mehr und is direkt in Windows gebootet.
Nach vielen Neustarts und Formatierungen hat es letztendlich nur mit der kfce und architect geklappt. Cinnamon wird gar nicht erkannt. Damit hab ich mich aber mittlerweile zufrieden gegeben.

da dies selten kommentarlos geschieht, wären eventuelle vorherige Meldungen auch interessant, etwa so was:

error: no such device: < a uuid >
error: unknown filesystem
Entering rescue mode...
grub rescue>

oder was immer Grub da meckert.

Es stand immer dran, dass das Dateisystem unbekannt ist.

Vielen Dank für den Tipp mit BalenaEtcher auch wenn das nicht reibungslos funktioniert hat.
Hat nur Manjaro Probleme mit Live USB Programmen?