KeepassXC won't autostart in minimized state, at system login

KeepassXC (from mainline repo) won't start minimized even though I have the option toggled in the program. Upon login it is open and I have to close it or minimize it everytime. Not an issue on Ubuntu.

Is there a startup parameter I can use to force this?

System:
  Host: manjaro-xfce-desktop Kernel: 5.4.35-1-MANJARO x86_64 bits: 64 
  compiler: gcc v: 9.3.0 Desktop: Xfce 4.14.2 Distro: Manjaro Linux 
Machine:
  Type: Desktop System: Gigabyte product: N/A v: N/A serial: <root required> 
  Mobo: Gigabyte model: 990FXA-UD3 v: x.x serial: <root required> 
  UEFI: American Megatrends v: F3 date: 05/28/2015 
CPU:
  Topology: 6-Core model: AMD FX-6350 bits: 64 type: MCP arch: Bulldozer 
  L2 cache: 2048 KiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 47037 
  Speed: 1498 MHz min/max: 1400/3900 MHz Core speeds (MHz): 1: 1533 2: 1742 
  3: 3209 4: 2974 5: 1406 6: 1406 
Graphics:
  Device-1: AMD Hawaii XT / Grenada XT [Radeon R9 290X/390X] 
  vendor: XFX Pine driver: amdgpu v: kernel bus ID: 01:00.0 
  Display: x11 server: X.Org 1.20.8 driver: amdgpu,ati 
  unloaded: modesetting,radeon resolution: 1920x1080~60Hz 
  OpenGL: renderer: AMD Radeon R9 390 Series (HAWAII DRM 3.35.0 
  5.4.35-1-MANJARO LLVM 10.0.0) 
  v: 4.6 Mesa 20.0.5 direct render: Yes 
Audio:
  Device-1: AMD SBx00 Azalia vendor: Gigabyte driver: snd_hda_intel 
  v: kernel bus ID: 00:14.2 
  Device-2: AMD Hawaii HDMI Audio [Radeon R9 290/290X / 390/390X] 
  vendor: XFX Pine driver: snd_hda_intel v: kernel bus ID: 01:00.1 
  Device-3: Kingston HyperX Virtual Surround Sound type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus ID: 7-5:4 
  Sound Server: ALSA v: k5.4.35-1-MANJARO 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Gigabyte driver: r8169 v: kernel port: b000 bus ID: 05:00.0 
  IF: enp5s0 state: up speed: 100 Mbps duplex: full mac: fc:aa:14:e0:d8:71 
  Device-2: Broadcom and subsidiaries BCM4360 802.11ac Wireless Network 
  Adapter 
  driver: bcma-pci-bridge v: N/A port: b000 bus ID: 06:00.0 
  IF-ID-1: wgpia0 state: unknown speed: 10 Mbps duplex: full mac: N/A 
Drives:
  Local Storage: total: 2.96 TiB used: 1.42 TiB (47.9%) 
  ID-1: /dev/sda vendor: Seagate model: ST1000DM003-1ER162 size: 931.51 GiB 
  ID-2: /dev/sdb vendor: Samsung model: SSD 850 EVO 250GB size: 232.89 GiB 
  ID-3: /dev/sdc vendor: Western Digital model: WD10EZEX-08WN4A0 
  size: 931.51 GiB 
  ID-4: /dev/sdd vendor: Crucial model: CT1000MX500SSD1 size: 931.51 GiB 
Partition:
  ID-1: / size: 37.30 GiB used: 13.70 GiB (36.7%) fs: ext4 dev: /dev/sdd2 
  ID-2: /home size: 734.15 GiB used: 516.09 GiB (70.3%) fs: ext4 
  dev: /dev/sdd3 
  ID-3: swap-1 size: 7.63 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sdd4 
Sensors:
  System Temperatures: cpu: 24.9 C mobo: N/A gpu: amdgpu temp: 41 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 267 Uptime: 1h 38m Memory: 15.60 GiB used: 2.24 GiB (14.3%) 
  Init: systemd Compilers: gcc: 9.3.0 Shell: bash v: 5.0.16 inxi: 3.0.37

I' m also interested in a solution.
I use KeePassXC on KDE and see the same behavior.

Hello,

I've got my KeePassXC autostarting in systray after login, so no window appear, I don't recall how I managed it to work but this are my settings :

I've got KDE running, so I just add manually the app in my autostart application under KDE settings manager, command is (I just add it from the apps selection when clicking add new app) :

keepassxc %f

Hope this help !

Does %f force it to start minimized?

I have the same app settings enabled. I too have a startup tool that shows keepassxc

EDIT:
i tried appending %f to the end of my keepassxc command in startup and it did not solve the porblem.

so I just deleted the ~/.config/keepassxc file and set it up again, and toggled on these settings: "minimize window at application startup" and "minimize instead of app exit" and "show a system tray icon". Then exited it. I checked the startup interface for manjaro xfce and it didn't show keepassxc. Rebooted, and keepass started minimized to the tray! Don't know what the deal was but I've solved it.

Forum kindly sponsored by