Keep running out of disk space => xorg-session.log

I’ve been having this weird issue with manjaro for a few weeks now. I keep running out of disk space even though I am not installing anything new on the system. I did some digging as to what is the culprit and I found out that the log file “xorg-session.log” located at “/home/user/.local/share/sddm” will grow till there’s no more space on the partition.

I delete the file but it keeps coming back.

Welcome at the Manjaro forum, @Grafdude :tada:

Can you please post the output of the command

systemctl status systemd-tmpfiles-clean.timer

And please provide some background data to your system:

inxi -Fazy
2 Likes

Post Deleted

Did you check the actual log entries in that logfile to investigate and hopefully remedy the underlying problem?

I didn’t even look at it lol. I figured a 4GB log file would be a lot to look at, I have very basic knowledge of linux/manjaro.

Post Deleted

Thanks for the welcome Wollie! :slight_smile: Apologies for the late reply, here’s the output of “systemctl…”

● systemd-tmpfiles-clean.timer - Daily Cleanup of Temporary Directories
Loaded: loaded (/usr/lib/systemd/system/systemd-tmpfiles-clean.timer; static)
Active: active (waiting) since Wed 2020-10-14 06:51:36 EDT; 21h ago
Trigger: Thu 2020-10-15 23:52:08 EDT; 19h left
Triggers: ● systemd-tmpfiles-clean.service
Docs: man:tmpfiles.d(5)
man:systemd-tmpfiles(8)
Oct 14 06:51:36 luke-ms7a11 systemd[1]: Started Daily Cleanup of Temporary Directories.

and inxi -Fazy:

Kernel: 5.8.11-1-MANJARO x86_64 bits: 64 compiler: N/A
parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64
root=UUID=21443445-2e47-41b4-9709-1a79dab8c8b2 rw quiet apparmor=1
security=apparmor udev.log_priority=3
Desktop: KDE Plasma 5.19.5 tk: Qt 5.15.1 info: latte-dock wm: kwin_x11
dm: SDDM Distro: Manjaro Linux
Machine:
Type: Desktop Mobo: MSI model: Z170A KRAIT GAMING 3X (MS-7A11) v: 1.0
serial: UEFI: American Megatrends v: 2.B0 date: 07/03/2018
CPU:
Topology: Quad Core model: Intel Core i5-6500 bits: 64 type: MCP
arch: Skylake-S family: 6 model-id: 5E (94) stepping: 3 microcode: D6
L2 cache: 6144 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
bogomips: 25610
Speed: 1515 MHz min/max: 800/3600 MHz Core speeds (MHz): 1: 1515 2: 1140
3: 1129 4: 935
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled
Type: mds mitigation: Clear CPU buffers; SMT disabled
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
IBRS_FW, STIBP: disabled, RSB filling
Type: srbds status: Vulnerable: No microcode
Type: tsx_async_abort mitigation: Clear CPU buffers; SMT disabled
Graphics:
Device-1: NVIDIA GP106 [GeForce GTX 1060 3GB] vendor: Micro-Star MSI
driver: nvidia v: 440.100 alternate: nouveau,nvidia_drm bus ID: 01:00.0
chip ID: 10de:1c02
Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: nvidia
display ID: :0 screens: 1
Screen-1: 0 s-res: 3840x2160 s-dpi: 162 s-size: 602x341mm (23.7x13.4")
s-diag: 692mm (27.2")
Monitor-1: DP-4 res: 3840x2160 hz: 60 dpi: 163 size: 600x340mm (23.6x13.4")
diag: 690mm (27.2")
OpenGL: renderer: GeForce GTX 1060 3GB/PCIe/SSE2 v: 4.6.0 NVIDIA 440.100
direct render: Yes
Audio:
Device-1: Intel 100 Series/C230 Series Family HD Audio
vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus ID: 00:1f.3
chip ID: 8086:a170
Device-2: NVIDIA GP106 High Definition Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:10f1
Sound Server: ALSA v: k5.8.11-1-MANJARO
Network:
Device-1: Intel Ethernet I219-V vendor: Micro-Star MSI driver: e1000e
v: 3.2.6-k port: f000 bus ID: 00:1f.6 chip ID: 8086:15b8
IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac:
Drives:
Local Storage: total: 1.13 TiB used: 390.37 GiB (33.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda vendor: Kingston model: SA400S37240G size: 223.57 GiB
block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s serial:
rev: 0102 scheme: GPT
ID-2: /dev/sdb vendor: Western Digital model: WD1001FALS-00J7B0
size: 931.51 GiB block size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
serial: rev: 0K05 scheme: GPT
Partition:
ID-1: / raw size: 33.72 GiB size: 32.94 GiB (97.69%) used: 26.91 GiB (81.7%)
fs: ext4 dev: /dev/sda6
Swap:
Kernel: swappiness: 60 (default) cache pressure: 100 (default)
ID-1: swap-1 type: partition size: 8.25 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/sda7
Sensors:
System Temperatures: cpu: 29.8 C mobo: 28.0 C gpu: nvidia temp: 40 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info:
Processes: 228 Uptime: 21h 54m Memory: 15.60 GiB used: 4.95 GiB (31.7%)
Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: 1353 pacman: 1336
lib: 361 flatpak: 10 snap: 7 Shell: Bash v: 5.0.18 running in: konsole
inxi: 3.1.05

Here’s a few lines of the log

Sandbox: unsupported flags 2048 in fstatat(-100, “/home/luke/.config/gtk-3.0/colors.css”, 0x7F3057BFD8A0, 2304)
Sandbox: seccomp sandbox violation: pid 1570, tid 82480, syscall 262, args 4294967196 139845615602320 139845607348384 2304 2304 1.
Sandbox: unsupported flags 2048 in fstatat(-100, “/home/luke/.config/gtk-3.0/colors.css”, 0x7F5EBA1FD8A0, 2304)
Sandbox: seccomp sandbox violation: pid 1472, tid 82542, syscall 262, args 4294967196 140044833471984 140044826302624 2304 2304 1.
Sandbox: unsupported flags 2048 in fstatat(-100, “/home/luke/.config/gtk-3.0/colors.css”, 0x7EFDF59FD8A0, 2304)
Sandbox: seccomp sandbox violation: pid 1392, tid 82536, syscall 262, args 4294967196 139629725265392 139629212719264 2304 2304 1.
Sandbox: unsupported flags 2048 in fstatat(-100, “/home/luke/.config/gtk-3.0/colors.css”, 0x7F70442FD8A0, 2304)
Sandbox: unsupported flags 2048 in fstatat(-100, “/home/luke/.config/gtk-3.0/colors.css”, 0x7F77DBBFD8A0, 2304)
Sandbox: seccomp sandbox violation: pid 2486, tid 82535, syscall 262, args 4294967196 140120165182096 140120157051040 2304 2304 1.
Sandbox: seccomp sandbox violation: pid 10070, tid 82491, syscall 262, args 4294967196 140153295039984 140152764618912 2304 2304 1.
Sandbox: unsupported flags 2048 in fstatat(-100, “/home/luke/.config/gtk-3.0/colors.css”, 0x7F4BA09FD8A0, 2304)
Sandbox: unsupported flags 2048 in fstatat(-100, “/home/luke/.config/gtk-3.0/colors.css”, 0x7F504CCFD8A0, 2304)
Sandbox: seccomp sandbox violation: pid 66876, tid 82540, syscall 262, args 4294967196 139962801286640 139962794104992 2304 2304 1.
Sandbox: seccomp sandbox violation: pid 10107, tid 82541, syscall 262, args 4294967196 139989777914512 139982862801056 2304 2304 1.
Sandbox: unsupported flags 2048 in fstatat(-100, “/home/luke/.config/gtk-3.0/colors.css”, 0x7F304CAFD8A0, 2304)
Sandbox: seccomp sandbox violation: pid 1570, tid 82543, syscall 262, args 4294967196 139845614517744 139845421750432 2304 2304 1.
Sandbox: unsupported flags 2048 in fstatat(-100, “/home/luke/.config/gtk-3.0/colors.css”, 0x7F5EB99FC8A0, 2304)
Sandbox: seccomp sandbox violation: pid 1472, tid 82473, syscall 262, args 4294967196 140044834249216 140044817909920 2304 2304 1.
Sandbox: unsupported flags 2048 in fstatat(-100, “/home/luke/.config/gtk-3.0/colors.css”, 0x7F9631FFD8A0, 2304)
Sandbox: unsupported flags 2048 in fstatat(-100, “/home/luke/.config/gtk-3.0/colors.css”, 0x7F96707078A0, 2304)
Sandbox: seccomp sandbox violation: pid 5769, tid 82505, syscall 262, args 4294967196 140284217059984 140283060672672 2304 2304 1.
Sandbox: seccomp sandbox violation: pid 5769, tid 82544, syscall 262, args 4294967196 140284216045040 140284108241056 2304 2304 1.

I would update by

sudo pacman-mirrors -f && sudo pacman -Syyu

first.

Then, in your case I also would check if there is a new Nvidia driver for your graphic card.

Last but not least I would check if there is something wrong with you package gtk-3.0 as is generates all these error lines in the log file.

post deleted

Thanks for your reply Wollie! My system is up to date. I’m on the nvidia 440 driver.

There is the 450 driver available, I attempted to update it with no success.

From the GUI hardware menu i tried installing the 450 returns this error:

Starting
Error: config ‘video-nvidia-450xx’ conflicts with config(s): video-nvidia-440xx

Done …

I thought I might have to remove/uninstall the 440 driver first, attempting that also returns an error:

Starting

Removing video-nvidia-440xx…

Sourcing /etc/mhwd-x86_64.conf

Has lib32 support: true

Sourcing /var/lib/mhwd/local/pci/video-nvidia-440xx/MHWDCONFIG

Processing classid: 0300

Sourcing /var/lib/mhwd/scripts/include/0300

Processing classid: 0302

checking dependencies…

error: failed to prepare transaction (could not satisfy dependencies)

:: removing linux58-nvidia-440xx breaks dependency ‘linux58-nvidia-440xx’ required by linux-latest-nvidia-440xx

Error: pacman failed!

Error: script failed!

Done …