Keep 'ARK: Survival Evolved' maximized - currently minimizing but running WindowedFullscreen

Hi,

I’ve just installed ARK: Survival Evolved on my machine, through Steam.

After starting it, i changed the “Window mode” to WindowedFullscreen, but the window keeps minimizing if i change the focus to my browser, on my other monitor.

I’m not sure if this is related to KDE, Proton, or something else. However, I’d like to have it fixed, so I can use my other monitor, without having ARK to minimize itself.

I’m not sure if it’s related to a KDE-function, or if it’s 100% related to the game-engine.

How can I have a borderless-like execution of the game, and keep it maximized, even if i use the second monitor in my setup?

I hope someone can help me out.

System related information

KDE Plasma Version: 5.21.5

System info

Operating System: Manjaro Linux
KDE Plasma Version: 5.21.5
KDE Frameworks Version: 5.82.0
Qt Version: 5.15.2
Kernel Version: 5.9.16-1-MANJARO
OS Type: 64-bit
Graphics Platform: X11
Processors: 12 × Intel® Core™ i7-8700 CPU @ 3.20GHz
Memory: 62,7 GiB of RAM
Graphics Processor: AMD Radeon RX 5700 XT

mhwd -l -d
--------------------------------------------------------------------------------
> PCI Device: /devices/pci0000:00/0000:00:01.0/0000:01:00.0/0000:02:00.0/0000:03:00.0 (..removed...)
  Display controller ATI Technologies Inc Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT]
--------------------------------------------------------------------------------
  > INSTALLED:

   NAME:        video-linux
   ATTACHED:    PCI
   VERSION:     2018.05.04
   INFO:        Standard open source drivers.
   PRIORITY:    2
   FREEDRIVER:  true
   DEPENDS:     -
   CONFLICTS:   -
   CLASSIDS:    0300 0380 0302 
   VENDORIDS:   1002 8086 10de 



  > AVAILABLE:

   NAME:        video-linux
   ATTACHED:    PCI
   VERSION:     2018.05.04
   INFO:        Standard open source drivers.
   PRIORITY:    2
   FREEDRIVER:  true
   DEPENDS:     -
   CONFLICTS:   -
   CLASSIDS:    0300 0380 0302 
   VENDORIDS:   1002 8086 10de 

   NAME:        video-modesetting
   ATTACHED:    PCI
   VERSION:     2020.01.13
   INFO:        X.org modesetting video driver.
   PRIORITY:    1
   FREEDRIVER:  true
   DEPENDS:     -
   CONFLICTS:   -
   CLASSIDS:    0300 
   VENDORIDS:   * 

   NAME:        video-vesa
   ATTACHED:    PCI
   VERSION:     2017.03.12
   INFO:        X.org vesa video driver.
   PRIORITY:    0
   FREEDRIVER:  true
   DEPENDS:     -
   CONFLICTS:   -
   CLASSIDS:    0300 
   VENDORIDS:   * 
Graphics-part of `inxi --admin --verbosity=7 --filter --no-host --width`
Graphics:
  Device-1: Intel UHD Graphics 630 vendor: ASUSTeK driver: vfio-pci v: 0.2 
  alternate: i915 bus-ID: 00:02.0 chip-ID: 8086:3e92 class-ID: 0380 
  Device-2: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT] 
  vendor: Sapphire Limited driver: amdgpu v: kernel bus-ID: 03:00.0 
  chip-ID: 1002:731f class-ID: 0300 
  Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: 
  loaded: amdgpu display-ID: :0 screens: 1 
  Screen-1: 0 s-res: 5120x1440 s-dpi: 96 s-size: 1354x381mm (53.3x15.0") 
  s-diag: 1407mm (55.4") 
  Monitor-1: DisplayPort-2 res: 2560x1440 hz: 60 dpi: 118 
  size: 553x311mm (21.8x12.2") diag: 634mm (25") 
  Monitor-2: DisplayPort-3 res: 2560x1440 hz: 60 dpi: 118 
  size: 553x311mm (21.8x12.2") diag: 634mm (25") 
  OpenGL: renderer: AMD Radeon RX 5700 XT (NAVI10 DRM 3.39.0 5.9.16-1-MANJARO 
  LLVM 12.0.0) 
  v: 4.6 Mesa 21.1.2 direct render: Yes 

Things I’ve tired

1) Tried to change the GameUserSettings.ini file, to see if there’s better things to do
Didn’t help.

2) Selected the ingame “Window”-mode, and used KDE’s “Fullscreen” mode instead, so it’s more like a borderless game experience instead.
That actually works, however, the window of ARK not can’t be forced to “Fullscreen” mode, nor resized:
image
And the game itself, are not resizing to 2560x1440 as selected:

3) Started the game with normal settings, moved it to the right monitor, and selected “Fullscreen” in the “More Actions” KDE-menu
Doen’t help. It’s still minimizing the game-window.

You can start by using google looking for “ark survival evolved minimizing”. You’ll see posts going back to 2015 where people talk about the issue.

You can also check ProtonDB to see if people talk about the issue

TL;DR : The native execution of ARK, are still a bit of a pain, if we talk about borderless gaming. With Proton, it works as expected. I ended up using Proton 4.11-13, with a few small changes. Check the last section of the post.


Hi

image
Yep, that’s why I am here. I couldn’t find anything, after searching for more than half an hour.

Now I’m trying to ask here.


The tip about using the ProtonDB, are actually a good tip. I didn’t think about that.

Proton 6.3-5

I’ve switched to Proton 6.3-5, selected the version without BattlEye and so, cause one mentioned this:

The default steam install is borked in several ways, most notably full screen stretches the window beyond the monitor. Proton solved this.

Now the WindowedFullscreen works as expected, however, it’s laggy as …

Proton 5.13-6

Jumped to Proton 5.13-6.

Now the window can’t be moved on the monitor. However, by selectiong WindowedFullscreen. Hereafter, I created a custom rule for the window:

Proton 4.11-13

Jumped to Proton 4.11-13.

Added the launch options: -USEALLAVAILABLECORES -nomansky -low -sm4 -lowmemory -novsync
Selected the first “Play ARK: Survival Evolved”, as launch options else will be removed.

Remove BattlEye with the Steam-launch option, if needed. And start the game without BattlEye, by pressing “Cancel”, and use the “Don’t ask again” checkbox…

The WindowedFullscreen still works, and the performance is… acceptable.