KDialog not showing previews for file sizes higher than 3mb

Hi,

I am struggling for several days with this problem I can not solve. All programs that use KDialog, specially chromium/firefox, don’t show preview of JPG files higher than 3mb in file size. As I need for work to upload high resolution images, this is getting annoying to open dolphin, check thumbnail and filename, then return to chromium(KDialog) and select the right file. I can see previews/thumbnails of image files below 3mb, but unfortunately most of my work relates to files with file sizes higher than that.

Dolphin shows all files properly.

I checked the file kdialogrc in /.config, but I see no option to increase file size image preview.

Is there actually any way to increase it to KDialog? Any help or suggestion? Lately I had to switch to windows in order to do the upload fast without switching windows and checking. I need to get rid of windows and delete that partition once and all, specially now I can use photoshop in a VM.

Thank you!!!

1 Like

Can it be it works with the setting in Dolphin:
Configure Dolphin --> General --> Previews
At the bottom of the window: Skip previews for remote files above: xxMB
I have no idea, but I know about this setting.

Thank you for your answer, but Dolphin works OK, shows all previews. It is something related to KDialog and limit the preview filesize, but I can’t find the answer anywhere. Even looked at KDialog code, but I don’t have a clue.

Have a look here: Chromium to download files with the appropriate extension
It seems there are issues with Kdialog. Not the same as what you experience but it could somehow be related.

Without KDialog, with the default file selector, we do not have previews of any kind. Besides, seems that bug is fixed, you just need to uncheck the append extensión (.bin) and that’s it.

If I start KDialog from command line:

kdialog --getopenfilename

The same behaviour happens, that is, no previews for files above 3mb. I suspect there is a limit hardcoded in KDialog.

Can you check if you see previews on photos over 3mb in your system using the above command line?

I can’t tell if the limit is indeed 3MB, but I also don’t see previews in Kdialog. I must say I have never used it although it is installed.

Definitely there is something wrong there. For me is a must to check previews with file selector, there must be a solution, I don’t think linux can’t handle this. Manjaro is my world now, so I will make that work or I will throw away all my technology, house, wife and car, climb a mountain and live alone with my cat in a self made hut.

1 Like

I use Dolphin for that and that works great, also for larger files.
As said, I have never ever used Kdialogs before, didn’t even know it existed till you wrote about it.

Living on a mountain doesn’t sound so bad, but with a cat?

Yes, I need to talk to someone every now and then :smiley:

Well, I will try to hack the KDialog code. Until then I will continue using Dolphin to check the filename, then open on KDialog. Slow, but better than nothing.

Just so I know what it is you are doing: what are you doing with Kdialogs?
Is it just the preview? That works in Dolphin when you have the sidebar (F11) selected.
What do you do with Kdialogs what you can’t do with Dolphin?
Please explain, I like to learn something new.

I upload files using Chromium, and I need the Chromium file dialog show the images thumbnails to select the right files (several actually, using CONTROL key). Chromium uses KDialog (as some other apps, like thunderbird, firefox…).

No ideas? :sob:

I can can confirm the bug. Just found your post googling the issue.

Well, still no solution here? Can we replace Kdialog?

Does this link help you in anyway: https://forum.kaosx.us/d/1767-kde-file-dialog-thumbnail-settings
I looked in my files and even though I set in Dolphin to show me previews from external source until the size of 100MB, this value does not show up in dolphinrc but in kdeglobals.
A line similar to what is copied from dolphinrc to kdeglobals is also in my dolphinrc. It’s the line which says which files should have a preview.

Just a suggestion I have no idea if it will work. Perhaps try installing the KDE Falkon web browser and try it out. It uses native KDE file dialogs, and perhaps it will play better with kdialog. Just a thought.

I have the same issue with any application using KDialog.
No way to change that?

1st WORKAROUND

Edit ~/.config/kdeglobals in section [PreviewSettings] add :

MaximumSize=xxx

xxx = Maximum size in byte


2nd WORKAROUND

another way is to:

copy those 2 files:

/usr/share/kservices5/imagethumbnail.desktop
/usr/share/kservices5/jpegthumbnail.desktop

to
~/.local/share/kservices5/

and in both of them add the following line:

IgnoreMaximumSize=true


I don’t understand where it find the value that limit so much as by default it should be really huge value (maximum unsigned 64bits integer)
there is only a MaximumRemoteSize defined to 0 for remote location. :thinking:

PS: the IgnoreMaximumSize=true will be ignored for remote location. for remote location it will just check MaximumRemoteSize of [PreviewSettings] in ~/.config/kdeglobals

for other kind of file there is also other xxxthumbnail.desktop file.

1 Like

the first workaround worked fine to me! Thanks!

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by