Kdenlive Version 20.08.1 crashes and freezes my desktop

Hello manjaro users:

I’m brand new to Manjaro and would like to make it work in my live. I’m a video content creator and chose Kdenlive 20.08.1 as my video editor. There are times when I’m editing a video and the entire desktop freezes and the only way to get out of it is by pressing the reset button on my tower. Yes, I have tried CTRL+ALT+DEL; CTRL+SHIFT+ESC with no avail. I want to make it clear that this happens only when editing videos with kdenlive tool. More specific information, the issue happens when I’m playing the entire video within the kdenlive timeline. I may have to contact kdenlive about it, but the issue here is that if kdenlive is the one causing it, why the desktop environment renders useless? It won’t respond to even CTRL+ALT+F1.


VGA compatible controller: NVIDIA Corporation GK208B [GeForce GT 710] (rev a1)
Model name: AMD Ryzen 5 3600 6-Core Processor

uname -a
5.8.11-1-MANJARO #1 SMP PREEMPT Wed Sep 23 14:35:40 UTC 2020 x86_64 GNU/Linux

$ free -h
total used free shared buff/cache available
Mem: 31Gi 1.6Gi 26Gi 167Mi 3.7Gi 29Gi
Swap: 8.8Gi 0B 8.8Gi


Please also share:
inxi -Fayz
use ``` above and bellow the text for proper formatting.

1 Like

Please read this:
[HowTo] reboot / turn off your frozen computer: REISUB/REISUO

  1. An inxi --admin --verbosity=7 --filter --no-host would be the minimum required information we need to help you further… (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)

  2. The free looks good but that’s without kdenlive running, right?
    Could you open a terminal window and type this:

    watch --interval=3 'free --human'

    and report on the numbers while the system is freezing / frozen?


@bogdancovaciu and @Fabby

Here you go:

Every 2.0s: interval=3 free --human                                                                                                                        host: Mon Oct  5 12:46:30 2020

              total        used        free      shared  buff/cache   available
Mem:           31Gi       856Mi        30Gi        66Mi       515Mi        30Gi
Swap:         8.8Gi       530Mi       8.3Gi

$ inxi --admin --verbosity=7 --filter --no-host
System:    Kernel: 5.8.11-1-MANJARO x86_64 bits: 64 compiler: N/A 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 root=UUID=hidden rw quiet apparmor=1 
           security=apparmor resume=redacted udev.log_priority=3 
           Desktop: KDE Plasma 5.19.5 tk: Qt 5.15.1 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: ROG STRIX B450-F GAMING v: Rev 1.xx serial: <filter> UEFI: American Megatrends 
           v: 3003 date: 12/09/2019 
Memory:    RAM: total: 31.35 GiB used: 1.03 GiB (3.3%) 
           RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
CPU:       Topology: 6-Core model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 2 family: 17 (23) model-id: 71 (113) 
           stepping: N/A microcode: 8701013 L2 cache: 3072 KiB bogomips: 86438 
           Speed: 2631 MHz min/max: 2200/3600 MHz boost: enabled Core speeds (MHz): 1: 3195 2: 1885 3: 2200 4: 2199 5: 1923 
           6: 2200 7: 2203 8: 2202 9: 3331 10: 2022 11: 2039 12: 2196 
           Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1 bmi2 bpext cat_l3 cdp_l3 clflush 
           clflushopt clwb clzero cmov cmp_legacy constant_tsc cpb cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total cqm_occup_llc 
           cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid f16c flushbyasid fma fpu fsgsbase fxsr fxsr_opt ht 
           hw_pstate ibpb ibs irperf lahf_lm lbrv lm mba mca mce misalignsse mmx mmxext monitor movbe msr mtrr mwaitx 
           nonstop_tsc nopl npt nrip_save nx osvw overflow_recov pae pat pausefilter pclmulqdq pdpe1gb perfctr_core 
           perfctr_llc perfctr_nb pfthreshold pge pni popcnt pse pse36 rdpid rdpru rdrand rdseed rdt_a rdtscp rep_good sep sev 
           sha_ni skinit smap smca sme smep ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3 stibp succor svm svm_lock syscall tce 
           topoext tsc tsc_scale umip v_vmsave_vmload vgif vmcb_clean vme vmmcall wbnoinvd wdt xgetbv1 xsave xsavec xsaveerptr 
           xsaveopt xsaves 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: conditional, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: NVIDIA GK208B [GeForce GT 710] vendor: Micro-Star MSI driver: nouveau v: kernel bus ID: 08:00.0 
           chip ID: 10de:128b 
           Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: nouveau unloaded: modesetting 
           alternate: fbdev,nv,vesa display ID: :0 screens: 1 
           Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1016x285mm (40.0x11.2") s-diag: 1055mm (41.5") 
           Monitor-1: HDMI-1 res: 1920x1080 hz: 60 dpi: 96 size: 509x286mm (20.0x11.3") diag: 584mm (23") 
           Monitor-2: VGA-1 res: 1920x1080 hz: 60 dpi: 106 size: 458x258mm (18.0x10.2") diag: 526mm (20.7") 
           OpenGL: renderer: NV106 v: 4.3 Mesa 20.1.8 direct render: Yes 
Audio:     Device-1: NVIDIA GK208 HDMI/DP Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus ID: 08:00.1 
           chip ID: 10de:0e0f 
           Device-2: Advanced Micro Devices [AMD] Starship/Matisse HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus ID: 0a:00.4 chip ID: 1022:1487 
           Sound Server: ALSA v: k5.8.11-1-MANJARO 
Network:   Device-1: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: 5.6.0-k port: e000 bus ID: 03:00.0 
           chip ID: 8086:1539 
           IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
           IP v4: <filter> type: dynamic noprefixroute scope: global broadcast: <filter> 
           IP v6: <filter> type: noprefixroute scope: link 
           IF-ID-1: virbr0 state: down mac: <filter> 
           IP v4: <filter> scope: global broadcast: <filter> 
           IF-ID-2: virbr0-nic state: down mac: <filter> 
           WAN IP: <filter> 
Drives:    Local Storage: total: 1.36 TiB used: 253.04 GiB (18.1%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda vendor: Western Digital model: WD5000AZLX-00K4KA0 size: 465.76 GiB block size: physical: 4096 B 
           logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: 0A80 scheme: MBR 
           ID-2: /dev/sdb vendor: Western Digital model: WDS100T2B0B-00YS70 size: 931.51 GiB block size: physical: 512 B 
           logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: 20WD scheme: GPT 
           Message: No Optical or Floppy data was found. 
RAID:      Message: No RAID data was found. 
Partition: ID-1: / raw size: 922.42 GiB size: 906.94 GiB (98.32%) used: 252.59 GiB (27.9%) fs: ext4 dev: /dev/sdb2 label: N/A 
           uuid: hidden 
           ID-2: /boot/efi raw size: 300.0 MiB size: 299.4 MiB (99.80%) used: 312 KiB (0.1%) fs: vfat dev: /dev/sdb1 
           label: N/A uuid: hidden 
Swap:      Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
           ID-1: swap-1 type: partition size: 8.80 GiB used: 461.4 MiB (5.1%) priority: -2 dev: /dev/sdb3 label: N/A 
           uuid: hidden 
Unmounted: ID-1: /dev/sda1 size: 465.76 GiB fs: ntfs label: New Volume uuid: hidden 
USB:       Hub: 1-0:1 info: Full speed (or root) Hub ports: 10 rev: 2.0 speed: 480 Mb/s chip ID: 1d6b:0002 
           Device-1: 1-5:2 info: Pixart Imaging Optical Mouse type: Mouse driver: hid-generic,usbhid interfaces: 1 rev: 2.0 
           speed: 1.5 Mb/s chip ID: 093a:2510 
           Device-2: 1-6:3 info: Microsoft Natural Ergonomic Keyboard 4000 V1.0 type: Keyboard,HID driver: microsoft,usbhid 
           interfaces: 2 rev: 2.0 speed: 1.5 Mb/s chip ID: 045e:00db 
           Hub: 2-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s chip ID: 1d6b:0003 
           Hub: 3-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 speed: 480 Mb/s chip ID: 1d6b:0002 
           Hub: 4-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s chip ID: 1d6b:0003 
Sensors:   System Temperatures: cpu: 48.4 C mobo: N/A gpu: nouveau temp: 47 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 288 Uptime: 23m Init: systemd v: 246 Compilers: gcc: N/A Packages: pacman: 1237 lib: 350 flatpak: 0 
           Shell: Bash v: 5.0.18 running in: kate inxi: 3.1.05 

The “free” output was collected while the issue was happening. Somehow I was able to get to the desktop again.

I would try to install the nonfree (proprietary) Nvidia driver. It’s very well described here:


I have updated the graphics card driver per your suggestion:
Graphics: Device-1: NVIDIA GK208B [GeForce GT 710] vendor: Micro-Star MSI driver: nvidia v: 450.66

So far so good.


I’ve marked the below answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (I just want to avoid even more subjective opinions being posted and confusing you even more)

P.S. In the future, please please don’t forget to come back and click the 3 dots below the answer to mark a solution like this below the answer that helped you most :
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.