Kdenlive icon missing in startmenu


After updating with Octopi on August 17th, the Kdenlive icon is missing in the startmenu. Only the text is shown. I am quite sure that the icon was there after my previous update on July 14th, since Kdenlive is one of my standard test applications after updating to see if graphic performance is still OK. Because I pinned Kdenlive (added to favorites), it doesn’t show up at all in the left column of the startmenu, just because I know that it is there, I can click on the invisible icon and stat Kdenlive. I use “Application menu”.

I Use kernel 4.19.138-1, KDE Plasma 5.19.4, KDE Framework 5.73.0, global theme Breath2 (automatically activated in May, since Breath was phased out).

I have no clue if this is a bug and if I should wait for another update. I have no knowledge of the linux filesystem so I don’t know where to look.
I tried right-click on Start, Edit Applications, then in the KDE Menu editor open Multimedia.
There is Kdenlive, with the familliar icon. I click on Kdnlive to edit it, there is the icon button with the correct icon. I click on that and in the Icon source window that appears I can browse to the kdenlive icon and (re)select it. Then back in the KDE Menu editor click save.
Still no icon in the menu.


This is probably due to an oversight in the composition of the icon theme ─ it happens in virtually all icon themes at some point, usually after an update, and with different icons missing between the different themes.

You can temporarily remedy the problem by installing one of the alternative icon themes, either from the repository, from the AUR, or from store.kde.org.


Thanks for the reply.
I will wait until it is noticed and fixed then, instead of messing with icon themes.
I am a real linux user and don’t want to deviate from the distro to avoid problems in the future.

I did however look around as you mentioned “icon theme”, looked in System settings, Appearance, Icons.
I noticed that my icons where still Breath, not Breath2, which was automatically implemented in May. Should I switch to Breath2 to avoid problems in future?

You could try that. Myself, I’m using the Oxygen icons (from the repository), with La Capitaine (from the AUR) for certain specific applications. Yet, you will come across missing icons in most icon themes, even if only because of the ever-varying landscape of available applications.


  1. The Oxygen icon theme does have an icon for Kdenlive.

  2. You can try logging out, deleting your icon cache from a tty and logging back in. :arrow_down:

rm -f ~/.cache/icon-cache.kcache

In case you still want to reply…
Since I don’t know how to use tty, I logged in as root and deleted the icon-cache.kcache file from my user from there with Dolphin. No change.
Then I logged in as root again and deleted the whole .cache folder, also no change.

Since I use a vmware player as my Manjaro VM, I can make a copy of the VM as backup so I can fool around whatever I like.
I then started changing Global theme to Oxygen and later Breeze, also the Icons, nothing changes.
Then I started noticing that when logged in as root, who also uses the Breath2 theme, the Kdenlive icon was there, so it is not the system, but the user having a problem I guess.

I uninstalled and installed Kdenlive via Octopi, no change.
Between most changes I rebooted to make shure changes were in effect.

The only thing that changed with Kdenlive is since it is major version 20. or so, the icon changed.
The root user has the new icon, my user shows the old icon in KDE Menu editor. I don’t know where icons come from. In Windows they are embedded in the executable.
Now that I know that root has the icon visible, I don’t think that any update is going to bring back the icon.
The thing is that I don’t understand the system, KDE, Plasma, theme, a.s.o., so no way to solve this.

When I rightclick on Kdenlive in the startmenu under Multimdia and choose +Add to desktop, I get a Kdenlive (the old version) icon on the desktop.

It’s in the icon cache. Try deleting all of the *.kcache files under your user’s ~/.cache directory.

  1. Log out of Plasma.

  2. Press Ctrl+Alt+F2.

  3. Log in as yourself at the prompt ─ no need for root.

  4. Issue the following commands… :arrow_down:

rm -f ~/.cache/*.kcache
kbuildsycoca5 --noincremental
  1. Log out again by pressing Ctrl+D or typing… :arrow_down:
  1. Press Alt+F1 and log back in.

Thanks for explaining how to enter tty.
As I wrote, I even deleted the whole .cache folder of the user, being logged in as root.
I did what you wrote. After deleting *.kcache I checked that it was gone in tty (went to the .cache dir, looked with ls before and after)

But after entering the command kbuildsycoca5 --noincremental I got the following message:
kf.service.sycoca: The menu spec file contains a Layout or DefaultLayout tag without the mandatory Merge tag inside. Please fix your file.

In that case, I’m afraid I’m going to have to defer to someone more knowledgeable than me. :man_shrugging:

Pinging @cscs:wink:

Thanks so far, Strider :slight_smile:

1 Like

What was the rest of the output?

Anyways … seems like it could be like this:

1 Like

There was no rest of the output, just that error.
I tried the steps on the Dedoimedo page you linked.
Nothing changed, just the output error of the kbuildsycoca5 command went away after restoring to system menu.
So being a MS system administrator but a Linux layman, I tried a clever approach.
Before the last update round the icon was there, but the kbuildsycoca5 output problem possibly already present.

I update once a month mostly.
I updated on July 14th, and then again on August 17th.
I went back to the VM copy of August 17th, before the update (so the state of July 14th).
The Kdenlive icon was present in the menu, and in the Favorite bar.
I know that would be the case, since it disappeared after the update round of updates that were released between July 14th and August 17th.

First I thought it would be good to get rid of that kbuildsycoca5 error.
I gave the command kbuildsycoca5, just in my session, in Yakuake terminal.
It gave the following error, it is the only error, like before.
kf.service.sycoca: The menu spec file contains a Layout or DefaultLayout tag without the mandatory Merge tag inside. Please fix your file.

Then I did the trick from Dedoimedo:
Right-click Start, Edit applications, in the KDE Menu Editor clicked Edit, choose Restore to system menu and confirmend.
Gave the command kbuildsycoca5 again within my session, the error was gone.

Then in System settings, I changed Icons from Breath to Breath2, since the Breath theme was replaced by Breath2 in a previous update this year but Icons was not changed to Breath2 automatically.
It gave me the new Kdenlive icon from version 20. (I think).
After reboot icon still there.

I logged out and did the trick from Aragorn:
In tty entered the commands:
rm -f ~/.cache/*.kcache
kbuildsycoca5 --noincremental
Logged in again, icon there, after reboot icon still there.

Then I installed the 476 updates again like I did five days ago.
After updating the Kdenlive icon was still there.
After the reboot is was gone.

Kdenlive version at July 14th after updating: 20.04.1
Kdenlive version after the updates now: 20.04.3

My guess is that the Kdenlive update is not correct. I don’t know where menu icons come from in linux.
The icon shows up in the KDE Menu Editor, both in the menu at the left as in the appliction details.
When I rightclick Kdenlive in the Plasma menu and choose Pin to task manager or Add to Desktop, it creates a visible icon.
Is it possible that it’s just the incomplete Kdenlive update and that it will be resolved in a next update?

same problem here.

Deleting the icon cache didn’t help.

Interestingly though, the icon is available in the start menu editor, but will not be shown in the menu. Selecting another icon shows the selected one in the menu. Switching back to kdenlive icon, icon missing in the menu.

For me this seem to some error in the icon file itself that’s being ignored by the editor but not by the start menu widget.

No, it’s a lot more convoluted than that. When an icon set is installed, then there is a set of default symbolic links that point to the icons for various functions.

So for instance, the icon for kdenlive could have various symbolic links pointing to it with different and generic names, so that it would be available in different desktop environments, which may be calling upon the icon by a different name.

Now, one of the problems with these icon sets is that sometimes, the developer forgets to add the symbolic link for a certain application in a certain desktop environment, or there is a typo in the name, or something like that. And then the environment or program looking for that particular icon by that particular name cannot find it, while some other environment or program that looks for that same icon but under a different name may show the icon as if nothing’s wrong.

Thanks for this comment Aragorn, that makes sence.
I thought it had to be a developer issue since I don’t fool around with the environment myself and it happened after a kdenlive update.
In Recent applictions the icon is there, putting a link on the desktop the icon appears, and also on the taskbar. Different symbolc links I guess.

Just interested, if it is about icon sets and symbolic links, how would you explain that when I login as root, the kdenlive icon appears in the startmenu under Multimedia, and when I login as user the icon is missing? Would it then be that a symbolic link or whatever has inproper rights set?
Just guessing, I have no knowledge of Linux filesystem and how things are organized.

That is not a permissions issue, because by default, a symbolic link usually has lrwxrwxrwx permissions. It would rather suggest a caching issue. :thinking: