Kdenlive 12.20.3-1 New feature - Typewriter missing

Hello all,

I solved this one for myself and didn’t find anything on the internet about this problem. So I though I would post here to share.

Solution: The version of mlt that comes from the official repo is not current enough. remove it and install the mlt-git package from AUR.

Kdenlive 20.12.3 was released on March 8th, 2021 and added a typewriter effect to the package… however, if you install the version of kdenlive from the official Manjaro repos, the effect simply isnt there…


And when you run kdenlive from the command line you will see this message on the console:
Unknown asset “typewriter”

I even tried the flatpack version (crashes when trying to use the typewriter effect – dont know, didnt debug this)

I tried compiling directly from git the master, 20.12 and even the 21.04… nothing.would.work.

So i decided to see if i could do it directly with mlt and discovered this:
$ melt -version
melt 6.24.0

$ melt -query filters | grep type
(no results)

— mlt didnt have the typewriter effect, so of course kdenlive wouldn’t… hmm…

So i backtracked the commits on mlt and found that it was added on Feb 23rd, 2021

and the latest “release” of mlt (which is in the manjaro repo) was released on Dec 7th, 2020.

So, solution was to pull from git… and it works.

:+1: Thank you for sharing! :+1:

However, could you do me a favour and:

  • edit your question by pressing the 3 dots and the pencil icon
  • make it into a real question
  • cut and paste the solution into an answer to your own question
  • click the 3 dots below your own answer to mark a solution like this:
    so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.