KDE widgets position reset on reboot / vol keys work only when 2 widgets are present

Hello guys! I'm new to Linux and I just installed Manjaro KDE. Yesterday I spent a few hours customizing the DE.
I have two minor issues.

  1. I added a new panel, placed on the top of the screen and I added two widgets (among others): window activity control and global menu. I dragged them to the right side. All good so far. I then rebooted and these two are being placed on the left side of the panel and I have to drag them to the right again. This happens every reboot.

  2. Volume keys (F keys) have stopped working. The only way I could get them to work was to have both the volume icon present in System Tray and another volume icon (forgot the widget's name) too. The two of them must be on the panel for vol keys to work, if I disable or hide either of them it stops working. I tried setting up the shortcuts again - they were already set, so that did not work.
    Note* the buttons used to work with the default bottom panel, I noticed this only after I finished setting up everything.

You have to lock the widgets after you customize them. System Tray is a must for some things to work, even for Notifications to show up, so is logical that the Audio Volume either is present trough it or via the widget itself.

1 Like

I did lock them, they still reset after a reboot. I have to unlock them, then move the widgets.

I don't think I explained well enough, but I'll try to do it.

If I have only System Tray (therefore the Audio Volume icon too) the vol keys do not work.

If I have the separate Audio Control widget (or whatever it's called) without the System Tray Icon the vol keys do not work.

If I have both System Tray (with the default Audio Volume icon) and the separate Audio Control widget, only then the vol keys work.

What you describe is quite atypical, and i don't know how it ended up that way. Make a TEST user, log into it and see if the issue with the default configurations continue. If not, then reset the plasma setting to default by:
rm ~/.config/plasma-org.kde.plasma.desktop-appletsrc
from terminal, from your user, log out and back int.

Default config worked, so I thought I redo the panel, which I did. The vol keys seem to be working fine for now.

As for the widgets resetting to the left, that still happens, but a workaround is to add a spacer.

That's not a workaround ─ it is how it must be done. The widgets you put on the panel are always left-aligned, and so if you want to put widgets on the right but nothing to the left of them, then you must add a spacer ─ preferably with variable width, in case you'd want to add a widget on the left later anyway.

Forum kindly sponsored by