[KDE] "Unable to create io-slave" after update

Hi folks,

my first post here which I find kinda positive given the fact that I rarely post any threads on any forums unless I have a problem with something :stuck_out_tongue: Enough said, until 2016-07-27 (stable update, when Plasma got updated to 5.7.2 and Framework 5.24) everything worked just fine. But now I’m experiencing a rather annoying problem. Every now and then some apps crash when I try to use them, giving me the following error:

Unable to create io-slave

I figured out that this error arises only when some apps try to communicate with KDE libs. I’m a n00b at reporting errors but I figured out that it’d be best if I attach a journalctl dump (journalctl --since=yesterday | grep "io-slave")

Journalctl dump

I’m not sure what could go wrong after the update nor have I time to delve into it but I’ve been looking at many Google searches and really, I couldn’t find anything adequate. There were however some useful advices:

  1. I tried to kill the X Server but it didn’t help
  2. I have found the “missing” files - they exist and seem to enjoy destroying my life (ls -al):

-rwxr-xr-x 1 root root 98256 Jul 10 15:10 file.so -rwxr-xr-x 1 root root 164208 Jul 10 15:10 trash.so

It really paralyzes me as I use Manjaro for pretty much everything including my work (I’m a dev) and now it’s not usable anymore.

PS I’m really sorry if you find my problem silly but I just can’t solve it :expressionless:

Best regards,
Jakub

If you just need your stuff to work try downgrading the packages you think are causing the trouble. It looks like you have at least one plasmoid giving you an issue and my first suspicion is that the apps in question have not been updated in a while, causing an issue with the brand new plasma.

@nadb, I don’t feel like downgrading to be honest. I do the updates regularly if you mean it. But the apps in question seem to be unable to find those libs from the journalctl dump so I can’t see any connection actually :frowning:

Have you tried cleaning your cache folder?
Well you can try too launching from Terminal seeing if it works:
dbus-launch appname

1 Like

In the last stable update compiz failed to work in xfce with a similar error, because metacit y had not been updated, it may very well be your only real solution, until the associated libraries are updated. I would check the dates on the libraries in question, it may point you in the right direction.

@Fpks, not sure if it’s related but when I try to run a KDE app (Dolphin) I get a following message from dbus-launch:

Cannot creat accessible child interface for object: PlacesView(0x27f2e00) index: 15 klauncher not running... launching kdeinit kdeinit5: Shutting down running client. We got some errors while running testparm "Load smb config files from /etc/samba/smb.conf\nError loading services.\n" KSambaShare: Could not find smb.conf! We got some errors while running 'net usershare info' "Can't load /etc/samba/smb.conf - run testparm to debug it\n"

I mean, it works, I just get this error.

Which ones (cache folders) should I remove?

@nadb, OK, for now this time everything works just fine, not sure why to be honest.

Thank y’all again for the answers. I’ll do a full upgrade tomorrow and let you know how it turns out.

it’s an error caused by dbus-launch :wink:

but please try to reinstall kio completely, since it seems that its related to kio somehow. please also post all your output to the last command here if there are errors or warnings or something.

sudo pacman -Scc ##cleans cache, very impoartent
sudo pacman-mirrors -g ##check for faster mirrors
sudo pacman -Syyuu kio ##upgrades system & reinstalls kio

I made a ■■■■■■■■ trying use deeping-file-manager on Manjaro Plasma KDE.
After I launched dolphin it said that he cannot create an "io-svale".
Thanks to your command it's now working!

Forum kindly sponsored by