KDE tray bug after using system tray settings

kde

#1

Iv looked but i can’t find this bug reported.

When i use the system tray settings “entries” tab it breaks the tray, I don’t need to change anything just hit the OK button, after that I can’t click any of the default icons, the only menu i can get is the main list even if I’m clicking the volume or network etc icons, even on the main drop-down menu i can not click any of the icons. The only way to fix it is to restart plasma.

I have tested this on a VM with brand new download of today’s stable .ISO and its exactly the same which is why i would have thought there must be a report of this somewhere but i don’t know how to describe it into a search, although iv tried.

Its a little hard to explain so iv taken a screen recording. I show the tray working as normal for the first half then go to the settings and hit OK and then show how it affects the tray.


#2

Weird. Can confirm here too.
Testing Branch - Plasma 5.13.4-1


#3

Same in vanilla Arch + Plasma. Anyone look for a bug report yet?


#4

Same issue here, had this issue 2 days back before updating (31 Aug stable updates) but was too busy and forgot to post.

Currently:
KDE latest update (confirmed still bugged)
Kernel 4.14.67-1 LTS


#5

just want to add a P.S. Its not something that is new, its been this way for ages and ages iv just been to busy with other bugs and since this one is not really important and is also easy to fix i never bothered with it but i just finished fixing my last problem so i thought id have a search for this bug.

O BTW for anyone who wants to know how to re-start plasma, I use this :-

kquitapp5 plasmashell && kstart5 plasmashell

#6

insert > workaround by restarting plasma


#7

It has certainly been quirky. It has other issues, too, such as randomly not displaying the Entries (like it is doing to me right now (curse you, Plasma!). Oh well, that’s just KDE. :wink:


#8

Bug confirmed, but I didn’t know the cause. Very useful. :+1:

Nice, but it’s kstart5 plasmashell no?

I got a lovely black screen :wink: before appreciating the TAB command completion.


#9

emmm, really not sure, I do have both kstart5 & kstart but kstart works for me to start up plasma. I use fish but that should not really matter. I dunno whatever works for you :slight_smile:


#10

In my case I see this behavior on a Plasma Panel but not in Latte Dock.


#11

I still get it on latte, in fact iv just recently changed back to the plasma default panel from latte because i thought it might solve the problem, but it didn’t :frowning:


#12

I just switched from KDE Neon to Manjaro KDE Edition and came across this bug directly. The problem seems to occur only under Manjaro.


#13

Na thats not so, i was just playing about with new installation of Kubuntu yesterday and it does it on there too.


#14

don’t have this bug in my plasma… should I worry?


#15

@notageek It’s an annoying bug, but rebooting Plasma temporarily fixes the problem. However, it annoyed me so much that I switched to gnome until it is fixed;)

@JackDinn Thanks for the correction. Does this bug report also exist in KDE bugzilla?


#16

It was IIRC.
For my Plasma, this does not occur, although I have recently switched from xfce. I had it on my desktop, which I can’t currently check.
You may need some Plasma refreshing. You can confirm it is fixed, if you create a new user (having Manjaro-Plasma settings installed).


#17

Sorry i just updated my manjaro-system completely, the bug still occurs. I just have to open the dialog “entries” in the system tray settings, close the system tray settings and open the settings again. After this, all entries in the entries-dialog disappear and the behavior, which is shown in the video, occurs.


#18

I created a new user and opened the “entries” dialog and changed a setting and went back to the desktop. After reopening the dialog was empty. So the bug continues :disappointed:


#19

Have you checked the upstream bug report?
Does it reset behavior with a plasma restart as reported, or only with reboot?


#20

It resets the behavior with a plasma restart:

kquitapp5 plasmashell && kstart5 plasmashell

but after some settings on the entries the bug comes back sometimes goes away. While I’m writing I do open the dialog and sometimes it’s empty and sometimes it displays the entries. The bug is still present.