KDE, suspend is not available anymore

I am using:

  1. Kernel 4.19.99
  2. desktop KDE

Suspend is not available anymore in the logout screen.
Where can I begin to search?

inxi -Fzxxx:

System:    Host: Sol Kernel: 4.19.99-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 Desktop: KDE Plasma 5.17.5 tk: Qt 5.14.0 
           wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Server System: Supermicro product: X10SRA v: 0123456789 serial: <filter> Chassis: type: 17 v: 0123456789 
           serial: <filter> 
           Mobo: Supermicro model: X10SRA v: 1.01 serial: <filter> UEFI: American Megatrends v: 2.1a date: 10/24/2018 
CPU:       Topology: 6-Core model: Intel Core i7-6800K bits: 64 type: MT MCP arch: Broadwell rev: 1 L1 cache: 384 KiB 
           L2 cache: 15.0 MiB L3 cache: 15.0 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 81598 
           Speed: 1201 MHz min/max: 1200/3800 MHz Core speeds (MHz): 1: 1200 2: 1201 3: 1201 4: 1202 5: 1200 6: 1201 7: 1201 
           8: 1201 9: 1459 10: 1200 11: 1200 12: 1202 
Graphics:  Device-1: NVIDIA GM204 [GeForce GTX 970] vendor: CardExpert driver: nvidia v: 440.44 bus ID: 02:00.0 
           chip ID: 10de:13c2 
           Display: x11 server: X.Org 1.20.7 driver: nvidia compositor: kwin_x11 resolution: 2560x1440~60Hz 
           OpenGL: renderer: GeForce GTX 970/PCIe/SSE2 v: 4.6.0 NVIDIA 440.44 direct render: Yes 
Audio:     Device-1: Intel C610/X99 series HD Audio vendor: Super Micro driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
           chip ID: 8086:8d20 
           Device-2: NVIDIA GM204 High Definition Audio vendor: CardExpert driver: snd_hda_intel v: kernel bus ID: 02:00.1 
           chip ID: 10de:0fbb 
           Sound Server: ALSA v: k4.19.99-1-MANJARO 
Network:   Device-1: Intel I210 Gigabit Network vendor: Super Micro driver: igb v: 5.4.0-k port: d000 bus ID: 04:00.0 
           chip ID: 8086:1533 
           IF: eno1 state: down mac: <filter> 
           Device-2: Intel I210 Gigabit Network vendor: Super Micro driver: igb v: 5.4.0-k port: c000 bus ID: 05:00.0 
           chip ID: 8086:1533 
           IF: eno2 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 4.57 TiB used: 1.00 TiB (22.0%) 
           ID-1: /dev/sda vendor: Samsung model: SSD 850 PRO 512GB size: 476.94 GiB speed: 6.0 Gb/s serial: <filter> rev: 4B6Q 
           scheme: GPT 
           ID-2: /dev/sdb vendor: Samsung model: SSD 850 PRO 512GB size: 476.94 GiB speed: 6.0 Gb/s serial: <filter> rev: 4B6Q 
           scheme: GPT 
           ID-3: /dev/sdc vendor: Western Digital model: WD4003FZEX-00Z4SA0 size: 3.64 TiB speed: 6.0 Gb/s rotation: 7200 rpm 
           serial: <filter> rev: 1A01 scheme: GPT 
Partition: ID-1: / size: 97.93 GiB used: 8.53 GiB (8.7%) fs: ext4 dev: /dev/sda3 
           ID-2: /boot size: 975.9 MiB used: 55.7 MiB (5.7%) fs: ext4 dev: /dev/sda1 
           ID-3: /home size: 195.86 GiB used: 12.31 GiB (6.3%) fs: ext4 dev: /dev/sda4 
           ID-4: /var size: 140.67 GiB used: 7.17 GiB (5.1%) fs: ext4 dev: /dev/sda5 
           ID-5: swap-1 size: 32.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 17.0 C mobo: N/A gpu: nvidia temp: 29 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 30% 
Info:      Processes: 246 Uptime: 5m Memory: 31.29 GiB used: 1.49 GiB (4.8%) Init: systemd v: 242 Compilers: gcc: 9.2.0 
           Shell: bash (su) v: 5.0.11 running in: konsole inxi: 3.0.37 

Can you provide /etc/default/grub and your /etc/fstab?

And:

lsblk -f

OK.

/etc/default/grub:

RUB_DEFAULT=saved
GRUB_TIMEOUT=5
GRUB_TIMEOUT_STYLE=menu
GRUB_DISTRIBUTOR='Manjaro'
GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=UUID=f1bdbdd1-7bc4-47d2-8db2-b67cbc7db680"
GRUB_CMDLINE_LINUX=""

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.
GRUB_SAVEDEFAULT=true

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK=y

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.
GRUB_COLOR_NORMAL="light-gray/black"
GRUB_COLOR_HIGHLIGHT="green/black"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/usr/share/grub/background.png"
GRUB_THEME="/usr/share/grub/themes/manjaro/theme.txt"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

/etc/fstab:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=c6c65b6c-c742-43f8-adbb-c59901ff54f5 /boot          ext4    defaults,noatime 0 2
UUID=f1bdbdd1-7bc4-47d2-8db2-b67cbc7db680 swap           swap    defaults,noatime 0 2
UUID=838120ed-c1e1-4620-ad6f-62c5830a8c08 /              ext4    defaults,noatime 0 1
UUID=9f37810a-7288-47e3-9bbe-7a864bd7b290 /home          ext4    defaults,noatime 0 2
UUID=c15c09b6-c471-403a-9b6b-b5a0c3981264 /var           ext4    defaults,noatime 0 2
UUID=886A-0907                            /boot/efi      vfat    defaults,noatime 0 2
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0
UUID=43166bcb-eb7f-4f68-8360-3bd6c383f3c1 /data          ext4    defaults,noatime 0 2

lsblk -f

NAME   FSTYPE FSVER LABEL UUID                                 FSAVAIL FSUSE% MOUNTPOINT
sda                                                                           
├─sda1 ext4   1.0         c6c65b6c-c742-43f8-adbb-c59901ff54f5    853M     6% /boot
├─sda2 swap   1           f1bdbdd1-7bc4-47d2-8db2-b67cbc7db680                [SWAP]
├─sda3 ext4   1.0         838120ed-c1e1-4620-ad6f-62c5830a8c08   84,4G     9% /
├─sda4 ext4   1.0         9f37810a-7288-47e3-9bbe-7a864bd7b290  173,5G     6% /home
└─sda5 ext4   1.0         c15c09b6-c471-403a-9b6b-b5a0c3981264  126,3G     5% /var
sdb                                                                           
├─sdb1 ntfs               ECCA76DCCA76A30E                                    
├─sdb2 vfat   FAT32       886A-0907                              70,9M    26% /boot/efi
├─sdb3                                                                        
└─sdb4 ntfs               E2286BCD286B9F73                                    
sdc                                                                           
└─sdc1 ext4   1.0         43166bcb-eb7f-4f68-8360-3bd6c383f3c1    2,4T    27% /data
sr0     

I can't see anything wrong here. :man_shrugging:
I'm running the same DE (on testing) and still have all suspend options.

I also checked my Win 10 installation and suspend is available there.

Open System Settings -> Startup and Shutdown -> Session Management -> Offer shutdown options

Also check if you are using the Breath theme, with breath it could sometimes be that there is not hibernation button, you could then change to Breeze theme to verify if this is the reason.

Can you suspend from the terminal?

systemctl suspend

systemctl suspend works, but I can´t find "offer shutdown options" in System Settings.
I am using german as default language.

So findet man bei mir das Kästchen zum Aktivieren der Optionen für das Herunterfahren:

Now, I have found "Arbeitsflächensitzung".
But there is no entry "suspend".

When I login to my account, I can see a button "Suspend".

Just for the record: this is entirely irrelevant. Availability of suspend (to-disk) on one OS has no bearing on any other OS on the same machine.

This comment does not solve the problem at all.
:rofl:

1 Like

Hope you can find the suspend setting in KDE system-settings

But at KDE system-settings --> Shortcuts --> Global Shortcuts --> Power Management --> Suspend
There is a 'suspend' there. And I also create/set a keyboard shortcut for it; easier than using power button.

Good luck.

1 Like

Change kernels. Sometimes power management may be impacted differently by different kernels.

(This is less apparent in Plasma than GNOME.)

I have installed kernel 5.4. and the suspend button is not available.

Suspend or hibernation? Anyway, try going to System Settings -> Appearance -> Global Theme and apply Plasma's default Breeze one. If it's a theming issue, then you'll have your extra options in bye-bye dialog working. Of course it will reset your custom appearance settings, but that's easy to set back.

Both buttons for Suspend and Hibernation are not available in the menu
(Manjaro button -> Exit -> System) anymore.

I have set the Global Theme to "Breeze" and the two buttons (Suspend and Hibernation) do not appear.
:maté:

Hier ist ein interessanter Beitrag, das mal auszuprobieren kann nicht schaden:

Außerdem, falls noch nicht geschehen, mal in der Datei

/etc/mkinitcpio.conf

nachsehen, ob in der Zeile, die mit

HOOKS="

beginnt,

resume

auftaucht.

Wollie´s link did not solve the problem.
???

Forum kindly sponsored by