KDE stable ISO refuses to boot into the live environment

  1. rEFInd as my computer’s bootloader
  2. Ventoy + full featured stable KDE ISO + Windows ISO on my USB stick

The Windows ISO works fine on the stick but Manjaro goes into the emergency root shell. I tried both the FOSS and proprietary drivers options in Manjaro ISO’s boot menu.

I’ve also checked the sha1sum and the GPG hash and they match with that of the ISO file’s website.

Can someone help me out?

with ventoy, all you do once you installed it to the USB drive,
is to copy the *.iso file to it

I assume you did check the checksums of the files that are on the USB?
(vs. the checksum of the files that you downloaded and then transferred to the ventoy USB drive)
… just checking for the seemingly obvious - nothing personal!
… you never know … :wink:

1 Like

You’re right, there’s a mismatch. I’ll try copying it again.

For the record, ventoy is on an exfat filesystem so that I can view and edit the files from windows.

Ventoy seems to automatically add the executable flag to the ISO, does that change the sha1 hash?

that is an “artifact” of the exfat filesystem - how you mount it
but don’t quote me on that - I have never used that filesystem

no - the hashes are made from the contents of the file
if the hashes don’t match, the content is different, which usually means it got changed/corrupted

Works now, thank you.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.