KDE, plasmashell won't start, "rdrand failed"

Hello, I recently made a post about having trouble installing Manjaro KDE on a PC build with an Nvidia card, but fortunately I have been able to at least get an install. Unfortunately, the last issue seems to be that plasmashell just refuses to start. It doesn’t start on boot like it should, and when I run the command kstart5 plasmashell, this is what I get:

kf.coreaddons: plugin metadata in /usr/lib/qt/plugins/many-different-filepaths does not have a valid 'MetaData' object

there are about 100 of the above types of warnings, and the last couple lines are:

terminate called after throwing an instance of 'std::runtime_error'
  what():  random_device: rdrand failed

I looked up that error message, but found nothing but my other post regarding KDE and an “rdrand failed” message. Here are my system details, in case anyone wants them:

System:
  Kernel: 5.4.141-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64
  root=UUID=e81b609e-0691-4d47-a395-efa432ec7fa9 rw quiet udev.log_priority=3
  nvidia-drm.modeset=1
  Desktop: KDE Plasma 5.22.4 tk: Qt 5.15.2 wm: kwin_x11 vt: 7
  dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: ASRock model: B550 Phantom Gaming-ITX/ax
  serial: <filter> UEFI: American Megatrends v: P1.10 date: 06/19/2020
CPU:
  Info: 6-Core model: AMD Ryzen 5 5600X bits: 64 type: MT MCP arch: Zen 3
  family: 19 (25) model-id: 21 (33) stepping: 0 microcode: A201003 cache:
  L2: 3 MiB
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  bogomips: 88677
  Speed: 2485 MHz min/max: 2200/3700 MHz boost: enabled Core speeds (MHz):
  1: 2485 2: 2016 3: 2136 4: 2031 5: 2031 6: 2013 7: 2016 8: 2025 9: 2508
  10: 2039 11: 2037 12: 2167
  Vulnerabilities: Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW,
  STIBP: always-on, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: NVIDIA GP107 [GeForce GTX 1050 Ti] vendor: ASUSTeK driver: nvidia
  v: 470.63.01 alternate: nouveau,nvidia_drm bus-ID: 08:00.0
  chip-ID: 10de:1c82 class-ID: 0300
  Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver:
  loaded: nvidia note: n/a (using device driver) failed: nvidia display-ID: :0
  screens: 1
  Screen-1: 0 s-res: 3840x2160 s-dpi: 162 s-size: 602x341mm (23.7x13.4")
  s-diag: 692mm (27.2")
  OpenGL: renderer: llvmpipe (LLVM 12.0.1 256 bits) v: 4.5 Mesa 21.1.6
  compat-v: 3.1 direct render: Yes
Audio:
  Device-1: NVIDIA GP107GL High Definition Audio vendor: ASUSTeK
  driver: snd_hda_intel v: kernel bus-ID: 08:00.1 chip-ID: 10de:0fb9
  class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: ASRock driver: snd_hda_intel
  v: kernel bus-ID: 0a:00.4 chip-ID: 1022:1487 class-ID: 0403
  Sound Server-1: ALSA v: k5.4.141-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.33 running: yes
Network:
  Device-1: Intel Ethernet I225-V driver: igc v: 0.0.1-k port: N/A
  bus-ID: 06:00.0 chip-ID: 8086:15f3 class-ID: 0200
  IF: enp6s0 state: down mac: <filter>
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 07:00.0
  chip-ID: 8086:2723 class-ID: 0280
  IF: wlp7s0 state: up mac: <filter>
Drives:
  Local Storage: total: 961.39 GiB used: 8.26 GiB (0.9%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 980 1TB
  size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
  lanes: 4 type: SSD serial: <filter> rev: 1B4QFXO7 scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 type: USB vendor: Samsung model: Flash Drive
  size: 29.88 GiB block-size: physical: 512 B logical: 512 B type: SSD
  serial: <filter> rev: 1100 scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
  ID-1: / raw-size: 931.22 GiB size: 915.53 GiB (98.32%) used: 8.26 GiB (0.9%)
  fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
  used: 288 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
Swap:
  Alert: No swap data was found.
Sensors:
  System Temperatures: cpu: 0.0 C mobo: N/A gpu: nvidia temp: 33 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info:
  Processes: 302 Uptime: 2m wakeups: 0 Memory: 31.29 GiB used: 1.27 GiB (4.0%)
  Init: systemd v: 248 tool: systemctl Compilers: gcc: N/A Packages:
  pacman: 1054 lib: 296 Shell: Zsh v: 5.8 default: Bash v: 5.1.8
  running-in: konsole inxi: 3.3.06

Any ideas of what’s going on, and how it can be fixed?

EDIT: To any future users who find my post, it was a BIOS update that fixed it! Who would have thought!