KDE/Plasma related error messages in journal

kde
plasma

#1

I see lots of KDE/XCB related error messages in the logs.
Anyone know what these mean?

kwin_x11[1076]: QXcbConnection: XCB error: 3 (BadWindow), sequence: 60495, resource id: 54525952, major code: 18 (ChangePro
plasmashell[1082]: QXcbConnection: XCB error: 3 (BadWindow), sequence: 41410, resource id: 69206023, major code: 142 (Unknown), minor code: 3perty), minor code: 0
dolphin[10612]: QXcbConnection: XCB error: 8 (BadMatch), sequence: 26150, resource id: 69206695, major code: 130 (Unknown), minor code: 3

There are tons of them, literally every minute I get a new error message, which are spamming the logs…


[Problem]Systemctl User: Failed to read server status: Input/output error
#2

Just that Qt dont follows a 30years old protocol (X11) :wink:


#3

Do you have the xcb packages installed…libxcb, etc?

Regards


#4

Lots of KDE spew due to default QT logging rules settings. You can yell at QT maintainers but they won’t listen.

It slows down KDE, fills the logs, and unless you are the developer, the messages are totally useless.

You can control this by setting the environmental variable:

QT_LOGGING_RULES=’*=false’
export QT_LOGGING_RULES

or

QT_LOGGING_RULES=’*.debug=false’
export QT_LOGGING_RULES

Above just kills debugging messages leaving plenty of garbage still in the logs.

You can put this in /usr/bin/startkde (probably not rcommended)
or /etc/profile (for everybody)
or ~/.bash_profile (for specific user)


#5

BTW there is also a little tool

kdebugdialog5

This might help for some unwanted output.


#6

Can one run that and unselect all those logs?
Just curious as always open to turning off or down things not needed.

Other question for any to answer.
As a User why would we want all those only useful to developers logs on our system?


#7

Adding more software to get LESS log garbage seems crazy to me. QT would have to still generate that logging only to have this utility turn it off. Waste of cycles. That’s why the statements above are better for me, they speed up my system, and keep my logging smaller).

The fundamental problem is that QT sets the logging levels too high. They use the same logging levels as everything else:
“emerg”, “alert”, “crit”, “err”, “warning”, “notice”, “info”, “debug”

But many (if not most) of the messages they send out are at least one log level too high.
Instead of debug, they are notice or warning.

So if you go into /etc/systemd/journald.conf and set your logging level higher (trimming low priority messages), you miss import warning messages from other parts of the Linux software just trying to avoid the QT rain storm of debugging message wrongly sent out as warnings.

Its really a denial of service attack on the logs.

And you are spot on @Orbmiser , there isn’t anything Joe User can do with all those messages.

Nothing at all, except perhaps sort them all out, save them all up and post bug reports against KDE or QT until the Devs start fixing the logging levels. Either that or email them to the devs weekly. (I actually got one DEV (kdeconnect) to stop logging everything at the warning level, but it took a lot of emails). But they usually just ban your bugtracker account or add you to their plonk file.

So I shut them all off. I know how to turn them back on if I need to, but quite frankly I never have a need for turning them on.


#8

Thanks for the details of this thing called Gobbly Gook Logging Frenzy! :smirk:
And yep guess I could just run “kdebugdialog5” and turn them all off if it isn’t going to break anything.

Man-O-Man there is a Huge list of Logging going on here.
Can I select the “Disable all debug output” without incurring any wrath? :fearful:

Tho running from a term generated error message running fine. And I selected disabled All logging.

“[orbmiser@Plasma-Node667 ~]$ kdebugdialog5
kf5.kcoreaddons.kaboutdata: Could not initialize the equivalent properties of Q*Application: no instance (yet) existing.”


#9

Sure.
You don’t need any of that, and you never will.
But why add another piece of software to intercept log messages when you can just turn them off all together?

Use your favorite editor: Open

~/.bash_profile

and add two lines at the bottom:

QT_LOGGING_RULES=’*=false’
export QT_LOGGING_RULES

Save, logout log in.
Done.


Turn off error messages in journal
#10

Thanks, @jsamyth. That’s going into my KDE tips-n-tricks file. :smiley:

Regards


#11

Works perfectly thanks. For zsh users put it in “~/.zprofile”

[onf ~]$ echo $QT_LOGGING_RULES                                                                                                                                                                                                                                                                                                                               (16-avril 10:56)
*=false
[onf ~]$ journalctl -xb | grep XCB                                                                                                                                                                                                                                                                                                                            (16-avril 10:56)
[onf ~]$ journalctl -xb-1 | grep XCB                                                                                                                                                                                                                                                                                                                       [1](16-avril 10:57)
avril 16 10:48:07 ArchMacDesktop kwin_x11[530]: QXcbConnection: XCB error: 3 (BadWindow), sequence: 894, resource id: 44040196, major code: 18 (ChangeProperty), minor code: 0
avril 16 10:48:07 ArchMacDesktop kwin_x11[530]: QXcbConnection: XCB error: 3 (BadWindow), sequence: 898, resource id: 41943044, major code: 18 (ChangeProperty), minor code: 0
avril 16 10:48:08 ArchMacDesktop kwin_x11[530]: QXcbConnection: XCB error: 3 (BadWindow), sequence: 1390, resource id: 4194335, major code: 18 (ChangeProperty), minor code: 0
avril 16 10:50:27 ArchMacDesktop kwin_x11[530]: QXcbConnection: XCB error: 3 (BadWindow), sequence: 6020, resource id: 31457350, major code: 3 (GetWindowAttributes), minor code: 0
avril 16 10:50:27 ArchMacDesktop kwin_x11[530]: QXcbConnection: XCB error: 9 (BadDrawable), sequence: 6021, resource id: 31457350, major code: 14 (GetGeometry), minor code: 0
avril 16 10:51:31 ArchMacDesktop kwin_x11[530]: QXcbConnection: XCB error: 3 (BadWindow), sequence: 8442, resource id: 31457771, major code: 3 (GetWindowAttributes), minor code: 0
avril 16 10:51:39 ArchMacDesktop kwin_x11[530]: QXcbConnection: XCB error: 3 (BadWindow), sequence: 12722, resource id: 31458279, major code: 3 (GetWindowAttributes), minor code: 0
avril 16 10:51:39 ArchMacDesktop kwin_x11[530]: QXcbConnection: XCB error: 9 (BadDrawable), sequence: 12723, resource id: 31458279, major code: 14 (GetGeometry), minor code: 0
avril 16 10:51:40 ArchMacDesktop kwin_x11[530]: QXcbConnection: XCB error: 3 (BadWindow), sequence: 13643, resource id: 56623104, major code: 18 (ChangeProperty), minor code: 0
avril 16 10:51:40 ArchMacDesktop kwin_x11[530]: QXcbConnection: XCB error: 3 (BadWindow), sequence: 13647, resource id: 56623105, major code: 18 (ChangeProperty), minor code: 0
avril 16 10:51:41 ArchMacDesktop plasmashell[535]: QXcbConnection: XCB error: 2 (BadValue), sequence: 4649, resource id: 52428816, major code: 142 (Unknown), minor code: 3
avril 16 10:53:25 ArchMacDesktop kwin_x11[530]: QXcbConnection: XCB error: 3 (BadWindow), sequence: 37603, resource id: 31458696, major code: 3 (GetWindowAttributes), minor code: 0
avril 16 10:53:25 ArchMacDesktop kwin_x11[530]: QXcbConnection: XCB error: 9 (BadDrawable), sequence: 37604, resource id: 31458696, major code: 14 (GetGeometry), minor code: 0
avril 16 10:56:00 ArchMacDesktop kwin_x11[530]: QXcbConnection: XCB error: 3 (BadWindow), sequence: 46632, resource id: 31460940, major code: 3 (GetWindowAttributes), minor code: 0
avril 16 10:56:00 ArchMacDesktop kwin_x11[530]: QXcbConnection: XCB error: 9 (BadDrawable), sequence: 46633, resource id: 31460940, major code: 14 (GetGeometry), minor code: 0

This was not enough, still had many logs.
QT_LOGGING_RULES='*.debug=false


#12

So I’m not the only one…
I have some packages in my repo just for things like this xD


#13

That only kills off debug loggging.
Read what I posted.


#14

Ok next time I will not say thanks.


#15

Thanks everyone.

My journalctl debugging level is already set at “notice”.
I’ll add the QT_LOGGING_RULES variable as well.

c00ter, yes, xcb packages are installed.


#16

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.