KDE Plasma - no parent window after SDDM login

Hi there, the latest (2?) updates broke my build ;-).

stable, KDE Plasma, Kernel 5.8+5.9 tested, fresh user tested, intel & nvidia

After login with SDDM akwallt prompts for some password and the story ends here.
Windows just get rendered when changed, no redraw for leftovers. No taskbar, nothing. Yakuake works. Opened Windows are fixed and can’t neither be moved nor resized.
Very similar to a black screen with mouse cursor only.

I couldn’t find this much in the logs, so bash debug help is welcome.
What I was able to extract and think could be relevant from the started syslog KDE app was:

14:38 sudo - Connecting to depricated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
14:38 kcminit_startup - QDBusConnection: error: could not send signal to service “” path “/home/<user_redacted>/.kde4/share/config/kdeglobals” interface “org.kde.kconfig.notify” member “ConfigChanged”: Invalid object path://home/<user_redacted>/.kde4/share/config/kdeglobals
14:38 keded5 - kf.kded: Could not load kded module “gtkconfig”:“Cannot load library /usr/lib/qt/plugins/kf5/kded/gtkconfig.so: libkdecorations2private.so7: cannot open shared object file: No such file or directory)” (library path was:"/usr/lib/qt/plugins/kf5/kded/gtkconfig.so")
14:38 kded - QDBusConnection: name ‘org.kde.kglobalaccel’ had owner " but we thought it was ‘:1.13’
14:38 kded5 - plasma-nm: Unhandled active connection state change: 1
14:38 kwalletd5 - Application ‘“kded5”’ using kwallet without parent window!

I had thermal monitor in KDE in .local but removed it.
I was only able to get it up and running again with restoring a timeshift BTRFS snapshot.

Neither a kernel change brought improvement nor a fresh user - so the problem does NOT locate within home space.
Also a change to testing was fruitless.

Any help would be appreciated, as I don’t see a way to install new (needed) programms without update, which broke my system many times. I learned to love timeshift ;-).

OK, this MAY not so important, as I relalized late but finally I had a customized system, to get wayland with external monitor running. For this I used kwinFT(-git?) and some other packages. A timeshift to a very early state of my system before the tweaks solved the problem.

I would be still interested how to debug such problems further.

I had a similar issue, system got stuck in the loading screen, Alt+F2 worked and I could open programs but couldn’t move or resize. I used tty2 and did:

pacman -S plasma-desktop-git

Then I rebooted and it worked. Seems to have been solved in the git version, though I wouldn’t recommend this since I believe it would be unstable. A temporal solution, I guess.

I had the same problem, and it got gradually worse.
after a while even sddm did not appear anymore and I had to login via tty2 and type startx to start kde, reinstallation of sddm soved that, but after another week the keyboard started malfunctioning (1 keystroke produced multiple characters) and the shift lock led started blinking.
At that point I gave up and did a complete re-install
So unfortunately no idea on hat went wrong