KDE Plasma: how to use the super / meta / windows key to open the menu?

plasma

#1

Hello,

I read that one of the new Plasma 5.8 features is being able to access the K menu / App launcher just by pressing a modifier key (say the super / meta / windows key).

I have installed Manjaro KDE 16.06 and been updating everything since then, but this doesn’t work by default. I have tried editing K menu’s shortcut, but the single Meta key isn’t accepted as a shortcut. How do I enable this feature?


Meta/Super key not bringing up menu in KDE
#2

I believe that ksuperkey has been integrated into Plasma 5.8, try setting the menu to ALT+F1.


#3

Setting it to ALT+F1 makes the super / meta / win key work.
But is this the way it’s meant to work? One could desire assigning super and Alt+F1 to two different actions…
Moreover, now super just opens the menu but doesn’t close it (I have to press Esc). Is there any way to make it toggle the menu (open and close) and not just open it and then do nothing?

EDIT: this toggle thing has been already filed as a bug: https://bugs.kde.org/show_bug.cgi?id=367685


#4

Yes, even under Windows Alt+F1 is the menu, always has been.


#5

My “windblows” key works to open the menu…never had to set anything.

Best regards.


#6

This was broken for a while, and Alt-f1 was the only way to get the menu.
Now it appears fixed again, but not entirely (toggle action not working on Windows key, but is working on alt-f1).

20 years after microsoft forced a windows key onto the worlds keyboards there is still no complete acceptance of it nor consistent usage between distros or DEs.


#7

On X11 our global shortcut system does not have such a deep knowledge about all key states. It only registers to the shortcuts one has configured and in general it triggers on the press event, for modifier only we need trigger on the release event. As our X11 shortcut system relies on key grabbing we couldn’t use it for modifier only support: the chances to break applications are too high. […]

Another reason why its good to go to wayland.


#8

I still have ksuperkey installed and running, does this integration mean it’s deprecated? To close the application menu, ESC works with ksuperkey. Could you please test if it works without?


#9

Why should linux “bow down” to the “almighty” ms?? The operative word used here is “forced”…that’s how ms does stuff.:angry:

Best regards


#10

Linux should use the hardware it is given. Even if we have to write our own drivers.

Surrendering keys on the keyboard just because of who got them introduced is the perfect definition of bowing down.


#11

I disagree, ms has always had a stranglehold on hardware due to strongarm tactics…hardly a fair playing field. Linux does amazingly well considering the situation.

Best regards.


#12

thats also how it works with the new integration.


#13

Alright, it still works after I kill ksuperkey. Time to remove the package.


#14

Umm, the Apple (command) key has been around way longer than the Windows meta key.

Just saying.
:wink:


#15

I think there is no point in stretching my hand to press Alt+F1 every time I want to open the menu since there is a Win key, even if it has been introduced by M$. :slight_smile:


#16

Indeed, I agree. Linux does very well in my opinion adapting to the available hardware. Some hardware is designed with only m$ in mind.

Best regards.


#17

On Plasma version 5.8 the meta key works “naturally” to open the main menu. If you have the ksuperkey script enabled in startup, you should disable it to the meta key works correctly.


#18

It works to Open and, CLOSE, which is the topic of this thread. This is a recent fix which just sneaked in a day or three ago.

Not a big deal, since clicking anywhere else would have closed the menu. But every once in a while you get stuck without any mouse or pointer.


#19

I had to set the Alt+F1 shortcut to make the super key work. I have just noticed that, after the last updates, it works both to open and close.
But, if I remove the Alt+F1 shortcut, the super key doesn’t “naturally” do anything.
No ksuperkey script enabled.


#20

@ciacnorris

There is no need to modifiy anything (keep Alt+F1 as the default). This is enough for the meta key works to open and close the main menu. I recommend that you open “System activity” (Ctrl+Esc) and look for “ksuperkey”. If it is running, finish the process. Your KDE Manjaro needs to be up to date. If it does not work, try rebooting (check ksuperkey). Those was the steps I made to metakey works to open/close the main menu.