KDE Plasma: how to use the super / meta / windows key to open the menu?

plasma

#13

Alright, it still works after I kill ksuperkey. Time to remove the package.


#14

Umm, the Apple (command) key has been around way longer than the Windows meta key.

Just saying.
:wink:


#15

I think there is no point in stretching my hand to press Alt+F1 every time I want to open the menu since there is a Win key, even if it has been introduced by M$. :slight_smile:


#16

Indeed, I agree. Linux does very well in my opinion adapting to the available hardware. Some hardware is designed with only m$ in mind.

Best regards.


#17

On Plasma version 5.8 the meta key works “naturally” to open the main menu. If you have the ksuperkey script enabled in startup, you should disable it to the meta key works correctly.


#18

It works to Open and, CLOSE, which is the topic of this thread. This is a recent fix which just sneaked in a day or three ago.

Not a big deal, since clicking anywhere else would have closed the menu. But every once in a while you get stuck without any mouse or pointer.


#19

I had to set the Alt+F1 shortcut to make the super key work. I have just noticed that, after the last updates, it works both to open and close.
But, if I remove the Alt+F1 shortcut, the super key doesn’t “naturally” do anything.
No ksuperkey script enabled.


#20

@ciacnorris

There is no need to modifiy anything (keep Alt+F1 as the default). This is enough for the meta key works to open and close the main menu. I recommend that you open “System activity” (Ctrl+Esc) and look for “ksuperkey”. If it is running, finish the process. Your KDE Manjaro needs to be up to date. If it does not work, try rebooting (check ksuperkey). Those was the steps I made to metakey works to open/close the main menu.


#21

This does not work for me. I was using KDE Neon a couple of weeks ago and it was working there (using the same ~/) so I know it can work. In manjaro it does nothing though. I don’t have ksuperkey installed or running, manjaro is up to date, Alt+F1 does nothing. Which shortcuts do I need to assign?


#22

Set whatever key you want to use by
system settings --> Shortcuts --> Global Shortcuts --> Plasma --> Activate Application Menu Widget --> Global Alternate


#23

That still does nothing for me.


#24

you need to set ALT+F1 for your menu, then meta will work


#25

It works for me.


#26

Now that you mention it, it no longer works for me either. This was working perfectly up till last week. I’ve made no changes. (And Alf-F1 doesn’t work any more either.)
Going to try log-out and back in again.


#27

Yup, that solved it. Try logging out and back in again.


#28

I logged out and logged back in but still nothing.

I added ALT+F1 to my menu but neither that nor meta do anything.


#29

‘Global Alternate’ click ‘apply’


#30

Well I want to just use the meta key, it is not possible to assign that to something though.

I added something to test but neither shortcut does anything.


#31

Then try “Activate Application Launcher Widget” then.

You may have used ‘Launcher’ instead of ‘Menu’. (and that’s okay).


#32

That gave me an idea, I forgot that the default isn’t the Menu, which is what I was using. I switched to the other Launcher and the shortcut worked straight away, then switched to the Menu again and it also worked there too. That’s really weird that doing that would make it work but nevermind. Thanks for the help, it was starting to drive me a little crazy!


Alt+F1 no longer pointing Plasma to the Meta key?