KDE Plasma Desktop Freezing

Hi everyone, I noticed sometimes the Desktop freezes and I can’t use the icons and links I put on it. They work if I open for example Dolphin and click on them, or via terminal, but not via “the graphical way”. What can I do when this happens? This is the output of inxi -Fx:

System: Host: manjacomo Kernel: 4.13.11-1-MANJARO x86_64 bits: 64 gcc: 7.2.0
Desktop: KDE Plasma 5.11.2 (Qt 5.9.2) Distro: Manjaro Linux
Machine: Device: laptop System: LENOVO product: 7440W5V v: ThinkPad R400 serial: N/A
Mobo: LENOVO model: 7440W5V serial: N/A BIOS: LENOVO v: 7UET94WW (3.24 ) date: 10/17/2012
Battery BAT0: charge: 48.4 Wh 101.4% condition: 47.7/56.2 Wh (85%) model: LGC 42T4653 status: Charging
CPU: Dual core Intel Core2 Duo P8400 (-MCP-) arch: Penryn rev.6 cache: 3072 KB
flags: (lm nx sse sse2 sse3 sse4_1 ssse3 vmx) bmips: 9046
clock speeds: max: 2267 MHz 1: 2261 MHz 2: 2261 MHz
Graphics: Card: Intel Mobile 4 Series Integrated Graphics Controller bus-ID: 00:02.0
Display Server: x11 (X.Org 1.19.5 ) driver: intel Resolution: 1280x800@60.00hz
OpenGL: renderer: Mesa DRI Mobile Intel GM45 Express version: 2.1 Mesa 17.2.4 Direct Render: Yes
Audio: Card Intel 82801I (ICH9 Family) HD Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
Sound: Advanced Linux Sound Architecture v: k4.13.11-1-MANJARO
Network: Card-1: Intel 82567LM Gigabit Network Connection driver: e1000e v: 3.2.6-k port: 1840 bus-ID: 00:19.0
IF: enp0s25 state: down mac: 00:21:86:a1:af:01
Card-2: Intel PRO/Wireless 5100 AGN [Shiloh] Network Connection driver: iwlwifi bus-ID: 03:00.0
IF: wlp3s0 state: up mac: 00:21:6b:91:f6:66
Card-3: Edimax EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS] usb-ID: 002-002
IF: N/A state: N/A mac: N/A
Drives: HDD Total Size: 280.1GB (25.8% used)
ID-1: /dev/sdb model: WDC_WD1600BEVS size: 160.0GB
ID-2: /dev/sda model: KINGSTON_SH103S3 size: 120.0GB
Partition: ID-1: / size: 110G used: 20G (19%) fs: ext4 dev: /dev/sda1
ID-2: swap-1 size: 4.29GB used: 0.00GB (0%) fs: swap dev: /dev/sdb4
Sensors: System Temperatures: cpu: 58.0C mobo: 40.0C
Fan Speeds (in rpm): cpu: 2630
Info: Processes: 168 Uptime: 52 min Memory: 1902.4/3850.2MB Init: systemd Gcc sys: 7.2.0
Client: Shell (bash 4.4.121) inxi: 2.3.43

Please open System Settings>Display & Monitor>Compositor>Rendering backend and see if is set to OpenGL 3.1. It not, change it. If it is, change it to 2.0.

You have a video card using Intel GM45 driver for rendering. Your config file for it may also need a bit of adjustment (sna versus uxa).

regards

Sometimes this happens when process baloo is active and is indexing files.

1 Like

@c00ter I’ve tried setting OpenGL 3.1 but it kept frozen. I’ve then tried setting XRender and after a reboot it worked. I now have set it again to OpenGL 3.1 (it was OpenGL 2.0 originally) and the issue hasn’t represented yet. I’ll update as it happens again.

@mudwalker I’ve had problems with the baloo file indexer process using 70% of my CPU on the x86 version of Manjaro but I’m actually on the x64 and there’s no sign of baloo indexing as before. I don’t know if it is the cause of the freezing start.

Thanks for your help both!

The desktop just froze again, the renderer is now OpenGL 3.1 and I still got the issue. What should I do?

Kill baloo, it you think file search/indexing may be the cause.

I don’t have this issue anymore, it was only on the x86 version of the system. Actually baloo isn’t around doing weird stuff so I don’t believe it can be responsible of the freezing.

Are you maybe using steam when this happens?

I still believe this may be true.

@eugen-b, is it you that has an Intel GM45 GPU?

Get off this kernel.

I had similar mysterious hangs (all of which eventually cleared by themselves) on 4.13 and also 4.12.

I switched to 4,14 (LTS) today and it boots faster, runs smoother, no hangs.
.
.
.

(Oh, and FTR: stop blaming baloo. Baloo is niced such that it doesn’t matter what percentage of CPU you think its taking. Especially when you have multiple cores.
Learn about nice people!
Run balooctl checkDb (its one of the most expensive baloo tasks you can do) and notice how responsive your desktop remains.)

1 Like

Baloo is niced, but if you install KDE to a desktop that has a few TB of data in a separate /home directory, you will notice its presence until everything is indexed. Especially if concurrently stocking the installation with applications, Even on an i7. Even with tons o’ RAM. :smiley:

That’s why I kill it every time I do a clean install. But you are correct that, once indexed, it takes little resources. I re-start baloo after all is said and done.

So I am in agreement in this case, but you just know I had to show you an exception, didntcha? :smiley:

Video drivers. Kernel. One o’ them.

3 Likes

Well there was bound to be a corner case. :wink:

What is a Separate home directory?

If you hard link another big disk into your /home/cooter, you might see it index that, but usually that would not happen during initial setup. And it won’t cross a file-system even if linked.

Baloo only indexes YOUR home. ( echo $HOME ) and its sub-directories.
Not even all /home directories (unless/until those users log in).

Its controlled by ~/.config/baloofilerc Which looks something like this:

[Basic Settings]
Indexing-Enabled=true

[General]
dbVersion=2
exclude filters=libtool,*.rcore,CMakeCache.txt,conftest,*.moc,CMakeTmp,*.m4,*.omf,*.swap,autom4te,CMakeFiles,.pch,.uic,*.loT,*.pc,*.pyc,.svn,.obj,confstat,*.gmo,*.aux,*.po,lzo,*.vm*,core-dumps,*.elc,_darcs,*.o,*.orig,*.lo,*.rej,po,*.class,confdefs.h,qrc_*.cpp,.hg,__pycache__,lost+found,*.la,Makefile.am,*.csproj,.histfile.*,config.status,CMakeTmpQmake,moc_*.cpp,CTestTestfile.cmake,*.nvram,CVS,ui_*.h,*.part,cmake_install.cmake,*.tmp,litmain.sh,.git,.moc,*~,.xsession-errors*,.bzr,.iso
exclude filters version=2
exclude folders[$e]=$HOME/VirtualBox VMs/
first run=false
folders[$e]=$HOME/

Note: The exclude folder was added by me, probably un-necessary since vm* is excluded by default.

It wont automatically index some other random directory under /home. Only those under /home/[user]/ and each [user] is separate and only indexed when that user is log in.

I have noticed that Pictures, music, and movies can take a long time to scan, and those are not excluded by the defaults. The utility of scanning these is questionable at best (IMHO) because all it will add is meta-data. You could add those directories to the exclude list. (They will still be included in the file name index). I just don’t make a practice of keeping them in my ~home directory anyway,

To intentionally add other locations for it to index you have to manually change ~/.config/baloofilerc because there is no way to manage that in system settings. (You can manage exclusions in system settings or manually).

Example:
I have a large code base on one of my machines, and I find it very useful to have that indexed, so I manually add that code library directory to my baloo. I can find the source code for any program that touches a particular variable in less than a second with Dolphin.

Note: (I had to nag Vishesh Handa (baloo author) to get him to remove an arbitrary limitation on the size of plain text files buried deeply in the code due to a forgotten early days bug in Baloo. Took 9 months of bug reports and personal emails to get it removed.)

3 Likes

Well, of course. :smiley:

Semantics will get you nowhere. :wink:

A week or so ago when I got done testing-out GNOME 3.26 I returned to Plasma by doing a fresh install after formatting “/”, retaining my data in a /home directory in a separate partition on the same HDD. Better? :wink:

I noticed–as I have before–a very sluggish system while Baloo was initially searching/indexing /home. I believe it’s only because I’d already set SWAPPINESS to “1” that it wasn’t worse. I’ve done this a few times before, ya know? :smiley:

Thanks for the exclude list and tute! :smiley:

Now let’s try to sort out OPs initial problems! :smiley:

Regards

I have Steam installed but it looks like the freeze is unrelated to Steam running. It usually freezes after booting and logging-in, then randomly unfreezes a couple days later.

Done as the 4.14 got released, still have the freezing desktop and I haven’t noticed any particular improvement; the only difference I noticed is it takes more time on the login screen to show me the desktop than the 4.13 or 4.12.

What I noticed via htop was that baloo was taking me 70% CPU of both cores, the system was in fact slower and the laptop started boiling, so I believe it was actually using that CPU percentage pretty heavily; it’s not a problem anyway, I don’t believe it’s baloo’s fault more than my hardware’s fault… This is an old PC so I’m used to having issues related to low CPU performance or I/O performance. I was just documenting my experience with baloo on the x86 installation. In fact on the x86_64 installation it didn’t give any problem at all.

I would gladly give you a medal for that, your determination is remarkable.


Thanks everyone for the explanation on how baloo works, the more you know the better :slight_smile: . Anyway, I guess I should follow @c00ter advice and take a look at that config file. The problem is I don’t know where to begin. Can anyone guide me in what I should do to adjust the configuration? :smiley:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by