KDE Plasma 5.26.x Stability Inquiry

So…we be in the Manjaruminati now? I’m all in with that! LOL.


Be careful with today’s update to kde apps 22.12 in unstable guys, plasma already crashed twice on me since I installed it this morning ! :frowning:
Rolled back to 22.08 this afternoon and no more problems now…


What were you doing at that time? I’m not seeing any crashes with 22.12. More detail/logs or this has to be regarded as FUD imho.


I’m on manjaro stable. On the process of updating to 5.26.4 now.
Since I left the safe grounds of 5.24 the only thing really bothering me is not the little quircks I can live with. It is just the fact that I can’t keep my machine running all time as it used to be. If I don’t put it to sleep overnight then most times in the morning the shell is stuck.
It never happens while I’m working, just when the machine is idle for some hours. I hope 5.26.4 makes it more stable but otherwise… what is the best way to downgrade to 5.24.7? Is there a manjaro meta package that does that?



From earlier in this thread:

However, keep in mind that the gravy train might not last much longer. Later releases of KDE Frameworks might soon cause glitches and breakages if we stick with KDE Plasma 5.24.7.


After the recent update (
[Stable Update] 2022-12-06) of Manjaro, I get rid of this problem without turning on DND. :heart:


happens again

Nothing special really, I just started Dolphin ! :wink:
KDE just frooze, I got lucky to open a console to reboot safely…
No logs or errors to show you, sorry.


1 Like

Hey man, you could try the following:

journalctl --boot=-1 --priority=4


  • --boot=-1 is the boot this happened. Adjust as necessary: -1 for the previous boot, -2 for the one before that, -3 for the one before that, and so on and so forth;
  • --priority=4 will limit the output to Warnings and Errors from the specified boot.

Hope it helps for something.


Thanks for responding but allas, because I used timeshift to rollback to previous day, all evidence is gone… Will try again when those updates hits “testing”…


1 Like

It’s just for future reference and you’re welcome!

1 Like

Live on the edge and switch to unstable branch. New KDE Apps and Frameworks …


To be honest, I think some of us are already close…to the edge :wink:


Just re-posting from latest stable release thread …

My system survived the whole upgrade sequence 5.24 to 5.25 to 5.26.2 to 5.26.3 without a hitch
But no more, since latest stable udpdate …
Plasma is completely broken - it flashes in and out of existence every few seconds until I kill it
Not sure if it’s the upgrade to 5.26.4 or the plasma-frameworks upgrade which caused the problem …

I’ve been following this thread for a while now
What is my best option here?

  • set up a new user - seems unappealing
  • restore system from backup - but then what happens at next update?
  • downgrade to 5.24.7 LTS - that path is surely doomed to fail at some point …
  • reinstall whole os - very unappealing
  • live on the edge as @phil says and switch to unstable?

Anyone …?

Currently working with no DE … at least kwin still goes

Creating a new user is very quick and easy, and you can then see if the problems persist with the new user. If the problems are gone, you can then copy over your files from your home bit by bit until you find out which configuration file caused the issue (and obviously don’t keep that copy…).

If the problems persist, then you can go to another option. Of those you list, I would recommend trying the unstable update before anything else. If that doesn’t work, a downgrade and holding the offending package(s) may tide you over until the bugs are fixed for you. It is almost never necessary to reinstall the operating system with Linux.

The other option you haven’t mentioned is switching desktop environment (or customise your own with your window manager of choice). Might be one to consider.

1 Like

Thanks for that @summrum
I tried the unstable option, but sadly no change … the current unstable update does not actually have a plasma-desktop update anyway, so no change - will try again

Also, have not succeeded with the new user as yet - will persist with that

OK, new user is set up and plasma shell is go … that’s a positive result at least
It seems like a daunting task to copy over files from old home to new home …
This is an old (7 years?) manjaro installation which has been considerably tweeked over the years
Maybe it can be done …

1 Like

There is no specific reason to think that this will work, but have you tried clearing the various KDE cache files?


Wow, @Takakage, you are indeed the hero of the day in my world!
I followed those cache-clearing steps and plasma is working just fine again!
Fantastic, thanks for that!

We often look for complex solutions when the easy ones do the job!


True, more or less. Glad you found a way out of this pickle :+1:

Thanks @Frenchy - I know you felt my pain :grinning:

Well, some of us are telling this over and over again: clean your system, cache, settings, etc. and only then bi*ch about Plasma.