KDE Plasma 5.18.5 Dual monitor problems

Have a strange issue with Plasma not wanting to remember which monitor I set as the main monitor, the built in monitor of the Lenovo T520 or the Auria monitor connected to the T520 via DP.

Seems to happen after I sleep the system or do a restart.

Also this morning is set the Auria monitor to 30Hz refresh rate that at first made me think my vision or monitor was on its last leg.

Should I report this to KDE direct or is posting it here sufficient?

Seems to be a very random issue as this morning it came out of sleep just fine with the monitors settings perfectly intact...

Did it again from Sleep this morning but this time it would only let me choose between 20 or 30 hurts and resolution was maxed at 1920 x 1080 until after I rebooted the system then it would let me select 60Hz and the true max res of the monitor of 2560 x 1440

I really have no idea why one day it sleeps and wakes just fine and other days it just messes up the external monitor?????

I've seen this problem pop up couple of times on KDE reddit, like that:

At least it's known...

Few things that i know:

  • It seems to happen only on displayport (upd: HDMI too :sweat_smile:)
  • It seems to be connected to nvidia drivers, i suppose you have them?

Should I report this to KDE direct or is posting it here sufficient?

Always do that, here everyone cares mostly about Manjaro / Arch parts, DE's bugs must be reported to them directly...

Well unless it's something that freeze your system or something critical like that, then here is more than fine :upside_down_face:

Thank you for the reply.

My Lenovo T520 actually uses "2nd Generation Core Processor Family Integrated Graphics Controller (Intel Corporation)

But yes I have read that nvidia drivers seem to cause some issues out there.

Of course this morning it woke from sleep just fine... so strange.

I will report this over on the KDE website.

Thanks again.

1 Like

UPDATE:

So after sending in a bug report on the 19th, the day after they released an update. I have been testing since then and have not had one issue with my Dual monitor setup since the update. 3 days of the laptop going to sleep at night and waking in the morning with no monitor issue.

If I reboot the system the task bar still moves back to the laptop screen and I have to manually change it in the settings menu to move it back to the external display but other than that it is much more stable.

Update 2: Guess I should not have said anything as this morning it started doing it all again.

Very strange.

Forum kindly sponsored by