KDE: Parts of system UI are oversized

Some time ago I switched from Windows to Linux Mint and now hopped over to Manjaro.

After booting into my live system and also after installing it to the PC, I saw that most parts of the system UI are completely oversized (see screenshots).
Screenshot_20200104_230722|690x388

The taskbar looks fine, the welcome dialog was also correctly scaled. A wrong size have the system apps like the settings, konsole, dolphin, etc.
Further are the panel decorations way to big, desktop icons are huge and the start menu is nearly unusable.

I use the proprietary nvidia drivers.
All packages are up to date, the screen resolution is set to 1920x1080 and the global scale is at 1.

How can I fix this?

1 Like

It looks as if you have the standard, out-of-the-box Manjaro theme. Two ideas:

  1. In System Settings, if you type size in the search box, can you adjust your icon size and font sizes?
  2. Have you tried creating a new user?

What is global scale is set to? (system settings > display configuration). (oops: i'm bad at reading)

By any chance are you on plasma-wayland session?
Do you use custom settings for fonts?
Mine are like this:

image

I'm not using wayland and I have the default settings (problem persists even after reinstall).

I looked through different apps and I think it's a problem with the graphics framework:
Fine are:

  • Pamac (Gtk3)
  • Steam
  • Firefox / Thunderbird (except the window titlebar)

Problems have:

  • Dolphin, Terminal, System Settings (all Qt5)
  • Qt Designer (Qt5)
  • VLC
  • and every other system app using Qt5
1 Like

New users are affected in the same way (the login screen is already).
Font and icon size changes have no effect. Increasing the global scale or reducing the resolution make it even worse.

The solution was switching to the nouveau driver.

1 Like

Hi, I think this is definitely not a solution.

I encounter the same problem of oversized font with some apps (Dolphin, Terminal, etc.) using Intel integrated graphics so... I cannot switch to Nouveau !

The solution I found is : unchecked the "Force font DPI" option in Plasma Settings -> Fonts.

Could you please check if it solves the problem for you under Nvidia Driver ?

Best regards

Doesn't work see here:

You would have to wait for Plasma 5.18 i'm afraid...

I have the same issue as the OP - see screen.


Login screen is also oversized.
When I use the integrated Intel GPU (Z390-E mobo) and not the RTX card the display is perfectly fine.

An interesting thing is initially after install the display was correct. It turned bad while I was trying to configure the 2-screen setup (which doesn't work either currently) and I've not been able to switch back.

The "Force font DPI" doesn't work.
The "QT_AUTO_SCREEN_SCALE_FACTOR=0" in the environment file doesn't work either.

As I am a fairly new converted to Manjaro I'm quite at a loss... I'd appreciate a step-by-step guide if possible -or a pointer to some more things to try-.

1 Like

Issue solved.
In fact I enabled the wrong non-free driver.
I am on a desktop PC, mobo with Intel GPU and I've added a RTX2070 Super in the box.
I originally wrongly enabled the combined Intel / NVidia driver (video-hybrid-intel-nvidia-440xx etc) and got the above results.
I switched to single video-nvidia-440xx and now everything is back to normal.
So my advice for future readers of this topic: Double check the driver you've enabled!
Less headaches later...

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by