KDE mouse scroll speed

Greetings !,
I would like to increase the speed/steps for the my mousewheel.
I’m using Manjaro KDE 5.13.5.
In the mouse settings it used to be the setting for this - “Mouse wheel scrolls by”. Also “Drag start time” and “Drag start distance” where there…
Now the settings are like this :
Will these settings come in the future ? Or can you suggest a solution ?
I did not find anything for KDE and the scrollwheel that works for me.
Thanks !

1 Like

That’s the results of libinput instead of libsynaptics, and was all done to accommodate Wayland in GNOME. Libinput is not needed in Plasma–yet–so you can change over to the libsynaptics driver and it will give you a different Input Devices selection. But be warned–it will also impact your Touchpad, if you are using a laptop.

The information on how to change drivers can be found by doing a forum search here or referring to the Arch Wiki.



try this:

1 Like

I have tried, but any change on the files, did nothing for the mouse.
Does it matter that it’s Logitech ?
Any other solution, more … newbie friendly ? :slight_smile:
I come from LinuxMint … so I’m not so savvy, yet

I have a Logitech mouse. Did you read the part where i mentioned what needs to be commented from the file? You could also create a new file:

sudo cp /usr/share/X11/xorg.conf.d/10-evdev.conf /etc/X11/xorg.conf.d/11-evdev.conf

that has only this lines:

Section "InputClass"
        Identifier "evdev pointer catchall"
        MatchIsPointer "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"

After reboot you should have the complete settings for mouse in KDE.


And that’s how you help a neewbie !!! :smiling_face_with_three_hearts:
With the creation of “11-evdev.conf” it worked !!
Multumesc din suflet !!

1 Like

The huge problem is that the mouse movement is wanky again, because of the acceleration. You cannot disable acceleration.
So it’s better the way it is now, with no scroll option :disappointed_relieved:

1 Like

This are my settings and i feel no latency and no wonkyness, quite the default settings.
Do you have the Compositor set to OpenGL 3.1 in Display and Monitor Settings ?

I did try with OpenGL3.1 and it’s the same

  1. I have a laptop, so the file /etc/X11/xorg.conf.d/11-evdev.conf - I have to leave it intact, otherwise the touchpad doesn’t work.
  2. The laptop is connected to a TV through HDMI, so the wonkyness was always a issue for me. On ALL the distros that I have tried. Only on Windows OS the mouse was crisp. And so far, with Manjaro with the new config, my mouse is almost as good as in Win. The only withdraw with this is, I as a newbie, I cannot increase the scroll lines.
    But so far this is a very small price to pay for the mouse to work perfectly.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by