KDE manjaro zsh style for Konsole?

Used to use XFCE and zsh as shell and it had this nice Manjaro M in prompt (from manjaro-zsh-config).
My .zshrc style part is identical to /etc/skel/.zshrc from manjaro-zsh-config.
Swapped DE to KDE/Wayland (for vrr support) but now the zsh looks just weird in Konsole compared to xfce terminal.
Is this font issue? What should I choose? Is there manjaro-zsh-config for KDE?

Yes. :wink:

The default should be the Hack font, but Droid Sans Mono will also work very well. :wink:

Not specifically, no, but the konsole profiles in Plasma are of course designed specifically for consistency with the Manjaro theme used in Manjaro Plasma, and the fonts are set in the konsole profile.

1 Like

Swapping to Hack fixed the right arrow, but M and the other icon are still missing and have those boxes there. :frowning:

just in case re-installed xfce4-terminal and there the icons are present as before…

Notice manjaro-zsh-config depends on ttf-meslo-nerd-font-powerlevel10k as it’s the recommended font. See GitHub - romkatv/powerlevel10k: A Zsh theme

However, any Nerd Font should work. If you want to use Hack, then install ttf-hack-nerd.


Droid Sans Mono at 10pt size… :arrow_down:

2023.10.07 - 19:15

Had ttf-meslo-nerd-font-powerlevel10k installed already, didn’t change a thing. installing ttf-hack-nerd fixed it. Weirdly enough xfce4-terminal worked with “Hack” also and was fine (even without this ttf-hack-nerd).

Just having a font installed indeed doesn’t change anything. Did you change the font in Konsole?

Nope. Was Hack (after Aragorns suggestion then, but still with boxes; Originally I think it was Noto Sans Mono), still is Hack, just had to restart Konsole after installing ttf-hack-nerd and it automatically worked.

That’s apparently what did it since you didn’t change the font in Konsole.

technically no, because I restarted it after every change… just in case. Like changed the font in Konsole from Noto Sans to Hack; boxes remained; restarted; boxes still remained; swapped font in Konsole to Droid Sans Mono; font changed, boxes remained; restarted Konsole; still boxes; Changed font back to Hack; restarted; still boxes; installed ttf-hack-nerd; restarted Konsole; correct icons shown.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.