Kde manjaro slow to boot


I have been using KDE manjaro for a couple of months now and I have recently noticed that it got slower to boot.
I have done my duty searching the forum for some explanation but, newbie I’m, and hence did not find a way to fix thingsd.

So may I ask for your Help?

Startup finished in 7.059s (kernel) + 37.983s (userspace) = 45.043s 
graphical.target reached after 36.975s in userspace
systemd-analyze blame 
18.609s udisks2.service                                
14.333s systemd-journal-flush.service                  
10.390s dev-sda1.device                                
10.380s lvm2-monitor.service                           
10.152s polkit.service                                 
 9.181s cups.service                                   
 6.266s avahi-daemon.service                           
 6.258s NetworkManager.service                         
 6.236s systemd-logind.service                         
 4.639s apparmor.service                               
 4.504s ModemManager.service                           
 3.434s systemd-udevd.service                          
 3.309s ufw.service                                    
 3.242s user@1000.service                              
 2.671s systemd-tmpfiles-setup-dev.service             
 2.551s upower.service                                 
 1.884s colord.service                                 
 1.370s wpa_supplicant.service                         
 1.289s systemd-tmpfiles-setup.service                 
 1.128s systemd-modules-load.service                   
  999ms tlp.service                                    
  918ms modprobe@drm.service                           
  752ms systemd-random-seed.service                    
  742ms systemd-tmpfiles-clean.service                 
  595ms systemd-rfkill.service                         
  555ms systemd-binfmt.service                         
  549ms systemd-journald.service                       
  473ms systemd-sysctl.service                         
  465ms systemd-udev-trigger.service                   
  410ms dev-hugepages.mount                            
  409ms dev-mqueue.mount                               
  407ms sys-kernel-debug.mount                         
  405ms sys-kernel-tracing.mount                       
  403ms snapd.service                                  
  401ms modprobe@fuse.service                          
  347ms sys-kernel-config.mount                        
  319ms tmp.mount                                      
  316ms kmod-static-nodes.service                      
  313ms modprobe@configfs.service                      
  261ms snapd.apparmor.service                         
  258ms sys-fs-fuse-connections.mount                  
  257ms systemd-timesyncd.service                      
  215ms systemd-backlight@backlight:acpi_video0.service
  204ms systemd-user-sessions.service                  
  142ms rtkit-daemon.service                           
  125ms systemd-remount-fs.service                     
   92ms systemd-update-utmp.service                    
   88ms user-runtime-dir@1000.service                  
   57ms linux-module-cleanup.service                   
    6ms proc-sys-fs-binfmt_misc.mount                  
    2ms snapd.socket   
systemd-analyze critical-chain udisks2.service
The time when unit became active or started is printed after the "@" character.
The time the unit took to start is printed after the "+" character.

udisks2.service +18.609s
└─basic.target @22.291s
  └─sockets.target @22.291s
    └─snapd.socket @22.289s +2ms
      └─sysinit.target @22.218s
        └─systemd-timesyncd.service @21.959s +257ms
          └─systemd-tmpfiles-setup.service @20.647s +1.289s
            └─systemd-journal-flush.service @6.311s +14.333s
              └─systemd-journald.service @5.753s +549ms
                └─systemd-journald.socket @5.536s
                  └─system.slice @5.270s
                    └─-.slice @5.270s

Should you need any other information…

thank you for your help;

you have an HDD 5400 trs/mn
think about an SSD

You can safely disable:

Thank you for your reply.

Thank you for your reply.

would systemctl mask unit do the trick?, and if so, would this look something like:
systemclt mask lvm2-monitor.service