KDE manjaro install hangs at 93% and no internet connection via ethernet

AMD r9 390x
Fx 6350 cpu
Gigabyte GA-990-FXA-UD3 Rev 4.1 mobo with a Realtek RTL8111/8168/8411 pci express gigabit ethernet controller (Rev 06)

I have an issue when installing KDE manjaro from a live USB disk. It hangs at 93% installing “Misc postinstall configurations”. I’ve canceled it and reinstalled it. I partition it myself and just put everything on one partition (root, swap, boot) by just selecting / as the mount point for the partition. If I cancel it at that point and reboot, it starts up fine except my ethernet connection has no internet.

I’ve had the ethernet issue in the past an dut was bc I have a Realtek controller for it. This was a year ago and I was hoping it was fixed by now. A thread I made back then, a guy suggested the following after I told him I couldn’t ping the Google dns address and I had no resolve.conf file:

I don’t know why you don’t have resolv.conf but create it and write a DNS name solver address in it, like 9.9.9.9

  sudo nano /etc/resolv.conf

  write
  save with: ctrl o
  exit with: ctrl x
  reboot

My file:

  $ cat /etc/resolv.conf
  # Generated by NetworkManager
  nameserver 9.9.9.9

I haven’t tried that yet, but I’m at work right now and will when I get home. Any other suggestions in the meantime? Particularly with why it’s hanging at 93% during install? I don’t like forcing it to end bc I feel like I might discover stuff is broken down the road bc of it.

1 Like

It’s almost impossible for anyone to answer this without Calamares installation log.
About internet, search for recent changes regarding resolv.conf in the forum, maybe it helps.

Normally you don’t need a internet connection to install Manjaro. Please provide the install log or try to start calamares in debug mode from within a terminal: sudo -E calamares -d. I also recommend the v18.0 series.

Sorry for the VERY late reply. I needed a working OS right away so I've been using Ubuntu since last July. Ready to try this again.

Do I start that calamares log prior to beginning the installation process?

If I end the process when it hangs, I am able to boot into Manjaro but I have no internet. I suspect it has something to do with the Realtek ethernet controller issue of my mobo, noted in the arch wiki at the bottom of the "network configuration" page.

Please let me know about that calamares log (when to start that command you gave, during or before I begin installation) and I'll try that and get back to you.

After using Linux for a year, I have much more patience now for troubleshooting. So hopefully we can resolve this. Thanks for your help.

This is a well known issue. Many Gigabyte motherboards have bad USB support, and issues with their r8168 realtek adapters in Linux. You will likely need to use a kernel boot parameter to get your NIC working.

Read this:

I found this https://forum.giga-byte.co.uk/index.php?PHPSESSID=8h47qhnhvhl9mjed9k82o0r721&topic=14802.msg105102#msg105102. I'll give it a try. I think it's the same thing you did in your link too.

Is there a way to set this prior to installing it so it installs with it functional? I worry that if I install it with the hangup at 93% and cancel it, that it may break other things.

Actually, now that I think about it, I believe I tried these boot parameters in the past and it didn't work. Look at this post Installation of 18.0 Hangs at 94% (Postinstall configurations) guy at the bottom blacklists some driver prior to installing and it forces it to install some other one.

Also, here is my realtek controller:
Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06)

Yes there is a way, it's not something I do everyday. You might want to doublecheck before relying on this.

To temporarily add a boot parameter to a kernel:

Start your system and wait for the GRUB menu to show. if you don't see a GRUB menu, press and hold the left Shift (or ESC) key right after starting the system.

Now highlight the kernel you want to use, and press the "e" key. You should be able to see and edit the commands associated with the highlighted kernel.

Go down to the line starting with linux and add your parameter iommu=soft (or whatever) to its end.
Now press Ctrl + x or F10 to boot.

I made a few edits right before you responded. I believe I already tried this in the past, after I installed the OS, and it did not solve the issue with ethernet.

Regarding your response, can I do that grub edit when booting from the live disk? Would that change anything during the install process, potentially?

Yes, I'm pretty sure you can do it from a live disk.

You might also want to change to the r8169 kernel module.

sudo rmmod r8168
sudo modprobe r8169
sudo systemctl restart NetworkManager
1 Like

Trying to understand what I'm doing here, I googled this stuff and am I correct in the following: So we are unloading the r8168 module (realtek driver?) and then loading the r8169 driver instead?

Then restarting the network manager process to implement the change?

Should I do this from a terminal at the grub screen, prior to booting into the live disk?

On a separate note, in another old thread I had from trying manjaro, someone suggested I create and edit a resolv.conf file

I will try your suggestion first (loading r8169 first) and also the grub config line tweaks. Then I'll try this resolv.conf edit.

 

Sorry for all of the questions without trying anything first. I try to get a slew of potential solutions lined up while I'm work, so after work I can try multiple things and not have to wait for responses if solutions don't work, since I have limited time in the evening to actually attempt to troubleshoot. I hope you understand. Thanks

You can try switching the driver from within the live environment.

Sounds good. I'll give this a shot tonight or maybe tomorrow night (need to work on the car tonight). Thanks again

1 Like

How would I set those grub boot parameters like iommu=soft, from the grub menu on a live disk? I can't enter the /etc/default/grub like I normally would, because I don't think it exists yet.

Edit directly the grub entry.
On Installer grub menu, there is a textbox for entering extra parameters, IIRC at the bottom of the list.

This is for a working system.

I'll try this tomorrow night. Thanks

Turns out after installing it, r8169 was already installed as the driver to be used according to

lspci -v

Reloading it with modprobe made it work, but after rebooting it's not working again.

You need to uninstall the r8168 driver from within Manjaro settings manager.

Open Manjaro Settings Manager -> Hardware configuration -> Network controller

Right click on the RTL8111/8168/8411 ethernet device and select “Remove”.

After the uninstall process has finshed, restart.

1 Like

When I try that I get:

Starting

> Removing network-r8168...

warning: database file for 'core' does not exist (use '-Sy' to download)

warning: database file for 'extra' does not exist (use '-Sy' to download)

warning: database file for 'community' does not exist (use '-Sy' to download)

warning: database file for 'multilib' does not exist (use '-Sy' to download)

Sourcing /etc/mhwd-x86_64.conf

Has lib32 support: true

Sourcing /var/lib/mhwd/local/pci/network-r8168/MHWDCONFIG

Processing classid: 0200

warning: database file for 'core' does not exist (use '-Sy' to download)

warning: database file for 'extra' does not exist (use '-Sy' to download)

warning: database file for 'community' does not exist (use '-Sy' to download)

warning: database file for 'multilib' does not exist (use '-Sy' to download)

warning: database file for 'core' does not exist (use '-Sy' to download)

warning: database file for 'extra' does not exist (use '-Sy' to download)

warning: database file for 'community' does not exist (use '-Sy' to download)

warning: database file for 'multilib' does not exist (use '-Sy' to download)

warning: database file for 'core' does not exist (use '-Sy' to download)

warning: database file for 'extra' does not exist (use '-Sy' to download)

warning: database file for 'community' does not exist (use '-Sy' to download)

warning: database file for 'multilib' does not exist (use '-Sy' to download)

error: failed to init transaction (unable to lock database)

error: could not lock database: File exists

if you're sure a package manager is not already

running, you can remove /var/lib/pacman/db.lck

Error: pacman failed!

Error: script failed!

Done ...

Might be because when I installed this, it was hung up on 93% again and I had to "cancel" the installation.

I tried:

sudo pacman -Sy

and got:

:: Synchronizing package databases...
error: failed to update core (unable to lock database)
error: failed to update extra (unable to lock database)
error: failed to update community (unable to lock database)
error: failed to update multilib (unable to lock database)
error: failed to synchronize all databases

I was going to do this: https://forum.artixlinux.org/index.php/topic,112.0.html but I'm not sure how to rebuild the initramfs since Idk what to substitute for LTS in his example.

Make sure that no instances of a package manager is running then delete the lock file:

sudo rm /var/lib/pacman/db.lck

Then:

sudo pacman-mirrors -f 5 && sudo pacman -Syyuu

You may be in a partial upgrade situation if your update failed, so -Syyuu may be required. Normally sudo pacman -Syyu would be the command you would use.

1 Like

Awesome. I'll give that a shot tomorrow night. Thanks for hanging in there to help me out. I really need to finish linuxjourney.com to learn some of those commands

edit: nvm I'm trying it right now real quick. It's still installing a bunch of packages. Is this all of the "postinstall" stuff that was being installed at the 93% mark when it hung do you think?

1 Like

Forum kindly sponsored by