KDE Logo in splash screen instead of Manjaro after update

Hi, I just updated my Manjaro Install and faced a few problems (not sure if they are ‘bugs’), when I change my splash screen under Appearance under System Settings, the apply button is grayed out. So no changing splash screen! :worried:

Please help.

1 Like

Maybe changing to a different one and then back to Breath2 will work.


Yes, it did work !! Thanks a lot. :smiley:

I have the same problem, but changing the topic does not help here. The butto remains inactive in any case.

But for me, changing to Breath 2 and reverting does work. Maybe you need to log out and log back in.

Have you tried the solution from the release Wiki already?

The case is, when after update I clicked the Breath2 splash screen, apply button was greyed out, but after I change the global theme to Breath2 and then change it back to any other global theme, and thereafter choose any splash screen, the apply button reappears.

1 Like

Yes, it did work for you, but AFAIU it doesn’t work for @anon55802073

(or am I missing something?)


OK, this works, thx

1 Like

Thanks that worked for me!

I second @dan1001’s extra steps. They are needed to make the “Apply” button work. Otherwise, you cannot click “Apply” to change the splash screen, as it remains greyed out.

Thus, the Wiki solutions needs to be updated to include @dan1001’s extra steps.

EDIT: On second thought, maybe there’s a better way before the Wiki is updated? After all, this “solution” unfortunately will undo someone’s custom colors, Plasma style, icons, etc. It’s a lot for a user to revert with a single stroke, just to bring back an “Apply” button. :confused: I’d hate for them to have to re-do all of their custom settings because of this update that strangely disabled the “Apply” button.

Solution changed…

I updated the Wiki after more investigation.

  • Backup / remove the old ksplashrc file
  • mv ~/.config/ksplashrc ~/.config/ksplashrc.bak
  • Go to System Settings
  • Type in Splash
  • Click on Splash Screen
  • Select and Apply your desired splash screen

This way you don’t need to completely undo any custom themes, icons, colors, etc, just to bring back a working “Apply” button. :v:

Here is a comparison between the old (broken) and newly created ksplashrc config files:

Old (renamed to ksplashrc.bak):


New (automatically created upon applying your desired splash screen when no available ksplashrc file currently exists):


This worked for me.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.