KDE Language Settings Broken

I have a multilingual system and this is what I see if I try to configure my languages in KDE (I haven’t switched language in a while, but now I need to and I can’t tell if this is due to the last update or not):


System info:



Any idea on how to solve this problem?

The file in /usr/lib/qt/plugins/plasma/kcms/systemsettings/kcm_translations.so is owned by plasma-workspace so you either had a partial update or you did not reboot after the update. To be sure, run from terminal:

sudo pacman-mirrors -f5 && sudo pacman -Syyu plasma-workspace

Reboot your system after that.

OK thanks, I’ve done that and there was actually something missing. But even after rebooting, the problem is still there.

Do you have packagekit and packagekit-qt5 installed?


I admit my KDE Plasma padawan status.

Are you sure they are required?

I don’t have them and my language section works as expected.

Well, I was just going off what the error message stated…

I don’t have them installed, and I have the same error.

Update: And installing them fixed it on my end.

Hmm - a mystery indeed. Perhaps the messages referencing possible causes is more accurate - in the sense of old modules?

My system is heavily trimmed and for one thing I don’t have Manjaro Settings Manager installed - could that be a direction to investigate?

This is from within the KDE Settings, not Manjaro Settings Manager.

The bigger the mystery - I have several systems with the same trimmed Plasma (including rpi4) - no packagekit but the Language settings works fine.

But alas if those packages fix it that is the solution.

But it doesn’t provide hints to as why it works on my end :smile: without packagekit

I had packagekit installed, but not packagekit-qt5. Installing it fixed the issue. Thanks.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.