KDE - Ksystemlog missing logs


After the last major update (v.21) I’m facing some random error that freezes my PC, forces log out, pixel-ed the screen and finally made the system nonoperational requiring me to reset from the case bottom. I post in the announcements thread but for sure there are other priorities. So I decided to try to investigate it myself, regardless I’m still noob with Linux, to find at least some tips about what is happening, the first think It came in my mind is to check system LOGS witch leads me to the ksystemlog tool

For a while, I wasn’t able to find proper issue log, but I found that my system is presenting just some log options, they are:

All the other log options in the ksystemlog are indicated in the configure options as they are missing , see the list below:

  • Acpid log
  • Apache log (this is ok because apache server isn’t installed)
  • Cron log
  • Cups log
  • Daemons’ log
  • Samba log (this is ok because samba server isn’t installed)
  • Postfix log
  • System log
  • X Session log

See attached picture for instance about the system log missing

I have the impression that probably KDE and/or Manjaro devs disabled those log options for any reason in the default installation, maybe to avoid performance reduction, I don’t know just guessing. But how can I enable them properly? I tried to read KDE documentation but didn’t found any explanation how to do it. Maybe it’s simple as creating a log file and link it in the configure option.

Below the doc I was reading

Most of these settings are for syslog logs which isn’t installed by default (if you want these settings you need rsyslog from AUR). But no worry, in Manjaro almost all logs are captured by journald – you need to search them by unit.

Is it possible to see log from older days?

My system log is showing logs only for current day, maybe this is because I shut down the PC every day. I hope the system keep the log info when forced to reset.

Uncheck “Display log entries from current boot only” in Settings > Journald Log. But it may be not enough KSystemLog can load max 30000 entries (it show me about 2 days). KSystemLog is good only if you need to display current logs or you have outside files. If you want older logs you need to use console and journalctl command. For example with this command you display cron logs from begining:

journalctl -u cronie

thank you

Being able to check log from older day the error indicated in the attached image was registered in the Journald LOG. I will keep may eye on it to confirm if they are the errors that crashes my system, I can’t confirm right now, but some google shown that this issue was report in the past to arch and kde community. If my OS crashes again I will try to confirm the log and back here with some feedback.

kdeglobalaccel5 - This application failed to start
systemd - Failed to start KDE Global Shortcuts Server
systemd-coredump - Failed to connect coredump service - connection refused
kwin_x11 - Couldn’t start kglobalaccel

It’s a driver error, maybe due to the last 5.10 kernel update. I just turned my desktop on but after logon I was working on the laptop so the the desktop was basically in idle and the GPU driver present error, maybe when KDE tried to turn the screen off, I can’t precisely confirm for a while because is the first time I was able to use log file properly. If it’s the driver i going to wait the next update to see if it will be fixed.

The issue still remains besides it looks less frequent in the latest kernal 5.10 update.

Once the issue to not correlate directly to the subject i will post the error in a different threat.