KDE interface really slow

kde
intel
nvidia
dell

#21

I was thinking of something like that too, but first I want to understand why there is this problem with intel because is absurd to me that I cannot run something like plasma (that is heavy but not so much) on the integrated card.

I doesn’t have problem with software, or at least the major issue is the DE itself. If i run something through the nvidia card it worl correctly.

Here the output of optirun inxi -SMGxxxz

System:    Host: bering Kernel: 4.19.6-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 Desktop: KDE Plasma 5.14.4 
           tk: Qt 5.11.2 wm: kwin_x11 dm: GDM 3.30.2, LightDM 1.28.0, SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: Dell product: Inspiron 7577 v: N/A serial: <filter> Chassis: type: 10 
           serial: <filter> 
           Mobo: Dell model: 0J8HMF v: A00 serial: <filter> UEFI: Dell v: 1.6.1 date: 08/16/2018 
Graphics:  Device-1: Intel vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:591b 
           Device-2: NVIDIA GP106M [GeForce GTX 1060 Mobile] vendor: Dell driver: nvidia v: 415.18 bus ID: 01:00.0 
           chip ID: 10de:1c20 
           Display: x11 server: X.org 1.20.3 driver: intel compositor: kwin_x11 resolution: <xdpyinfo missing> 
           OpenGL: renderer: GeForce GTX 1060 with Max-Q Design/PCIe/SSE2 v: 4.6.0 NVIDIA 415.18 direct render: Yes

#22

I know this seems to be a video related issue, but perhaps other factors are at play as well. Have you checked on your resource usage. Is your RAM usage excessive. Are you swapping to disk. If so, perhaps changing your swapiness factor may help. Are you using an SSD. How much ram do you have.


#23

Thanks for the reply. I’ve checked and I don’t think is some problem releated to that. I’ve 16Gb of RAM and it’s almost empty (don’t remember the actual value but was normal), Also no swap on disk and OS installed on an SSD drive. All seems fine regard of that.


#24

Can you verify your HW acceleration setup?
Is your browser running in HW accel?

There should be nvidia here too. I don’t remember seeing this again with bumblebee.
Please check

systemctl status bumblebeed
journalctl -b -g "bumble\|bbswitch"

#25

No idea what that is. Nemo FM is for Cinnamon.

You can disable and mask this service.

And you probably don’t need this, either.

None of these–with the possible exception of the first item–will change the perceived “speed” of the UI but will speed up your boot process and slightly lower your system overhead.

nVidia and Bumblebee are outside my area of knowledge nowadays.

regards


#26

Regarding systemd-analyze, it just inspects booting. OP thinks the runtime behavior is slow.


#27

This doesn’t look like a bumblebee setup report. Please provide

mhwd -li
systemctl status bumblebeed
journalctl -b -g "bumbl\|bbswitch"
lsmod | grep nvidia

#28

This is normal, is the automount of my data partition, my user on this machine is “nemo”, sorry for the misunderstanding :wink:

Here the outputs:

mhwd -li

> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-intel-nvidia-bumblebee            2018.08.09               false            PCI


Warning: No installed USB configs!

systemctl status bumblebee

Unit bumblebee.service could not be found.

journalctl -b -g “bumbl|bbswitch” (your was a typo or not? In any case I’ve tested both bbswitch and bbswithch and the output is the same"

-- Logs begin at Tue 2018-12-04 20:19:32 CET, end at Thu 2018-12-06 07:32:15 CET. --
-- No entries --

last command no output at all.

Now I see that bumblebee is not set up or at least not working, and that catch me offguard because I was thinking that mhwd should handle the bumblebee config and setup during installation (haven’t made any change to that). Moreover I can run applications using optirun/primusrun without problem, isn’t that a bumblebee features or I’m mistaken? Sorry but I’ve not much knowledge about discrete graphics card and so forth.


#29

It’s not bumblebee.service, but

bumblebeed.service


#30

Gosh, what an idiot! Thanks I will try again this evening.


#31

Next time just copy/paste… the command was correct.:wink: (almost)


#32

Here the right output

systemctl status bumblebeed

● bumblebeed.service - Bumblebee C Daemon
   Loaded: loaded (/usr/lib/systemd/system/bumblebeed.service; enabled; vendor preset: disabled)
   Active: active (running) since Thu 2018-12-06 17:28:14 CET; 1h 3min ago
 Main PID: 543 (bumblebeed)
    Tasks: 1 (limit: 4915)
   Memory: 2.1M
   CGroup: /system.slice/bumblebeed.service
           └─543 /usr/bin/bumblebeed --use-syslog

dic 06 17:28:14 bering systemd[1]: Started Bumblebee C Daemon.
dic 06 17:28:15 bering bumblebeed[543]: /usr/bin/bumblebeed 3.2.1-2017-02-27-Format:%h$ started

#33

Plus this

journalctl -b -g "bumble\|bbswitch"

#34

Same result as before

-- Logs begin at Tue 2018-12-04 20:19:32 CET, end at Fri 2018-12-07 08:33:50 CET. --
-- No entries --


#35

Not possible! How wrong can I go with those commands?

journalctl -b -g bumblebee
journalctl -b -g bbswitch

#36

What’s here by the way?


#37

Will try this evening. Thanks.

Everything! I mean that right now is like your screen but I’ve tried all the combinations and I’ve got no noticeable change


#38

journalctl -b -g bumblebee

-- Logs begin at Tue 2018-12-04 20:19:32 CET, end at Fri 2018-12-07 18:38:19 CET. --
dic 07 17:36:12 bering systemd[1]: Started Bumblebee C Daemon.
dic 07 17:36:12 bering audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 msg='u>
dic 07 17:36:12 bering bumblebeed[548]: /usr/bin/bumblebeed 3.2.1-2017-02-27-Format:%h$ started

journalctl -b -g bbswitch

-- Logs begin at Tue 2018-12-04 20:19:32 CET, end at Fri 2018-12-07 18:38:07 CET. --
dic 07 17:36:12 bering kernel: bbswitch: version 0.8
dic 07 17:36:12 bering kernel: bbswitch: Found integrated VGA device 0000:00:02.0: \_SB_.PCI0.GF>
dic 07 17:36:12 bering kernel: bbswitch: Found discrete VGA device 0000:01:00.0: \_SB_.PCI0.PEG0>
dic 07 17:36:12 bering kernel: bbswitch: detected an Optimus _DSM function
dic 07 17:36:12 bering kernel: bbswitch: disabling discrete graphics
dic 07 17:36:12 bering kernel: bbswitch: Succesfully loaded. Discrete card 0000:01:00.0 is off


#39

Please use:

  • Animation speed very fast
  • Allow apps to block compositing No
  • Keep windows thumbs Never

#40

I don’t know if it’s only a placebo but seems better with this parameter.