kde glitch? (with konversation)

Yesterday I accidentally clicked the konversation app and ever since then it's acted like a startup program. Since I never use it I could probably just pacman -R konversation but wanted to report this weird behavior with the app before doing that. I'll wait to see replies before doing that. Oh and yes I looked the kde menu of startup programs it doesn't show there.

Depending on how you close it (I use File > Quit to really end it), it might still be running in the tray.

Alternatively, have you tried System Settings > Startup and Shutdown and in the Login section tried to Start with an empty session?

1 Like

I don't know what you mean by login section. The startup only was yakuke in it. (the kde drop down terminal)

Are you using a saved session?
[kde an other DE's can start with 'clean' or 'saved' sessions - like remembering what windows are open ... I dont use it... but some people do and it may be on and may be the reason]

Or is it possibly in ~/.config/autostart*?

In System Settings > Startup and Shutdown, you should see two panels:

  1. To the left, should be four selection choices
  2. To the right is the area where you change your defaults.

Pick the last item on the left (Desktop Session), then look to the right and the last item should say On Login. Select Start with an empty session.

Then re-boot.

That solved it but it doesn't explain why app added itself to the session even after it closed. (which the reason I reported this) I guess yakuke did the same thing but since it was terminal I didn't mind so maybe it's a fundamental behavior of kde) Also it seems to only be with K-suite apps because firefox doesn't act this way. It may start itself if I reboot while it's open but it doesn't boot regardless of that.

Update: I removed konversation from my system.