KDE-Edition: CUPS crashes Plasma

kde
plasma
cups
crash
#1

Hello there!

When I print a document Plasma Desktop crashes always. The infobar disappears and a right click on the desktop isn’t possible anymore. Switching between programs is still possible, Latte Dock is working, too.

This bug is already reported on the CUPS’s github page. apple/cups @ GitHub

Does anyone know a solution for that?

Cheers
THX-1138

Printer: Brother MFC-J870DW

System:
Operating System: Manjaro Linux
KDE Plasma Version: 5.15.3
KDE Frameworks Version: 5.56.0
Qt Version: 5.12.2
Kernel Version: 4.19.32-1-MANJARO
OS Type: 64-bit
Processors: 4 × Intel® Xeon® CPU E31225 @ 3.10GHz
Memory: 15,6 GiB

#2

When KDE Plasma crashes is usually related to the compositor, so, try this settings for it:

2 Likes
#3

If you’re using kvantum, see if the crash persists with the breeze widget style. If that’s the case you may consider updating to the latest kvantum version (AUR) or wait for the next update.

#4

@bogdancovaciu
Thanks for your idea, but unfortunately these settings make plasma crash on startup. I had to de-install manjaro-printer, cups and the printer driver to get plasma running again.

#5

@saedlar93
Thanks for your idea. I don’t have the breeze widget style and I cannot find it in pamac. I’ll try some other styles.

#6

Well, can we see the inxi -Fxxxz from your terminal? Copy it and paste it as text and use ``` above and bellow it for proper formatting.

#7

Here’s what solved the problem:

De- and re-install of manjaro-printer, cups and the printer driver
Using the compositor settings posted by bogdancovaciu, but tick the box “Allow applications to block compositing”.

Thank you