KDE Customizations - Randomly Reset To Factory Experience

Hey Everyone,

I’ve been using KDE Manjaro for about a year now. I had to boot into a Live USB last night to fix some partition issues, and restarted and everything was fine. I restarted again just now, and all my customizations are mostly gone (90%) and it looks like the factory / OOTB KDE experience. I wasn’t doing anything at the time…why would things randomly reset back to factory?

Confused and needing some help if anyone can offer some assistance. Thanks in advance!

Hi @A4orce84,

Did you delete something in.you home folder? Because, AFAIK, all user specific customization is stored somewhere in your home directory. I’m guessing exactly what it is, depends on you and how you configured everything.

Another option that it might be is ownership/file permissions.

And yet another cause could be an incompatible theme. :wink:

3 Likes

True. Just not something that was mentioned, so I didn’t think about it.

With @A4orce84 mentioning he did some work on a partition, I immediately thought of something file or -system related, not the theme. But yes, it could be that, or perhaps an extension…?

1 Like

@Aragorn - I haven’t touched my theme configs in over 6 months. Everything was working fine, and it just randomly started changing. I have not installed anything except “Strongswan / swanctl” package recently as I was trying to get some things with VPN working yesterday. That’s the last things I “touched” from a configuration standpoint. Last night I booted into my system using a Live USB, but to be clear, I did not actually change anything (sorry for confusion earlier). Just booted and restarted back into my main system basically.

@Mirdarthos - I do not have any special (hacked) themes or anything installed. However, your comment about looking in the HOME directory got me curious, and the only thing that was updated this morning was my /home/$USERNAME/.config directory.

Is there some type of system process / cron that runs daily possibly? Not sure what’s going on, but that is the only directory that I see when I do an ls -lhart command that shows up as being modified today.

Thanks guys!

Note:

This in only according to me and I might be wrong. If I am, someone plase correct me so that I know for future referende as well.


To make sure the ownership of the files are correct, in the terminal, run:

sudo chown -R <username>:<group> ~/*

Where <username> is replaced by your username, and <group> is replaced by your primary group. In my case it’d be:

sudo chown -R mirdarthos:mirdarthos ~/*

(The ~ is a built-in alias to the current users home directory.)

Then, to change the permissions, and I might be completely wrong here, run:

sudi chmod -r 0755 ~/

(This is the permissions of my ~/.config directory, so if that’s not correct, someone please correct it)


Also note:

If this is to work, the files shouldn’t have been deleted. If they were, These commands won’t help and to recover them you’ll need someone else’s help. Definitely not me.

I take it that you meant for that command to be recursive, but you definitely don’t want to chmod everything in your $HOME to 755. That would make every file executable. :wink:

Also, in order to do a recursive chmod, the option should be -R ─ uppercase ─ and in order to execute something with root privileges, we use sudo, not sudi. :laughing:

1 Like

I ran a version of the commands, no change. Is there a system process / cron that runs daily? I was literally sitting at my desktop when things started changing by themselves (no user intervention).

That’s rather site-specific, so why don’t you see for yourself? :wink:

System Settings → System Administration → Systemd

All of your timers should be listed there, under the tab by that name.

I always get confused with chmod's and chown's -r/ -R.

(Man, that was a lot of quotes on my tablet, sheesh!)

As for the permissions, that’s why I said I might be wrong and if so correct me.

Hey, I’m just pulling your leg, man. All is cool. :wink:

1 Like

Please just be careful with it.

It’s barely somewhat functional, after my knee replacement and whatnot. :wink:

1 Like

Screenshot of Timers:
Imgur

Nothing is jumping out at me unfortunately. Still confused why this happened.

Question:
More importantly, how do I “fix” this issue?

Well… That’s what backups are for… :man_shrugging:

Gollum_Backupses

Lolz did he forget to mention Backups?
I still have some cinnamon files from 2019 hanging around if you need them…
Seriously, if you’re not using BTRFS then you should have an RSYNC backup producing regular snapshots.

This month I did some extra messing - borked my system a couple of times and fixed it firstly by deleting a ton of stuff and then copying back some old .config files. The second time I was going out, so I set it to simply restore ‘yesterday’.

KDE is great, but there are lots of nooks… Create a new user to see if it’s your install or your home.

1 Like