KDE Connect not showing notifications anymore

Hi, right after the 20201230 Manjaro stable branch update, which came with kdeconnect, my desktop version of KDE Connect hasn’t been able to show any type of notifications anymore. I’m pretty sure the issue is not related to the Android version - it’s always worked fine, and I’ve tried to uninstall it after deleting data and reinstalling it, to no avail, and in addition to that the problems only started happening straight after I updated and rebooted the system.

I’m only posting now on the forum cause I have again updated Manjaro to the 20210119 stable release, which comes with kdeconnect, and this new package doesn’t fix whatever issue I had. I’ve tried reverting to the last working version,, but to my surprise this didn’t seem to fix the issue (every time I’ve also restarted my laptop and deleted my phone from trusted devices). So it’s gotta have to do with something else, considering no one else on the internet seems to have encountered this issue as of late.

What’s interesting is that kdeconnect correctly shows my phone’s battery percentage, is still able to cast the currently played media on my phone, send files etc. - basically, all functionality seems to work as expected, bar the notifications.

By the way, all settings (except for prevent screensaver) are turned on in the kdeconnect application, and I haven’t found anything wrong with the android app either. Is there any log or whatever I can send here that could help with troubleshooting? Thanks a lot in advance!

Just bumping this a lil bit (hoping it’s allowed, apologies if it’s not) :slight_smile:

Although I am assuming you already tried this, but could you check if notification access is given to KDE connect on your phone?
I had that issue once, had to re-enable access (on the phone).

Yeah, unfortunately I did already check this and the app is allowed notification access on Android.

Same thing here. The pop up notification appears but since it’s gone the notification doesn’t persist, doesn’t show anymore when opening kde connect

Hey, kdeconnect’s most recent update bundled in Manjaro’s stable branch seems to have fixed this for me! Just came today.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.