[KDE] Can´t add favorites to app starter menu

kde

#7

The user modified menu is stored under ~/.config/menus/.
Favorites on the other hand are stored in your ~/.config/plasma-org.kde.plasma.desktop-appletsrc file.

Kickoff uses a different entry for favorites than the other kicker based menus.
Kickoff uses “favorites”, [“systemsettings.desktop”]
Kicker uses “favoriteApps”, [“systemsettings.desktop”]

If this is not what the kickoff menu containment line looks like in your plasma-org.kde.plasma.desktop-appletsrc file, then I’d say it a bug and needs to be reported upstream. https://bugs.kde.org/


AdaptaBreath Theme WIP
#8

Ok the other menu style lost favorites too.

https://bugs.kde.org/show_bug.cgi?id=385814

Seems a bit similar but don´t know what´s wrong with my kmenu. Everything else works as expected


#9

I have a same issue btw. When I add favorite apps, it doesnt matter, on next login they are lost. I was not able to find the right solution, yet.


#10

I had several strange entries and folders in ~/.config/menus

Deleted whole folder content and now it seems to work. Will see tomorrow

New day new boot… and it works! So deleting all contents in ~/.config/menus seems to solve this


#11

Wow really annoying… it worked and a few restarts later not :frowning:


#12

Not working for me too. Only if you delete everything in menu. Or just something? I gave up on that. Favorites are empty. :unamused:


#13

I have fixed this problem recently.
Try to delete every files in ~/.local/share/kactivitymanagerd/resources/ and ~/.config/kactivitymanagerd-statsrc so KDE will try to regenerate those files again after reboot.

Note: these steps are optional, you can try it if the favorites are still empty after reboot
After reboot, change the application launcher to something else by right-clicking Kickoff icon -> Alternatives…
After changing them you should see the KDE default favorites are restored and you can add and remove things like it used to be.


KDE resets favorites on logout
[Stable Update] 2018-04-28 - Kernels, Cinnamon, Browsers, Mesa, KDE Apps, KDE Framework, Virtualbox
KDE Application Launcher/ Menu favorites panel always empty
Adding to favourites
#14

Fixed. Good job. Thank you! :+1:


#15

Many thanks ! It’s resolved for me too !


#16

Hi I have the same problem but how do I get to how to get to ~/.local/share/kactivitymanagerd/resources/


#17

open terminal and do
rm ~/.local/share/kactivitymanagerd/resources/*
little explanation:
rm is shell built in for deletion (mnemonic for remove)
* selects all files
~ is expanded by your shell into full path of your home directory (e.g. /home/yourusername)


#18

Well something is really wrong here. First it worked and now it´s happening again and couldn´t be resolved by deleting the files.

But now my kde menu editor is f***ed up too :frowning: Deleted several entries, saved and they came back again. Annoying…


#19

Same here. :confused:


#20

I tried deleting that, it didnt worked, still no favorites saved on the menu. I need this to work so I can be happy with kde again.

Edit: nevermind, it worked.


#21

The hint above does not work for me, but the description below.
However, I have not found the path ~/.config/kactivitymanagerd-statsrc on my system. It was enough to delete the files in ~/.local/share/kactivitymanagerd/resources/. After a restart I was able to recreate the favorites again.

This hint solved my problem!


#22

Did those deletions cause you then to lose your Activities?


#23

@kdemeoz: My main focus are the favorites, if the activities are missing I can not say. I have not checked and currently I am not sitting at my PC.


#24

Solved the problem. I had this problem earlier and it was annoying. Thanks!


#25

I had this issue as well. Thank you!


#26

I have delete only files in /.local/share/kactivitymanagerd/resources/

Thx