KDE broke on sudo pacman -syy

I was trying to install libimobiledevice but it didn’t work first try so I tried updating the repositories. I typed it as libimobiledevice. But now KDE won’t boot and sddm theme is now gone. Us there any way to fix this?

When I try to log in with my password it goes on a blank screen for a few seconds and returns back to sddm.
I tried to run inxi on tty but it doesn’t fit the whole screen.

Can you login in a tty (ctrl+alt+f3) and update all with sudo pacman -Syu?

Never ever do Sy only. Are you now fully up to date? Have you run pacman -Syu after that? If not it would be the first thing to do. From TTY.
Or boot from a live usb, chroot and provide info and update from there. You will probably need to reset the kde config now, but i will leave this to kde users to tell you the correct procedure.

Did it and rebooted. Nothing.

At least one similar or even identical topic already exists.
If one could search the forum for similar looking screenshots, it would be easy to find.
Alas: screenshots and the text in them is not searchable.
that is why they are seldom helpful

Look for the announcement thread re upgrading plasma / QT to version 6

reset your config to default and (temporarily) remove customizations

your config seems to refer to something that doesn’t exist anymore

it’s hard to read

pacman -Syy
is also not something that could have done that

1 Like

Please edit your topic title to be clear and concise about the problem. No, nothing was “bricked”. I do not think that word means what you think it means. Also, pacman -syy is not a valid command.

What package?

That’s not a word, let alone a verb.

Please also edit your post to include more information.

Please see:

Fixed the mistakes. What can I add? And Sudo Pacman -Syy worked for me.

Notice the difference? :wink:

Also, never use -yy and never use -y without -u. Anything else will put you in an unsupported upgrade state.

2 Likes

Is there anything I can do?

Yes, login and switch to a compatible SDDM theme. :wink:

1 Like

I can’t log in. KDE crashes on login without anything.
Gnome crashes with: A problem has occured and the system can’t recover.
There are timeshift backups if it can be used.

Fixed it with timeshift.

By the way installing gnome and kde on the same user profile is also a bad idea and will lead to troubles.

2 Likes