KDE black screen after login

Have created a new user and tried to log in as a the new user?

Yes. I did it same result. As far as I can tell after qt 5.14 rebuild of KDE package, some package/applet is broken. That is causing plasmashell to crash.

The bug report for kde is saying that the problem is from locale not being set properly.

sudo localectl set-locale LANG=en_US.UTF-8

Arch updated kwin and plasma-framework yesterday. Did that solve your problem?

Yes, that did fix it.

1 Like

Is anyone getting this in Manjaro? Login screen comes up just fine but after entering password, it just goes to black screen. Monitor is on, but black. I can drop to tty. I've looked at locale settings and they all seem to be set properly. I wasn't the one using the machine at the time, so I don't know what preceded the issue other than, "I was just using the internet." Is there a key combo in plasma that would cause this if hit accidentally? I've already tried all the function options. Switching between kernel 5.4 and 5.5 makes no difference.

Forum kindly sponsored by