KDE Ark crashes when clicking "Apply to All" when extracting

So since installing Ark 20.12 (?) whenever i go to extract something into a folder where a file with the same name exists and i get the overwrite dialog and i click “Apply to All” Ark crashes. I have tried downgrading and that doesnt seem to fix the issue, Afaik i am not using any kde-git packages. I have the latest testing packages for kde and etc.

I can’t reproduce it, try removing /home/edorta/.config/arkrc file.

Didnt work, i also tried removing the dolphinrc file which didnt do anything either.

Try disabling previews and services in dolphin. Maybe they are the origin of the fail.

Or look at journalctl,coredump, and ~/.local/share/sddm/xorg-session.log to find what is making the error.

Im looking at the journalctl, and its showing that ark or kio.widgets cant open the files for comparison. It seems to be some sort of Qt5 issue or something, its kindof unclear to me

I found this:

It seems be the same bug.

Whait for the next update.

Yea it looks generally to be the same issue, Hopefully itll reach Manjaro within the next week or so, clicking overwrite on a few thousand files takes a while.